Bug 174612

Summary: New Device Notifier option to only mount drive
Product: [Plasma] plasma4 Reporter: greatbunzinni
Component: widget-devicenotifierAssignee: Alexis MENARD <darktears31>
Status: RESOLVED DUPLICATE    
Severity: wishlist CC: aseigo, axel.kellermann, axel, Martin.Vala, me, moritz-kdebugs, PVince81, sasha2048, tcech, updatedb, vidakris, weber-jonathan
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Unspecified   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description greatbunzinni 2008-11-08 11:34:18 UTC
Version:            (using KDE 4.1.2)
Installed from:    Ubuntu Packages

At the moment the "New Device Notifier" widget only supports two types of operations: unmounting mounted drives and launching Dolphin after mounting an unmounted drive. Nonetheless, the ability to simply mount a drive and perform no extra follow-up action is very important.

It would be nice if the "New Device Notifier" widget offered a "mount drive" option without forcing the user to launch some application that the user doesn't need.
Comment 1 Aaron J. Seigo 2008-11-08 21:40:39 UTC
"the ability to simply mount a drive and perform no extra follow-up action is very important. "

how is it very important?
Comment 2 greatbunzinni 2008-11-09 16:20:51 UTC
The "very" was a bit of an exaggeration. Nonetheless, I regularly use a hand full of USB mass storage devices (external HD, flash drives, card reader) but I rarely use Dolphin on them. For example, I store my music collection on an external HD and when I wish to listen to music I simply plug it in, mount it and launch amarok. With KDE4 to be able to mount that drive I need to go through the command line or needlessly launch dolphin through the "New Device Notifier" widget, which is a bit of a hack. It would be nice if it was possible to simply mount that drive without being forced to launch some application that I will need to shut down immediately.
Comment 3 FiNeX 2008-11-16 23:18:47 UTC
*** Bug 170457 has been marked as a duplicate of this bug. ***
Comment 4 Krisztian Vida 2008-11-17 00:17:19 UTC
this feature would be also handy when working in konsole, opening Dolphin just for mounting a pendrive takes a lot of time :(
Comment 5 Sasha Unspecified 2009-02-20 17:52:27 UTC
I agree with the reporter. IMHO there should be more options than "Open in Dophin", there should be "(Just) mount", "Open with <other registered app>", etc. IMHO the best way for that is a context menu.
Comment 6 Dario Andres 2009-03-17 15:55:04 UTC
*** Bug 187366 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2009-03-17 15:55:17 UTC
*** Bug 185694 has been marked as a duplicate of this bug. ***
Comment 8 Alan Moore 2009-04-07 17:11:11 UTC
This is also useful if you want to work with Konqueror or any other file browser.  Also, an "unmount without ejecting" might be nice, even if hidden somewhat (right click menu?). 

If nothing else, it would be nice if users could just add actions of their own to perform on the device, through a config dialog.  This way the default setting could remain uncluttered, but power users could get the options they want.
Comment 9 Sasha Unspecified 2009-04-07 21:34:30 UTC
I agree
Comment 10 Dario Andres 2009-04-25 12:26:01 UTC
*** Bug 185262 has been marked as a duplicate of this bug. ***
Comment 11 FiNeX 2009-04-29 22:33:45 UTC
*** Bug 191046 has been marked as a duplicate of this bug. ***
Comment 12 Axel Kellermann 2009-05-27 21:01:05 UTC
I agree with the original poster. I use amaroK to manage my music collection and transfer songs to an iPod. Every time I attach the iPod, I have to open a Dolphin session to mount it. A button that just mounts the device would be really nice.

Just as a side node: i switched from Dolphin to Konquerer as my default file browser and the device notifier still shows the message 'Open with Dolphin'.
Comment 13 Axel Schwank 2009-06-07 12:45:02 UTC
*** This bug has been confirmed by popular vote. ***
Comment 14 Pino Toscano 2009-07-03 15:14:39 UTC
*** Bug 198783 has been marked as a duplicate of this bug. ***
Comment 15 Pino Toscano 2009-07-07 12:33:23 UTC
*** Bug 199273 has been marked as a duplicate of this bug. ***
Comment 16 Moritz Moeller-Herrmann 2009-08-05 21:59:05 UTC

*** This bug has been marked as a duplicate of bug 164053 ***
Comment 17 Sasha Unspecified 2009-08-13 00:16:47 UTC
Imho, it is not a duplicate of bug 164053.
Device Notifier should certainly have more actions than just "Open in dolphin" and "Unmount" (e.g. "Just mount", "Open in krusader", "Open in <some other app>", etc).
... independently on whether drives are automounted or not.