Bug 185262 - No possibility just to mount/unmount devices
Summary: No possibility just to mount/unmount devices
Status: RESOLVED DUPLICATE of bug 164053
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Unspecified
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-22 18:41 UTC by Axel Schwank
Modified: 2009-08-05 22:18 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Schwank 2009-02-22 18:41:14 UTC
Version:            (using KDE 4.2.0)
Installed from:    SuSE RPMs

KDE4 lacks the possibility just to mount devices (without opening it in Dolphin) or unmounting them (without ejecting).
The notifier widget only offers "open with Dolphin", then the device gets mounted; it's not mounted when you plug it.
Ok, that's a wish.
But in Konqueror's sysinfo:/ view, the device tooltip says "Right klick for further options like mounting or unmouting". But the context menu offers nothing like that.
I think that's a bug.
Comment 1 Dario Andres 2009-02-22 19:24:32 UTC
The "sysinfo:/" view is an OpenSUSE plugin (not supported in this bugtracker)
You can use the Kwikdisk/KDF application (in kdeutils) to list and mount/umount the partitions.
Comment 2 FiNeX 2009-02-23 22:20:09 UTC
@Dario: could be interesting develop a kdf-based plasmoid?
Comment 3 Dario Andres 2009-02-23 22:24:00 UTC
I don't have enought time currently, but it may be possible. However I'm not sure if that will be duplicating efforts, as there's already the Device Notifier widget, may be it can be expanded to show possible mount points too.
Comment 4 Axel Schwank 2009-02-25 17:10:07 UTC
I also think that the Device Notifier Widget is the right place for this, I even think it doesn't have to be expanded as it already shows the possible mount points, e.g. the devices that are plugged but not mounted.
It only lacks a possibility to actually mount these devices (without opening Dolphin).
Anyway, why don't the devices get mounted automtically? I think in KDE 4.1 they used to. The best solution of course would be to make this configurable in the system settings.
Thanks for your efforts.
Comment 5 smallpond 2009-04-24 13:17:43 UTC
Is this different from bug 175611
Comment 6 Dario Andres 2009-04-25 12:26:01 UTC
They are actually similar because the two want to get rid of Dolphin. But this report doesn't talk about AUTOmounting.
This is more like bug 174612
Thanks

*** This bug has been marked as a duplicate of bug 174612 ***
Comment 7 Moritz Moeller-Herrmann 2009-08-05 22:18:24 UTC

*** This bug has been marked as a duplicate of bug 164053 ***