Bug 94918 - no "System Notifications" (system sounds) after KDE 3.3.2 update
Summary: no "System Notifications" (system sounds) after KDE 3.3.2 update
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: knotify (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 189 votes (vote)
Target Milestone: ---
Assignee: Carsten Pfeiffer
URL:
Keywords:
: 97789 99610 104619 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-11 14:02 UTC by Jörg Hermsdorf
Modified: 2006-09-10 13:19 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jörg Hermsdorf 2004-12-11 14:02:08 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    SuSE RPMs

After updating KDE 3.3.1 to KDE 3.3.2 I hear no longer any System Notifications. Arts is running. amaroK, XMMS, Kaffeine... etc. play sound correctly using the arts engine. Even the "Test Sound" (Control Center > Sound & Multimedia > Sound System > General > Test Sound Button) is played.
But when I try to configure a certain System Notification (e.g. "KDE is starting up") and click the "Test the Sound" button no Sound is played.
I experience this problem on 4 different machines after the KDE 3.3.2 update. Searching Google and the SUSE mailing lists I found more people experiencing this problem, someone said it seems to be a piping problem...
Downgrade of the arts package, while ignoring the dependencies, fixes the problem.

System: SUSE 9.2
KDE: 3.3.2 SUSE packages
arts: 1.3.2-3

cu guys, Jörg.
Comment 1 Rudolf Kollien 2004-12-13 22:00:00 UTC
Same problem after same upgreade. Happens on SuSE 9.1 with KDE 3.3.2 too. But for me neither xmms with the arts-plugin nor xine works (xine got sig 11 but don't know if this is a arts related problem. Think no.). "Test Sound" in Control Center works. But nothing else. Downgraded to the original artsd from SuSE 9.2 did NOT resolve my problem. Sorry, haven't the RPMs immeditately to the update from 09. Dec. 2004.
Comment 2 Mark 2004-12-14 09:26:08 UTC
Ditto with the Suse 9.1 64 bit and 3.3.2, all other sounds work fine just the system notifications.
Comment 3 ps 2004-12-15 09:48:45 UTC
No sound works for me after installing SuSE 9.2 with KDE 3.3.2. Knotity ends with SIG 11, kdetv hangs after startup (different symtoms: close without message, black video screen). Shutting down the artsd will result in working kdetv. But no other sound application work.
Comment 4 Condor 2004-12-15 17:31:42 UTC
I have this problem too on Slackware 10 with KDE 3.3.1 and KDE 3.3.2
Comment 5 Jim Robertson 2004-12-15 20:01:22 UTC
I am also using SuSE 9.2 and after upgrading to KDE 3.3.2, the system notifications ceased working. It appears that KNotify does not start on start up or crashes while starting. Once logged into KDE, running kdeinit knotify from a console starts knotify and system sounds do work afterwards. On log-out, knotify crashes with a sig 11, if activated with kdeinit knotify.
Comment 6 arimar_te 2004-12-16 08:26:36 UTC
Same problem here after updating the new arts package five days ago! I am using SUSE 9.1
Comment 7 kdebugs 2004-12-19 11:11:26 UTC
According to http://linux-club.de/viewtopic.php?t=21388&postdays=0&postorder=asc&start=0 the problem is caused by arts
Comment 8 Jim Robertson 2004-12-19 12:42:17 UTC
I have successfully compiled an arts package that works, thanks to the steps mentioned in that forum. If you are interested, I have put a copy here: http://www.freewebs.com/sbsoftea/arts.htm . It might be a bit slow, but the package works.
Comment 9 Thiago Macieira 2004-12-19 14:55:10 UTC
There was a problem even in HEAD. Recompiling aRts fixed it.

I wonder if this is a duplicate of Bug #79924.
Comment 10 Jim Robertson 2004-12-19 15:58:37 UTC
I am certain this is not a bug, but just a problem that occured when SuSE compiled its RPM for KDE 3.3.2. It is not a duplicate of Bug #79924, as it is not an actual problem with the sound system, but a problem with knotify not starting.
Comment 11 Geoff Fitton 2004-12-27 17:20:31 UTC
I've also got the same "no sounds" problem after updating my two machines (SuSE 9.2) to KDE 3.3.2. 
Comment 12 Stephan Binner 2005-01-02 14:02:16 UTC

*** This bug has been marked as a duplicate of 69830 ***
Comment 13 John Griffiths 2005-01-15 23:42:17 UTC
This is not a duplicate of 69830. Use Arts is not set to false.

knotifyrc contains:
 [StartProgress]
  Arts Init=true
  KNotify Init=true
  Use Arts=true

xsession-errors collects the following error messages.

kbuildsycoca running...
DCOP Cleaning up dead connections.
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x8257260 ): KAccelobject already contains an action name "del" 
Comment 14 Stephan Binner 2005-01-17 23:11:53 UTC
Ok, let's reopen it.
Comment 15 Stephan Binner 2005-01-17 23:12:04 UTC
Ok, let's reopen it.
Comment 16 Gary Castro 2005-02-05 00:12:02 UTC
Same problem in SuSE 9.1 with KDE 3.2 upgraded to 3.3.2 on Dell P4
Comment 17 Jörg Hermsdorf 2005-02-05 03:50:06 UTC
This is no KDE bug... it occurs only on Suse systems. It seems that Suse 
messed something up when they compiled the arts package. You just need to 
recompile the Suse src.rpm that comes with KDE 3.3.2 and build your own arts 
package! (rpmbuild --rebuild arts*.src.rpm) Afterwards System Sounds should work fine again!
Comment 18 kdebugs 2005-02-05 03:55:17 UTC
Jörg: When everybody needs to rebuild - why are there Suse packages? Can somebody simply contact the maintainer, so only he has to rebuild.
Comment 19 alumpezdek 2005-02-05 03:57:59 UTC
It doesn't work on Slackware 10.0 either.  I did recompile arts.  I also 
tried the previous version of arts.  Still no luck.

Jörg Hermsdorf wrote:
> ------- You are receiving this mail because: -------
> You are a voter for the bug, or are watching someone who is.
>          
> http://bugs.kde.org/show_bug.cgi?id=94918         
> 
> 
> 
> 
> ------- Additional Comments From yojoe schneebrett com  2005-02-05 03:50 -------
> This is no KDE bug... it occurs only on Suse systems. It seems that Suse 
> messed something up when they compiled the arts package. You just need to 
> recompile the Suse src.rpm that comes with KDE 3.3.2 and build your own arts 
> package! (rpmbuild --rebuild arts*.src.rpm) Afterwards System Sounds should work fine again!
> 

Comment 20 Gael Beaudoin 2005-02-17 21:32:29 UTC
Same problem on gentoo using kde3.4beta2 :(
Comment 21 Rich Birch 2005-02-18 00:48:19 UTC
Same problem here on Gentoo using kde3.4beta1 &beta2. And also had the problem in at least the last couple of kde minor releases. I noticed loss of notification sounds sometime in the autumn.

I am not using arts btw. I have not compiled arts with the betas. If I turn on arts in the sound center (which must then use the kde3.3 arts) clicking on the test sound button produces sound but still nothing from notifications. I can't even get anything by pressing the play button in the notification settings dialog.

So just to confirm, this is NOT just a SUSE problem!
Comment 22 Rich Birch 2005-02-18 00:51:37 UTC
I'd just like to add that setting play as play as an external player makes no difference. play does work as I tested it in a console.
Comment 23 Stephan Binner 2005-02-18 08:20:23 UTC
*** Bug 99610 has been marked as a duplicate of this bug. ***
Comment 24 Stephan Binner 2005-02-18 08:37:30 UTC
*** Bug 97789 has been marked as a duplicate of this bug. ***
Comment 25 Tim Spargo 2005-02-20 14:16:50 UTC
Agreed this is *not* a SuSE-only issue. I am running Fedora core 3 and I have no sound whatsoever after recent upgrades (I don't know the kernel version where it started).

I also see signal 11 crashes in the KNotify when I click on auto-detect (hardware) in the KDE control center. Similar (but different) to a previous post, here is what I see in the stderr. Seems like some memory leaks perhaps. Thx.

warning: leaving MCOP Dispatcher and still 1 object references alive.
KCrash: Application 'knotify' crashing...
warning: leaving MCOP Dispatcher and still 13 object references alive.
  - Arts::SampleStorage
  - Arts::Synth_MULTI_ADD
  - Arts::Synth_MULTI_ADD
  - Arts::Synth_MULTI_ADD
  - Arts::Synth_MULTI_ADD
  - Arts::Synth_RECORD
  - Arts::Synth_BUS_UPLINK
  - Arts::Synth_PLAY
  - Arts::StereoVolumeControl
  - Arts::StereoEffectStack
  - Arts::Synth_BUS_DOWNLINK
  - Arts::SoundServerV2
  - Arts::MidiManager
warning: leaving MCOP Dispatcher and still 75 types alive.
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
ALSA lib pcm_hw.c:549:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
Comment 26 campo23 2005-03-02 12:26:45 UTC
Same problem with arts-1.4.0 in Suse 9.2 and kde-3.4.9-rc1.
If I downgrade to arts-1.3.2 recompiled using original spec file, it works fine.

Regards
Comment 27 campo23 2005-03-02 14:16:13 UTC
Update:
It works again with arts-1.4.0 & KDE-3.4.0-rc1 & SuSE 9.2 if I execute:
"kdeinit knotify" in a console window. 

Regards
Comment 28 nah 2005-03-02 19:46:08 UTC
i have suse 9.2 
i had the problem with arts 1.3.2 / KDE 3.3.2 -compiling from the src.rpm helped
recently i updated to KDE 3.4 rc1 ..and this time i compiled arts-1.4.0 from the source and installed over the rpm installation ("./configure --prefix=/opt/kde3" > "make" > "make install")..which made sounds work again
Comment 29 miroslaw holubek 2005-03-03 22:41:38 UTC
Same problem on gentoo using kde3.4_rc1. It worked on kde3.4beta2.
Comment 30 Gerrit Jan 2005-03-16 13:53:19 UTC
Still no systemsound ???
Just update to KDE 3.4.0-12.
This is the stable release,now on ftp.
Use SuSE 9.2
Comment 31 Rich Birch 2005-03-16 14:18:56 UTC
I'm running 3.4rc1 on gentoo and still have the problem. Typing 'kdeinit knotify' makes no difference. Also makes no difference whether arts is installed or not.
Comment 32 nah 2005-03-16 17:30:21 UTC
i just updated from 3.4_rc1 to kde 3.4 .. ad guess what.. the system sounds are gone again ;P 
/me compiles arts-1.4.0-0.src.rpm at the moment
Comment 33 Rich Birch 2005-03-17 13:58:06 UTC
I'm wondering if i've been mistaken here. Is arts support required for kde apps to be able to produce sound? I've turned off arts (--without-arts) in everything, and I don't even have arts installed.

Was I wrong in thinking that kde sounds could function without arts?
Comment 34 John Griffiths 2005-03-17 23:03:04 UTC
Updated to KDE 3.4.0-12 from SuSE on 9.2 and still no System Notifications sounds. The sound system works for everything else but System Notifications.
Comment 35 david powell 2005-03-18 17:24:18 UTC
i just updated to 3.4.0 from suse ftp

and have also lost some system notifications 
the sound system otherwise works ok 
but interestingly i found some system notifications are working but not others

kmail , and konversation notifications are working 
but no mater what i try notifications from kde window manager do not work
nor does the option to execute program as notification for this application 

it would point to being a bug in the windowmanager not in arts etc in my case 
so although i have generally the same bug it may not be the same bug 

also i had to use "kdeinit knotify" to start knotifications as i noticed its process was not running on the process list
Comment 36 Thiago Macieira 2005-03-18 18:48:52 UTC
aRts is still the default KDE sound server and will continue to be so until a new one is selected for KDE 4. Not before.

You disable it at your own risk of not having sounds in KDE. Some applications -- multimedia ones especially -- have support for other sound backends. The same is true for KNotify. But not all apps can do that.
Comment 37 Rich Birch 2005-03-19 11:56:03 UTC
Ok, I knew arts is the default sound server, but I was under the impression that sounds would work without it since the option to change kde event sounds still exists when arts is not enabled at compile time.

I have just recompiled kdelibs with arts support and sounds are now working on my system! Hurray!

But leads me to ask why the options to edit/play event sounds are still present/enabled when kde itself is not able to produce any sounds. Maybe this isn't worth bothering with since arts is likely to disappear with 4.0?
Comment 38 david powell 2005-03-19 15:47:37 UTC
ok with reference to my previous post here #35 
is there any way of adding "kdeinit knotify" to kde startup as i have to manualy run it each time i login

i think that if this process is started before kde window manager i may get sounds from it also 

i beleve that it is working normaly otherwise it appears that it may not be enabled in the startup but i do not know  where to look to check this

as i suspect it may be configured to start i have been unable to find any error message giving a reason why it my of failed to load 

maybe its trying to start knotify before arts or something 
where would have to look to check this
Comment 39 R.F. Pels 2005-03-19 18:33:48 UTC
If you remove the LD_BIND_NOW=true clause before kdeinit +kcminit the problem goes away:

Change

   LD_BIND_NOW=true kdeinit +kcminit

into

   kdeinit +kcminit
Comment 40 John Griffiths 2005-03-19 18:57:38 UTC
Yes, but you don't have to drop out LD_BIND_NOW=true.

Edit /opt/kde3/bin/startkde so that the line

    LD_BIND_NOW=true kdeinit +kcminit

is two lines

    LD_BIND_NOW=true
    kdeinit +kcminit

Which I think maintains the intent of the use of LD_BIND_NOW so, according to the comment "We set LD_BIND_NOW to increase the efficiency of kdeinit." we increase the efficiency.

With this simple edit System Notifications now work.
Comment 41 R.F. Pels 2005-03-19 19:19:37 UTC
Would it be too much to ask to patch startkde according to the remark of John, please? I realize it seems to be a SuSE only bug, but.... 
Comment 42 Maksim Orlovich 2005-03-19 20:59:21 UTC
That change is incorrect, and will hurt the performance. However, this indicates something about the nature of the problem --- well, mostly that it is nasty and subtle
Comment 43 david powell 2005-03-19 21:21:06 UTC
knotifications here work ok with fix on comment #40
Comment 44 R.F. Pels 2005-03-19 21:36:59 UTC
Same here
Comment 45 Thiago Macieira 2005-03-19 23:01:26 UTC
The solutions in comments #39 and #40 are the same.
Comment 46 david powell 2005-03-19 23:21:07 UTC
may be so , but it helps to know what file to change it in 

thanks both for help 
Comment 47 Condor 2005-03-20 11:45:41 UTC
This solution does not work on Slackware 10.1 with kde 3.4
Comment 48 Gerrit Jan 2005-03-20 12:29:22 UTC
fix on comment #40 works for me on suse 9.2
Comment 49 Winfried Dobbe 2005-03-20 13:08:17 UTC
Yep, comment #40 fixes problem for me as well, suse 9.2, KDE 3.4
Comment 50 Verdi March 2005-03-26 07:15:16 UTC
Comment 40 works, but artsd will consume lots of CPU cycle.
On my laptop (PIII), it's about 40%
Comment 51 James Ots 2005-03-27 19:03:07 UTC
You may want to look at Bug #61438 to see if that is the problem.
Comment 52 Condor 2005-03-27 21:46:18 UTC
Thanks, solutions in Bug #61438 fix the problem with start sound in kde but does not resolve problem with kcontrol->sound & multimedia ->sound system->test sound && test midi.
 
Comment 53 Geoff Fitton 2005-04-02 00:24:21 UTC
I've updated KDE to 3.4.0-12 from 3.2.2 SuSE 9.2, and there are still no System Notifications sounds. However comment 40 works, & the Notification sounds are back. 
 
Comment 54 Olivier Goffart 2005-05-16 18:54:33 UTC
*** Bug 104619 has been marked as a duplicate of this bug. ***
Comment 55 Christopher Neufeld 2005-05-16 23:16:34 UTC
The change suggested in comment 40 did not have any effect in my setup (non-distribution, compiled from sources).

Not all notifications fail.  In the control center, I can test them one by one.  Kbattleship doesn't work, neither does KWordQuiz or Kopete.  KDE system notifications works, so does Ksirc, Keyboard status, Konsole, Tea cooker, and KDE window manager.
Comment 56 Gabriel M. Beddingfield 2005-05-20 06:05:05 UTC
Try:
$ rm ~/.kde/share/config/knotify*
Then restart X.
Do Notifications return?
Comment 57 Christopher Neufeld 2005-05-20 16:02:25 UTC
Yes, the solution suggested in comment 56 solved the problem for me.  Comparing the old versions of those files with their values regenerated in the configuration manager, the following things appear different:

knotify.eventsrc has added a "Trash: emptied" field, and many configuration fields have changed from "presentation=3" to "presentation=2".

knotifyrc no longer has the lines prefixed with '-' below:
 [Misc]
-External player=
 LastConfiguredApp=KDE System Notifications
-Use external player=false
-Volume=31
Comment 58 John Griffiths 2005-05-21 21:33:32 UTC
I still do not get system notifications unless /opt/kde3/bin/startkde is edited like in comments 39 or 40.
Comment 59 Jörg Hermsdorf 2006-09-10 13:19:33 UTC
It's a long time ago since I reported this bug... I'm running KDE 3.5.4 now and this bug seems not to be present anymore. I think we can close it, ok?!