Bug 61438 - sound for system notification doesn't work if paramter of volume doesn't be at max
Summary: sound for system notification doesn't work if paramter of volume doesn't be a...
Status: RESOLVED FIXED
Alias: None
Product: kcontrol
Classification: Unclassified
Component: kcmknotify (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Daniel Molkentin
URL:
Keywords:
: 99931 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-07-19 23:11 UTC by Patrick Rutka
Modified: 2005-06-01 16:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Mentioned patch (1.25 KB, patch)
2005-05-27 11:03 UTC, Thomas Schwarzgruber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Rutka 2003-07-19 23:11:17 UTC
Version:            (using KDE KDE 3.1.2)
Installed from:    Unspecified Linux

sound for system notification doesn't work if paramter of volume doesn't be at max. It's only work when the volume paramater in the kcontrol module is a t max...  small bug .. ;-)
Comment 1 Daniel Molkentin 2003-10-27 15:48:16 UTC
Works just fine here and for others I asked. Might be a problem with your hardware or a distribution issue.
Comment 2 Marcin Gil 2005-03-02 20:03:59 UTC
I can confirm the bug in 3.4rc1. This has been confirmed by another user in
this Gentoo Forum thread : http://forums.gentoo.org/viewtopic-t-302625.html.

My hardware: Audigy Gamer (emu10k1)
Comment 3 Joonas Koivunen 2005-03-17 14:20:51 UTC
Doesn't work either for less than two days old CVS!

My sound output is through alsa drivers for via on-board chip..
Comment 4 James Ots 2005-03-21 10:53:56 UTC
I am seeing the same behaviour on KDE 3.4, SuSE RPMs.

Just to make it clearer: The volume that must be set to 100% is the one in the Player Settings dialog in the System Notifications control centre module.

Could someone with a thicker skin than I reopen this bug?
Comment 5 Hugo Costelha 2005-03-21 13:14:23 UTC
Same here, also using SuSE RPMs and KDE 3.4. I even recompiled arts, but to no avail.
Comment 6 John C Borkowski III 2005-03-23 16:22:08 UTC
Same here on Gentoo... see above mentioned thread.
Comment 7 Alexander Malashenko 2005-03-26 23:54:20 UTC
I have the same problem with any volume. There are only sounds for k3b!
I recompiled the all KDE packages myself from the source on FC3. 
Comment 8 James Ots 2005-03-27 18:59:12 UTC
*** Bug 99931 has been marked as a duplicate of this bug. ***
Comment 9 James Ots 2005-03-27 19:01:41 UTC
Ok, I can see enough evidence that this bug still exists - reopening.
Comment 10 Thomas Schwarzgruber 2005-05-23 16:09:49 UTC
*** This bug has been confirmed by popular vote. ***
Comment 11 Thomas Schwarzgruber 2005-05-27 11:02:45 UTC
Hello !

I looked into the code segment in kdelibs/arts/knotify/knotify.cpp which connects the soundsource to a volume control if volume != 100%. I compared it with similar code in juk/alsaplayer, changed knotify.cpp to look similar than that and - voila! - it works ! (at least for me). I will attach a patch (it will apply for 3.4-branch and trunk).

Please test it, and if it's okay, commit it. (IMHO it should be commited in branch and trunk as well).

thx,
Thomas Schwarzgruber
Comment 12 Thomas Schwarzgruber 2005-05-27 11:03:48 UTC
Created attachment 11212 [details]
Mentioned patch

I created it with svn diff.
Comment 13 Matthias Kretz 2005-06-01 16:22:30 UTC
SVN commit 420839 by mkretz:

BUG: 61438
apply proposed patch that removes the _node.start/stop calls which
seem not to be needed at this point (my aRts knowledge is fading :-( )


 M  +0 -2      knotify.cpp  


--- trunk/KDE/kdelibs/arts/knotify/knotify.cpp #420838:420839
@@ -479,13 +479,11 @@
                 volumeControl.scaleFactor( d->volume/100.0 );
 
                 ap.stop();
-                player._node()->stop();
                 Arts::disconnect( player, "left", ap, "left" );
                 Arts::disconnect( player, "right", ap, "right" );
 
                 ap.start();
                 volumeControl.start();
-                player._node()->start();
 
                 Arts::connect(player,"left",volumeControl,"inleft");
                 Arts::connect(player,"right",volumeControl,"inright");
Comment 14 Matthias Kretz 2005-06-01 16:28:21 UTC
SVN commit 420841 by mkretz:

backport to 3.4 branch
CCBUG: 61438
apply proposed patch that removes the _node.start/stop calls which
seem not to be needed at this point (my aRts knowledge is fading :-( )



 M  +0 -2      knotify.cpp  


--- branches/KDE/3.4/kdelibs/arts/knotify/knotify.cpp #420840:420841
@@ -479,13 +479,11 @@
                 volumeControl.scaleFactor( d->volume/100.0 );
 
                 ap.stop();
-                player._node()->stop();
                 Arts::disconnect( player, "left", ap, "left" );
                 Arts::disconnect( player, "right", ap, "right" );
 
                 ap.start();
                 volumeControl.start();
-                player._node()->start();
 
                 Arts::connect(player,"left",volumeControl,"inleft");
                 Arts::connect(player,"right",volumeControl,"inright");