Bug 91640 - report playlist size in bytes
Summary: report playlist size in bytes
Status: CLOSED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Playlist (show other bugs)
Version: 2.3-GIT
Platform: unspecified Linux
: NOR wishlist with 112 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 97689 148384 149199 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-10-19 04:06 UTC by Andrew Barr
Modified: 2018-03-26 10:40 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Barr 2004-10-19 04:06:38 UTC
Version:           1.1.1 (using KDE KDE 3.3.0)
Compiler:          GCC 3.3.3 Gentoo release 3.3.3-r6
OS:                Linux

Another feature that would help portable player users (see bug #91639 for my other request) would be reporting the size of compiled playlists in kilo/mega/giga bytes. This helps when making playlist decisions with limited storage space.

BTW, I never thought I'd see the day when there was an open-source application _better_ than Windows Media Player (or anything else, for that matter), but once again I've been proved wrong. Great work guys!
Comment 1 Sami Nieminen 2005-01-29 19:59:51 UTC
*** Bug 97689 has been marked as a duplicate of this bug. ***
Comment 2 Iñaki Baz Castillo 2005-01-29 20:51:21 UTC
I copy the songs from amaroK playlist to the USB MP3 player, so I need to know the size in MB of the selected tracks, because the memory of my USB MP3 player is 512MB.
I think this may be a usable feature.
Comment 3 Fabio 2006-01-02 15:40:31 UTC
I create my mp3 CD/DVD data from amarok. I think this may be a good feature to burning CD/DVD with different size: CD 210MB, CD 650MB, CD 700MB, DVD 4.7GB, DVD-DL 8,5GB, ecc.
Comment 4 Iñaki Baz Castillo 2006-01-02 16:07:15 UTC
Unfortunallety this wish of 2004-10-19 is still UNCONFIRMED.
Comment 5 Mark Kretschmann 2006-01-02 16:12:58 UTC
We don't usually confirm wishes.
Comment 6 Iñaki Baz Castillo 2006-01-02 16:16:16 UTC
Ok, I didn't know it.
Comment 7 Ludovico Intravaia 2006-01-03 19:46:17 UTC
*** This bug has been confirmed by popular vote. ***
Comment 8 Fabio 2006-01-04 08:50:19 UTC
I think that would be a good idea to put the playlist size in bytes near the play list time and number of tracks.
i.e.:
124 Track   1:20   84Mb
Comment 9 Fabio 2006-01-04 08:50:57 UTC
I think that would be a good idea to put the playlist size in bytes near the play list time and number of tracks.
i.e.:
124 Track   1:20   570Mb
Comment 10 Kevin Funk 2007-02-17 15:43:11 UTC
Another thought: Report the playlist size or the size of selected songs in a tooltip when hovering playlist time.
Something like: "Size of selected songs: 20 MB; overall size: 50MB"
Comment 11 Janet 2007-05-18 00:22:47 UTC
Really would be great if that would be implemented. By now I always have to use  my desktop calculator to manually sum up the filesize column of amarok's playlist when I collect songs in a playlist for burning an mp3 CD.
Comment 12 Kevin Funk 2007-07-31 10:12:57 UTC
*** Bug 148384 has been marked as a duplicate of this bug. ***
Comment 13 Kevin Funk 2007-08-25 17:39:32 UTC
*** Bug 149199 has been marked as a duplicate of this bug. ***
Comment 14 richlv 2007-08-28 16:56:57 UTC
i just wanted to add that, according to svn log, jefferai is working on this for amarok 2.0 ;)
Comment 15 Jeff Mitchell 2007-08-28 17:04:51 UTC
Yep, I started some preliminary work on a Plasma applet for the Context View that would have (at the beginning) total tracks, total time, and total size -- for the Playlist that is, not for random playlists in the playlist browser (just to be clear).  I'm not sure if file size is gathered by our collection scanner but if not it could definitely make sense to add it.  Anyways I'm having trouble running anything in the context browser right now but once I get that figured out...
Comment 16 shattered 2007-08-31 20:32:18 UTC
bug 144041 is related.
Comment 17 Dan Meltzer 2007-11-14 23:15:10 UTC
Bumping version to 2.0 to help filter, especially as it seems to have recieved some attention.
Comment 18 Jeff Mitchell 2008-07-27 17:19:33 UTC
I got pinged by Hydrogen so I guess I should update.  I stopped working on the context view applet for a long time while the various A2 frameworks matured, it just wasn't ready yet.  Another issue is that since you can add internet sources for which the file size might not be available, I'm not sure how to properly calculate size in all scenarios.
Comment 19 Janet 2008-07-28 03:40:16 UTC
Just calculate size for local files and ignore internet sources.
Comment 20 Lydia Pintscher 2008-07-28 09:42:47 UTC
Well you could have good reasons to have internet sources in your playlist.
And if you don't consider them when calculating the size you may as well not do it at all since it is going to be inaccurate and useless.
Comment 21 Nigel Stewart 2008-07-28 17:32:27 UTC
I don't agree that it would be a useless feature without supporting internet streams.

A couple of use cases:
- Browsing collection and assembling a playlist to burn to CD (car mp3 CD player), need to know how much space remains available.

- Assembling a playlist for a limited capacity device such as a micro-SD memory card in a cell phone.

All in all I'd rather be able to use Amarok for this task than relying on K3B, since searching, browsing and sampling all works so nicely in Amarok.
Comment 22 Lydia Pintscher 2008-07-28 18:36:09 UTC
Nigel: I wasn't implying that the feature itself is useless. I was just saying that we need to find a good way to work with internet sources. Simply ignoring them is not a good idea. You could have a playlist with 10 local tracks and 5 from an Ampache server. If you only take the 10 local tracks into account it is going to be wrong. You could very well load those 5 tracks from Ampache on your mp3 player or burn it to a CD. The actual size would be about 1.5 times the size that would get reported if you only take local tracks into account.
Comment 23 Mark Kretschmann 2008-07-28 18:39:45 UTC
@Nigel: you have to take into account that Amarok 2 is much more about integrating internet sources seemlessly.

It's perfectly common in Amarok 2 to have one playlist composed of local tracks, Ampache media, and Mp3Tunes - at the same time.
Comment 24 Nigel Stewart 2008-07-28 19:07:59 UTC
MM streams and XX Mb in NN files.

Internet sources would be good to count too, but prevent having a useful feature sooner, rather than later or never.
Comment 25 Kevin Funk 2009-09-28 23:45:41 UTC
commit 42b8b3d8950857260f86910fa95e068bc7e75b4c
Author: Kevin Funk <krf@electrostorm.net>
Date:   Fri Sep 18 13:00:45 2009 +0200

    Show total size of the playlist in the statusbar.
    BUG: 91640
Comment 26 Kevin Funk 2009-09-28 23:47:10 UTC
Not tested for ampache tracks (yet).
Maybe I am going to put that info in a tooltip, not sure yet either.
Comment 27 Kevin Funk 2009-09-29 00:47:34 UTC
commit 24c6c6a91f299bc665384c027d5411391faa219c
Author: Kevin Funk <krf@electrostorm.net>
Date:   Tue Sep 29 00:26:09 2009 +0200

    Show total playlist size in a tooltip when hovering total playlist time.
Comment 28 Myriam Schweingruber 2018-03-26 10:03:26 UTC
@Gregor: please do not change status of outdated bugs that are already in RESOVED state, it is a total waste of time to mark them as CLOSED, especially if those relate to extremely outdated versions :-) We do not use the CLOSED marker in our bugtracker

FWIW: this particular bug is resolved since over 8 years!
Comment 29 Gregor Mi 2018-03-26 10:40:13 UTC
(In reply to Myriam Schweingruber from comment #28)
> @Gregor: please do not change status of outdated bugs that are already in
> RESOVED state, it is a total waste of time to mark them as CLOSED,
> especially if those relate to extremely outdated versions :-) We do not use
> the CLOSED marker in our bugtracker

Thanks for the hint. Sorry, I didn't know until yesterday that the CLOSED status is not used here.