Bug 144041 - iPod database may be truncated if a playlist is too big to fit on iPod
Summary: iPod database may be truncated if a playlist is too big to fit on iPod
Status: RESOLVED NOT A BUG
Alias: None
Product: amarok
Classification: Applications
Component: Collections/iPod iPhone (show other bugs)
Version: 1.4.5
Platform: NetBSD pkgsrc NetBSD
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-10 19:22 UTC by shattered
Modified: 2011-12-20 11:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shattered 2007-04-10 19:22:02 UTC
Version:           1.4.5 (using KDE KDE 3.5.6)
Installed from:    NetBSD pkgsrc
Compiler:          gcc version 4.1.2 20061021 prerelease (NetBSD nb3 20061125) 
OS:                NetBSD

bug 114238 was closed as WONTFIX, but it's still there in 1.4.5.  Except when free space reaches 0, amaroK cannot write the iTunesDB at all.

------- Additional Comment #5 From madman  2007-03-18 21:57 ------- 
Upon reaching end of Shuffle's (1stGen) free space, amarok throws a bunch of popup messages about transfer error (IMHO it should cancel further transfers when out-of-disk-space occurs), then consumes 100% CPU for a few minutes and returns to normal state.
Comment 1 elder 2007-08-10 15:42:05 UTC
the same happened w/ me w/ ipod video 5th gen and the latest versions of amarok and kde... there should be a massage like "memory full"... all those popups are really annoying... 
Comment 2 Jeff Mitchell 2007-08-31 21:25:25 UTC
What's the problem here?  Popups or the iTunesDB?  Does the DB get corrupted?  Does it just not get written? 
Comment 3 shattered 2007-08-31 21:46:45 UTC
Popups are the problem because there are tons of them (one popup for each track that could not be written), they are spawned very fast, and they cover the "cancel transfer" button.

iTunesDB is the problem too -- it is truncated to 0.
Comment 4 Jeff Mitchell 2007-08-31 23:05:23 UTC
I don't know too much about this, and I don't have an iPod to test.  But as far as the truncation, that's probably a libgpod issue, as we're using all libgpod calls.  I would bring this issue up with them.
Comment 5 shattered 2007-09-01 08:55:08 UTC
Well, how about zillion popups, then? :-)

I think you can simulate an ipod -- all you really need is a block device with FAT filesystem.
Comment 6 Jeff Mitchell 2007-09-01 19:49:28 UTC
Zillion popups would be a different bug.  Someone already filed one about that.  Keep separate bug issues in separate reports, please :-)
Comment 7 Bram Schoenmakers 2008-06-15 19:53:37 UTC
Closing this bug. This is most likely a libgpod issue (which is most likely solved by now). There is a separate bug for the popups, but unfortunately I don't have the bug number at hand right now.