Bug 91639 - transfer playlists to directory
Summary: transfer playlists to directory
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Collections/Media Devices (show other bugs)
Version: 1.1.1
Platform: Gentoo Packages Linux
: NOR wishlist with 44 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 92931 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-10-19 04:01 UTC by Andrew Barr
Modified: 2006-08-22 09:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Barr 2004-10-19 04:01:51 UTC
Version:           1.1.1 (using KDE KDE 3.3.0)
Installed from:    Gentoo Packages
Compiler:          GCC 3.3.3 Gentoo release 3.3.3-r6
OS:                Linux

It would be nice if one could transfer playlists compiled to a directory on the file system. The most obvious application of this I can think of is for users of USB or IEEE1394 mass storage portable players.
Comment 1 Seb Ruiz 2004-11-10 13:11:34 UTC
*** Bug 92931 has been marked as a duplicate of this bug. ***
Comment 2 Andrew Barr 2004-11-10 17:13:20 UTC
Bug 92931 is more general than this: The reporter requests mp3 player support. Copying to a mountpoint will work for mass-storage players or a flashcard reader/writer (such as what I have), but many higher-end hard-disk-based players do not support this (with the notable exception of the Apple iPod, which I believe is an IEEE1394 SBP2 device). They usually have a proprietary protocol which allows for syncing playlists and remote control of the device. I considered buying a Dell Digital DJ this summer, and researched it's Linux compatibility. It is a clone of the Creative Nomad, and libnjb facilitates devlopment of compatible applications: http://libnjb.sourceforge.net/. Maybe a plugin-based architecture would work: you could have a plugin for mountable players, a plugin for libnjb, and the possibility to write additional plugins for different protcols as documentation and/or code becomes available.
Comment 3 Martin Aumueller 2006-08-22 09:42:21 UTC
There is now a plugin based architecture for handling portable players.
These plugins offer the requested feature if appropriate for the device in question.