Bug 446157 - system setting bug
Summary: system setting bug
Status: RESOLVED DUPLICATE of bug 437455
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.22.5
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-27 09:09 UTC by sepantamortazavi
Modified: 2021-11-28 21:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (3.65 KB, text/plain)
2021-11-28 20:04 UTC, sasuske
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sepantamortazavi 2021-11-27 09:09:36 UTC
Application: systemsettings5 (5.22.5)

Qt Version: 5.15.2
Frameworks Version: 5.85.0
Operating System: Linux 5.14.17-201.fc34.x86_64 x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.5
Distribution: "Fedora release 34 (Thirty Four)"

-- Information about the crash:
- What I was doing when the application crashed:
i was increasing the number of virtual desktops 
the app was laggy and so slow 
then i wanted to apply , it crashed

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f1bc67216a4 in QWaylandClientExtensionPrivate::handleRegistryGlobal(void*, wl_registry*, unsigned int, QString const&, unsigned int) () from /lib64/libQt5WaylandClient.so.5
#5  0x00007f1bc670e1b9 in QtWaylandClient::QWaylandDisplay::registry_global(unsigned int, QString const&, unsigned int) () from /lib64/libQt5WaylandClient.so.5
#6  0x00007f1bc672aaf3 in QtWayland::wl_registry::handle_global(void*, wl_registry*, unsigned int, char const*, unsigned int) () from /lib64/libQt5WaylandClient.so.5
#7  0x00007f1bc3fd9c04 in ffi_call_unix64 () from /lib64/libffi.so.6
#8  0x00007f1bc3fd9107 in ffi_call () from /lib64/libffi.so.6
#9  0x00007f1bc667bd10 in wl_closure_invoke.constprop () from /lib64/libwayland-client.so.0
#10 0x00007f1bc667c42b in dispatch_event.isra () from /lib64/libwayland-client.so.0
#11 0x00007f1bc667c61c in wl_display_dispatch_queue_pending () from /lib64/libwayland-client.so.0
#12 0x00007f1bc67066a3 in QtWaylandClient::QWaylandDisplay::flushRequests() () from /lib64/libQt5WaylandClient.so.5
#13 0x00007f1bc8d243f0 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#14 0x00007f1bc8d26b4a in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () from /lib64/libQt5Core.so.5
#15 0x00007f1bc8d27363 in QSocketNotifier::event(QEvent*) () from /lib64/libQt5Core.so.5
#16 0x00007f1bc98c3443 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#17 0x00007f1bc8cf0798 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#18 0x00007f1bc8d425ff in socketNotifierSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#19 0x00007f1bc6a784cf in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#20 0x00007f1bc6acc4f8 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#21 0x00007f1bc6a75c03 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#22 0x00007f1bc8d41b78 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#23 0x00007f1bc8cef1a2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#24 0x00007f1bc8cf76e4 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#25 0x0000564ce51e258c in main ()
[Inferior 1 (process 5379) detached]

Possible duplicates by query: bug 445384, bug 445359, bug 445166, bug 445150, bug 445122.

Reported using DrKonqi
Comment 1 sasuske 2021-11-28 20:04:06 UTC
Created attachment 144046 [details]
New crash information added by DrKonqi

systemsettings5 (5.22.5) using Qt 5.15.2

- What I was doing when the application crashed: estaba colocando las opciones a los  bordes de pantalla cuando se cerro de forma inesperada

- Unusual behavior I noticed: estoy usanso el sistema en modo wyland tal vez sea por eso que se ocaciono

- Custom settings of the application:

-- Backtrace (Reduced):
#4  0x00007fd5b49fd964 in QWaylandClientExtensionPrivate::handleRegistryGlobal(void*, wl_registry*, unsigned int, QString const&, unsigned int) () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
#5  0x00007fd5b49e2ac9 in QtWaylandClient::QWaylandDisplay::registry_global(unsigned int, QString const&, unsigned int) () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
#6  0x00007fd5b4a08526 in QtWayland::wl_registry::handle_global(void*, wl_registry*, unsigned int, char const*, unsigned int) () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
[...]
#11 0x00007fd5b495e33c in wl_display_dispatch_queue_pending () from /lib/x86_64-linux-gnu/libwayland-client.so.0
#12 0x00007fd5b49e2053 in QtWaylandClient::QWaylandDisplay::flushRequests() () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
Comment 2 David Edmundson 2021-11-28 21:08:15 UTC

*** This bug has been marked as a duplicate of bug 437455 ***