Bug 445150 - Settings program crashes (seg fault)
Summary: Settings program crashes (seg fault)
Status: RESOLVED DUPLICATE of bug 414834
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-08 10:04 UTC by aaruni
Modified: 2021-11-08 22:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aaruni 2021-11-08 10:04:16 UTC
Application: systemsettings5 (5.22.5)

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.16-301.fc35.x86_64 x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.5
Distribution: Fedora Linux 35 (KDE Plasma)

-- Information about the crash:
- What I was doing when the application crashed:

Experienced multiple times in different frames. To reproduce : enter settings program -> workspace behaviour -> screen edges. change a setting, hit apply. System settings crashes.

Also crashes when changing a setting in virtual desktops. Have not tried the rest of the settings yet (workspace is near the top of the list of settings).

Possibly system settings crashes when applying changes on a Wayland desktop?

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7fbc569f4940 (LWP 34529))]
[KCrash Handler]
#6  0x00007fbc5954e6a4 in QWaylandClientExtensionPrivate::handleRegistryGlobal (data=0x55b3469ff300, registry=0x55b344a4afc0, id=60, interface=..., version=1) at global/qwaylandclientextension.cpp:67
#7  0x00007fbc5953b1b9 in QtWaylandClient::QWaylandDisplay::registry_global (this=<optimized out>, id=<optimized out>, interface=..., version=<optimized out>) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwaylanddisplay.cpp:397
#8  0x00007fbc59557af3 in QtWayland::wl_registry::handle_global (data=0x55b344a47280, object=<optimized out>, name=60, interface=0x55b346e2d7b0 "org_kde_kwin_blur_manager", version=1) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwayland-wayland.cpp:94
#9  0x00007fbc56dedc04 in ffi_call_unix64 () at ../src/x86/unix64.S:76
#10 0x00007fbc56ded108 in ffi_call (cif=cif@entry=0x7ffc23da4240, fn=<optimized out>, rvalue=<optimized out>, rvalue@entry=0x0, avalue=avalue@entry=0x7ffc23da4310) at ../src/x86/ffi64.c:525
#11 0x00007fbc594a8d10 in wl_closure_invoke (closure=closure@entry=0x55b346e2d6d0, target=<optimized out>, target@entry=0x55b344a4afc0, opcode=opcode@entry=0, data=<optimized out>, flags=<optimized out>) at ../src/connection.c:1018
#12 0x00007fbc594a941b in dispatch_event (display=display@entry=0x55b344a4ae70, queue=<optimized out>, queue=<optimized out>) at ../src/wayland-client.c:1452
#13 0x00007fbc594a960c in dispatch_queue (queue=0x55b344a4af40, display=0x55b344a4ae70) at ../src/wayland-client.c:1598
#14 wl_display_dispatch_queue_pending (display=0x55b344a4ae70, queue=0x55b344a4af40) at ../src/wayland-client.c:1840
#15 0x00007fbc595336a3 in QtWaylandClient::QWaylandDisplay::flushRequests (this=0x55b344a47270) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwaylanddisplay.cpp:222
#16 0x00007fbc5bb423f0 in doActivate<false> (sender=0x55b344ad0a90, signal_index=3, argv=0x7ffc23da45e0) at kernel/qobject.cpp:3898
#17 0x00007fbc5bb3d327 in QMetaObject::activate (sender=sender@entry=0x55b344ad0a90, m=m@entry=0x7fbc5bde7460 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffc23da45e0) at kernel/qobject.cpp:3946
#18 0x00007fbc5bb44b4a in QSocketNotifier::activated (this=this@entry=0x55b344ad0a90, _t1=..., _t2=<optimized out>, _t3=...) at .moc/moc_qsocketnotifier.cpp:178
#19 0x00007fbc5bb45363 in QSocketNotifier::event (this=0x55b344ad0a90, e=0x7ffc23da46e0) at kernel/qsocketnotifier.cpp:302
#20 0x00007fbc5c6e7443 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55b344ad0a90, e=0x7ffc23da46e0) at kernel/qapplication.cpp:3632
#21 0x00007fbc5bb0e798 in QCoreApplication::notifyInternal2 (receiver=0x55b344ad0a90, event=0x7ffc23da46e0) at kernel/qcoreapplication.cpp:1064
#22 0x00007fbc5bb605ff in socketNotifierSourceDispatch (source=0x55b344a8ade0) at kernel/qeventdispatcher_glib.cpp:107
#23 0x00007fbc598aa33f in g_main_dispatch (context=0x55b344ad08e0) at ../glib/gmain.c:3381
#24 g_main_context_dispatch (context=0x55b344ad08e0) at ../glib/gmain.c:4099
#25 0x00007fbc598ff2b8 in g_main_context_iterate.constprop.0 (context=context@entry=0x55b344ad08e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#26 0x00007fbc598a79e3 in g_main_context_iteration (context=0x55b344ad08e0, may_block=1) at ../glib/gmain.c:4240
#27 0x00007fbc5bb5fb78 in QEventDispatcherGlib::processEvents (this=0x55b344ad05b0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#28 0x00007fbc5bb0d1a2 in QEventLoop::exec (this=this@entry=0x7ffc23da4950, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#29 0x00007fbc5bb156e4 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#30 0x000055b34389c58c in main (argc=<optimized out>, argv=0x7ffc23da4a70) at /usr/src/debug/plasma-systemsettings-5.22.5-1.fc35.x86_64/app/main.cpp:208
[Inferior 1 (process 34529) detached]

The reporter indicates this bug may be a duplicate of or related to bug 445019.

Possible duplicates by query: bug 445122, bug 445019, bug 444698, bug 444521, bug 444230.

Reported using DrKonqi
This report was filed against 'kde' because the product 'systemsettings' could not be located in Bugzilla. Add it to drkonqi's mappings file!
Comment 1 Nate Graham 2021-11-08 22:27:17 UTC

*** This bug has been marked as a duplicate of bug 414834 ***