Bug 445384 - Crashed after applying Window Decoration change
Summary: Crashed after applying Window Decoration change
Status: RESOLVED DUPLICATE of bug 414834
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.22.5
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-12 18:03 UTC by Willyanto
Modified: 2021-11-12 23:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Willyanto 2021-11-12 18:03:04 UTC
Application: systemsettings5 (5.22.5)

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.16-301.fc35.x86_64 x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.5
Distribution: Fedora Linux 35 (KDE Plasma)

-- Information about the crash:
- What I was doing when the application crashed:
I changed Window Decoration, clicked apply, and systemsettings crashed.

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7fc6ed54f940 (LWP 7478))]
[KCrash Handler]
#6  0x00007fc6f00a96a4 in QWaylandClientExtensionPrivate::handleRegistryGlobal(void*, wl_registry*, unsigned int, QString const&, unsigned int) (data=0x55af929cba80, registry=0x55af8ceae340, id=45, interface=..., version=1) at global/qwaylandclientextension.cpp:67
#7  0x00007fc6f00961b9 in QtWaylandClient::QWaylandDisplay::registry_global(unsigned int, QString const&, unsigned int) (this=<optimized out>, id=<optimized out>, interface=<optimized out>, version=<optimized out>) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwaylanddisplay.cpp:397
#8  0x00007fc6f00b2af3 in QtWayland::wl_registry::handle_global(void*, wl_registry*, unsigned int, char const*, unsigned int) (data=0x55af8ceaa590, object=<optimized out>, name=45, interface=0x55af939a35d0 "org_kde_kwin_blur_manager", version=1) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwayland-wayland.cpp:94
#9  0x00007fc6ed948c04 in ffi_call_unix64 () at ../src/x86/unix64.S:76
#10 0x00007fc6ed948108 in ffi_call (cif=cif@entry=0x7ffc8e8fcfe0, fn=<optimized out>, rvalue=<optimized out>, rvalue@entry=0x0, avalue=avalue@entry=0x7ffc8e8fd0b0) at ../src/x86/ffi64.c:525
#11 0x00007fc6f0003d10 in wl_closure_invoke (closure=closure@entry=0x55af939a34f0, target=<optimized out>, target@entry=0x55af8ceae340, opcode=opcode@entry=0, data=<optimized out>, flags=<optimized out>) at ../src/connection.c:1018
#12 0x00007fc6f000441b in dispatch_event (display=display@entry=0x55af8ceae1f0, queue=0x55af8ceae2c0, queue=<optimized out>) at ../src/wayland-client.c:1452
#13 0x00007fc6f000460c in dispatch_queue (queue=0x55af8ceae2c0, display=0x55af8ceae1f0) at ../src/wayland-client.c:1598
#14 wl_display_dispatch_queue_pending (display=0x55af8ceae1f0, queue=0x55af8ceae2c0) at ../src/wayland-client.c:1840
#15 0x00007fc6f008e4df in QtWaylandClient::QWaylandDisplay::flushRequests() (this=0x55af8ceaa580) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwaylanddisplay.cpp:222
#16 0x00007fc6f269d3f0 in doActivate<false>(QObject*, int, void**) (sender=0x55af8cf37250, signal_index=4, argv=0x7ffc8e8fd320) at kernel/qobject.cpp:3898
#17 0x00007fc6f2698327 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x55af8cf37250, m=m@entry=0x7fc6f2941ae0 <QAbstractEventDispatcher::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x0) at kernel/qobject.cpp:3946
#18 0x00007fc6f2666277 in QAbstractEventDispatcher::awake() (this=this@entry=0x55af8cf37250) at .moc/moc_qabstracteventdispatcher.cpp:149
#19 0x00007fc6f26bac0b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x55af8cf37250, flags=...) at kernel/qeventdispatcher_glib.cpp:430
#20 0x00007fc6f26681a2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffc8e8fd440, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#21 0x00007fc6f26706e4 in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#22 0x000055af8c72058c in main(int, char**) (argc=<optimized out>, argv=0x7ffc8e8fd560) at /usr/src/debug/plasma-systemsettings-5.22.5-1.fc35.x86_64/app/main.cpp:208
[Inferior 1 (process 7478) detached]

Possible duplicates by query: bug 445359, bug 445166, bug 445150, bug 445122, bug 445019.

Reported using DrKonqi
Comment 1 Nate Graham 2021-11-12 23:02:02 UTC

*** This bug has been marked as a duplicate of bug 414834 ***