Bug 445122 - Task window Switcher crash
Summary: Task window Switcher crash
Status: RESOLVED DUPLICATE of bug 414834
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-07 15:22 UTC by Danny Georgiev
Modified: 2021-11-08 22:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Danny Georgiev 2021-11-07 15:22:33 UTC
Application: systemsettings5 (5.22.5)

Qt Version: 5.15.2
Frameworks Version: 5.85.0
Operating System: Linux 5.14.15-200.fc34.x86_64 x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.5
Distribution: "Fedora release 34 (Thirty Four)"

-- Information about the crash:
- What I was doing when the application crashed:
I went to System Settings > Window management > Task switcher. When I chose another type of switching, the System Settings app crashed
- Custom settings of the application:
I changed from Breeze dark to Fedora switcher

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f4e65bf06a4 in QWaylandClientExtensionPrivate::handleRegistryGlobal(void*, wl_registry*, unsigned int, QString const&, unsigned int) () from /lib64/libQt5WaylandClient.so.5
#5  0x00007f4e65bdd1b9 in QtWaylandClient::QWaylandDisplay::registry_global(unsigned int, QString const&, unsigned int) () from /lib64/libQt5WaylandClient.so.5
#6  0x00007f4e65bf9af3 in QtWayland::wl_registry::handle_global(void*, wl_registry*, unsigned int, char const*, unsigned int) () from /lib64/libQt5WaylandClient.so.5
#7  0x00007f4e634a8c04 in ffi_call_unix64 () from /lib64/libffi.so.6
#8  0x00007f4e634a8107 in ffi_call () from /lib64/libffi.so.6
#9  0x00007f4e65b4ad10 in wl_closure_invoke.constprop () from /lib64/libwayland-client.so.0
#10 0x00007f4e65b4b42b in dispatch_event.isra () from /lib64/libwayland-client.so.0
#11 0x00007f4e65b4b61c in wl_display_dispatch_queue_pending () from /lib64/libwayland-client.so.0
#12 0x00007f4e65bd56a3 in QtWaylandClient::QWaylandDisplay::flushRequests() () from /lib64/libQt5WaylandClient.so.5
#13 0x00007f4e681f33f0 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#14 0x00007f4e681f5b4a in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () from /lib64/libQt5Core.so.5
#15 0x00007f4e681f6363 in QSocketNotifier::event(QEvent*) () from /lib64/libQt5Core.so.5
#16 0x00007f4e68d92443 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#17 0x00007f4e681bf798 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#18 0x00007f4e682115ff in socketNotifierSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#19 0x00007f4e65f474cf in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#20 0x00007f4e65f9b4f8 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#21 0x00007f4e65f44c03 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#22 0x00007f4e68210b78 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#23 0x00007f4e681be1a2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#24 0x00007f4e681c66e4 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#25 0x000055727611a58c in main ()
[Inferior 1 (process 10185) detached]

Possible duplicates by query: bug 445019, bug 444698, bug 444521, bug 444230, bug 443346.

Reported using DrKonqi
This report was filed against 'kde' because the product 'systemsettings' could not be located in Bugzilla. Add it to drkonqi's mappings file!
Comment 1 Nate Graham 2021-11-08 22:36:36 UTC

*** This bug has been marked as a duplicate of bug 414834 ***