Bug 445359 - System Settings Crashes When Applying changes to Virtual Desktops
Summary: System Settings Crashes When Applying changes to Virtual Desktops
Status: RESOLVED DUPLICATE of bug 414834
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.22.5
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-12 01:43 UTC by magicsoupbowl
Modified: 2021-11-12 22:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description magicsoupbowl 2021-11-12 01:43:14 UTC
Application: systemsettings5 (5.22.5)

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.16-301.fc35.x86_64 x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.5
Distribution: Fedora Linux 35 (KDE Plasma)

-- Information about the crash:
- What I was doing when the application crashed: Adding an additional desktop in the Virtual Desktops setting. I had the application open on an external monitor. The monitor had a resolution of 1920x1080, my laptop had a different resolution of 2256x1504 with fractional scaling set at 150%. This was in Wayland.

- Custom settings of the application: added second desktop named Desktop 2

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7f22293bd940 (LWP 3068))]
[KCrash Handler]
#6  0x00007f222bf176a4 in QWaylandClientExtensionPrivate::handleRegistryGlobal (data=0x55db19af7f80, registry=0x55db166073f0, id=47, interface=..., version=1) at global/qwaylandclientextension.cpp:67
#7  0x00007f222bf041b9 in QtWaylandClient::QWaylandDisplay::registry_global (this=<optimized out>, id=<optimized out>, interface=..., version=<optimized out>) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwaylanddisplay.cpp:397
#8  0x00007f222bf20af3 in QtWayland::wl_registry::handle_global (data=0x55db16603490, object=<optimized out>, name=47, interface=0x55db18ee1150 "org_kde_kwin_blur_manager", version=1) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwayland-wayland.cpp:94
#9  0x00007f22297b6c04 in ffi_call_unix64 () at ../src/x86/unix64.S:76
#10 0x00007f22297b6108 in ffi_call (cif=cif@entry=0x7ffef73781d0, fn=<optimized out>, rvalue=<optimized out>, rvalue@entry=0x0, avalue=avalue@entry=0x7ffef73782a0) at ../src/x86/ffi64.c:525
#11 0x00007f222be71d10 in wl_closure_invoke (closure=closure@entry=0x55db18ee1070, target=<optimized out>, target@entry=0x55db166073f0, opcode=opcode@entry=0, data=<optimized out>, flags=<optimized out>) at ../src/connection.c:1018
#12 0x00007f222be7241b in dispatch_event (display=display@entry=0x55db166072a0, queue=<optimized out>, queue=<optimized out>) at ../src/wayland-client.c:1452
#13 0x00007f222be7260c in dispatch_queue (queue=0x55db16607370, display=0x55db166072a0) at ../src/wayland-client.c:1598
#14 wl_display_dispatch_queue_pending (display=0x55db166072a0, queue=0x55db16607370) at ../src/wayland-client.c:1840
#15 0x00007f222befc6a3 in QtWaylandClient::QWaylandDisplay::flushRequests (this=0x55db16603480) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwaylanddisplay.cpp:222
#16 0x00007f222e50b3f0 in doActivate<false> (sender=0x55db166377b0, signal_index=3, argv=0x7ffef7378570) at kernel/qobject.cpp:3898
#17 0x00007f222e506327 in QMetaObject::activate (sender=sender@entry=0x55db166377b0, m=m@entry=0x7f222e7b0460 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffef7378570) at kernel/qobject.cpp:3946
#18 0x00007f222e50db4a in QSocketNotifier::activated (this=this@entry=0x55db166377b0, _t1=..., _t2=<optimized out>, _t3=...) at .moc/moc_qsocketnotifier.cpp:178
#19 0x00007f222e50e363 in QSocketNotifier::event (this=0x55db166377b0, e=0x7ffef7378670) at kernel/qsocketnotifier.cpp:302
#20 0x00007f222f0b0443 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55db166377b0, e=0x7ffef7378670) at kernel/qapplication.cpp:3632
#21 0x00007f222e4d7798 in QCoreApplication::notifyInternal2 (receiver=0x55db166377b0, event=0x7ffef7378670) at kernel/qcoreapplication.cpp:1064
#22 0x00007f222e5295ff in socketNotifierSourceDispatch (source=0x55db16649090) at kernel/qeventdispatcher_glib.cpp:107
#23 0x00007f222c27333f in g_main_dispatch (context=0x55db166683e0) at ../glib/gmain.c:3381
#24 g_main_context_dispatch (context=0x55db166683e0) at ../glib/gmain.c:4099
#25 0x00007f222c2c82b8 in g_main_context_iterate.constprop.0 (context=context@entry=0x55db166683e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#26 0x00007f222c2709e3 in g_main_context_iteration (context=0x55db166683e0, may_block=1) at ../glib/gmain.c:4240
#27 0x00007f222e528b78 in QEventDispatcherGlib::processEvents (this=0x55db1668e940, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#28 0x00007f222e4d61a2 in QEventLoop::exec (this=this@entry=0x7ffef73788e0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#29 0x00007f222e4de6e4 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#30 0x000055db153ff58c in main (argc=<optimized out>, argv=0x7ffef7378a00) at /usr/src/debug/plasma-systemsettings-5.22.5-1.fc35.x86_64/app/main.cpp:208
[Inferior 1 (process 3068) detached]

Possible duplicates by query: bug 445166, bug 445150, bug 445122, bug 445019, bug 444698.

Reported using DrKonqi
Comment 1 Nate Graham 2021-11-12 22:51:26 UTC

*** This bug has been marked as a duplicate of bug 414834 ***