Bug 445166 - System Settings crashes when unplugging secondary monitor
Summary: System Settings crashes when unplugging secondary monitor
Status: RESOLVED DUPLICATE of bug 414834
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.22.5
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-08 15:31 UTC by Ukaza Perdana
Modified: 2021-11-08 23:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ukaza Perdana 2021-11-08 15:31:31 UTC
Application: systemsettings5 (5.22.5)

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.16-301.fc35.x86_64 x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.5
Distribution: "Fedora release 35 (Thirty Five)"

-- Information about the crash:
- Laptop with primary monitor turned off (lid closed) and outputs to secondary monitor.
- Using Wayland

Disconnected and reconnected the display cable.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x00007fc7f88ae6a4 in QWaylandClientExtensionPrivate::handleRegistryGlobal(void*, wl_registry*, unsigned int, QString const&, unsigned int) () at /lib64/libQt5WaylandClient.so.5
#5  0x00007fc7f889b1b9 in QtWaylandClient::QWaylandDisplay::registry_global(unsigned int, QString const&, unsigned int) () at /lib64/libQt5WaylandClient.so.5
#6  0x00007fc7f88b7af3 in QtWayland::wl_registry::handle_global(void*, wl_registry*, unsigned int, char const*, unsigned int) () at /lib64/libQt5WaylandClient.so.5
#7  0x00007fc7f614dc04 in ffi_call_unix64 () at /lib64/libffi.so.6
#8  0x00007fc7f614d108 in ffi_call () at /lib64/libffi.so.6
#9  0x00007fc7f8808d10 in wl_closure_invoke.constprop () at /lib64/libwayland-client.so.0
#10 0x00007fc7f880941b in dispatch_event.isra () at /lib64/libwayland-client.so.0
#11 0x00007fc7f880960c in wl_display_dispatch_queue_pending () at /lib64/libwayland-client.so.0
#12 0x00007fc7f88934df in QtWaylandClient::QWaylandDisplay::flushRequests() () at /lib64/libQt5WaylandClient.so.5
#13 0x00007fc7faea23f0 in void doActivate<false>(QObject*, int, void**) () at /lib64/libQt5Core.so.5
#14 0x00007fc7faebfc0b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#15 0x00007fc7fae6d1a2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#16 0x00007fc7fae756e4 in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#17 0x000055e43d99658c in main ()
[Inferior 1 (process 3666) detached]

Possible duplicates by query: bug 445150, bug 445122, bug 445019, bug 444698, bug 444521.

Reported using DrKonqi
This report was filed against 'kde' because the product 'systemsettings' could not be located in Bugzilla. Add it to drkonqi's mappings file!
Comment 1 Nate Graham 2021-11-08 23:18:23 UTC

*** This bug has been marked as a duplicate of bug 414834 ***