Bug 445019 - Settings crashed when applying changes to Night Color
Summary: Settings crashed when applying changes to Night Color
Status: RESOLVED DUPLICATE of bug 414834
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.22.5
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-05 14:30 UTC by jdl
Modified: 2021-11-08 20:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jdl 2021-11-05 14:30:15 UTC
Application: systemsettings5 (5.22.5)

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.15-300.fc35.x86_64 x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.5
Distribution: Fedora Linux 35 (KDE Plasma)

-- Information about the crash:
- What I was doing when the application crashed:

Opened settings.
adjust Night Color slider
click apply
Settings crashed

New settings were saved.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Systeminnstillinger (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f8c14d156a4 in QWaylandClientExtensionPrivate::handleRegistryGlobal(void*, wl_registry*, unsigned int, QString const&, unsigned int) (data=0x55e78d804c90, registry=0x55e78bb8f400, id=45, interface=..., version=1) at global/qwaylandclientextension.cpp:67
#5  0x00007f8c14d021b9 in QtWaylandClient::QWaylandDisplay::registry_global(unsigned int, QString const&, unsigned int) (this=<optimized out>, id=<optimized out>, interface=<optimized out>, version=<optimized out>) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwaylanddisplay.cpp:397
#6  0x00007f8c14d1eaf3 in QtWayland::wl_registry::handle_global(void*, wl_registry*, unsigned int, char const*, unsigned int) (data=0x55e78bb8b4a0, object=<optimized out>, name=45, interface=0x55e78d372280 "org_kde_kwin_blur_manager", version=1) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwayland-wayland.cpp:94
#7  0x00007f8c125b4c04 in ffi_call_unix64 () at ../src/x86/unix64.S:76
#8  0x00007f8c125b4108 in ffi_call (cif=cif@entry=0x7ffddac459f0, fn=<optimized out>, rvalue=<optimized out>, rvalue@entry=0x0, avalue=avalue@entry=0x7ffddac45ac0) at ../src/x86/ffi64.c:525
#9  0x00007f8c14c6fd10 in wl_closure_invoke (closure=closure@entry=0x55e78d3721a0, target=<optimized out>, target@entry=0x55e78bb8f400, opcode=opcode@entry=0, data=<optimized out>, flags=<optimized out>) at ../src/connection.c:1018
#10 0x00007f8c14c7041b in dispatch_event (display=0x55e78bb8f2b0, queue=<optimized out>, queue=<optimized out>) at ../src/wayland-client.c:1452
#11 0x00007f8c14c7060c in dispatch_queue (queue=0x55e78bb8f380, display=0x55e78bb8f2b0) at ../src/wayland-client.c:1598
#12 wl_display_dispatch_queue_pending (display=0x55e78bb8f2b0, queue=0x55e78bb8f380) at ../src/wayland-client.c:1840
#13 0x00007f8c14cfa6a3 in QtWaylandClient::QWaylandDisplay::flushRequests() (this=0x55e78bb8b490) at /usr/src/debug/qt5-qtwayland-5.15.2-14.fc35.x86_64/src/client/qwaylanddisplay.cpp:222
#14 0x00007f8c173093f0 in doActivate<false>(QObject*, int, void**) (sender=0x55e78bbbf060, signal_index=3, argv=0x7ffddac45d90) at kernel/qobject.cpp:3898
#15 0x00007f8c17304327 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x55e78bbbf060, m=m@entry=0x7f8c175ae460 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffddac45d90) at kernel/qobject.cpp:3946
#16 0x00007f8c1730bb4a in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) (this=this@entry=0x55e78bbbf060, _t1=..., _t2=<optimized out>, _t3=...) at .moc/moc_qsocketnotifier.cpp:178
#17 0x00007f8c1730c363 in QSocketNotifier::event(QEvent*) (this=0x55e78bbbf060, e=0x7ffddac45e90) at kernel/qsocketnotifier.cpp:302
#18 0x00007f8c17eae443 in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x55e78bbbf060, e=0x7ffddac45e90) at kernel/qapplication.cpp:3632
#19 0x00007f8c172d5798 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x55e78bbbf060, event=0x7ffddac45e90) at kernel/qcoreapplication.cpp:1064
#20 0x00007f8c173275ff in socketNotifierSourceDispatch(GSource*, GSourceFunc, gpointer) (source=0x55e78bbd0f90) at kernel/qeventdispatcher_glib.cpp:107
#21 0x00007f8c1507133f in g_main_dispatch (context=0x55e78bbf02e0) at ../glib/gmain.c:3381
#22 g_main_context_dispatch (context=0x55e78bbf02e0) at ../glib/gmain.c:4099
#23 0x00007f8c150c62b8 in g_main_context_iterate.constprop.0 (context=context@entry=0x55e78bbf02e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#24 0x00007f8c1506e9e3 in g_main_context_iteration (context=0x55e78bbf02e0, may_block=1) at ../glib/gmain.c:4240
#25 0x00007f8c17326b78 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x55e78bc16a30, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#26 0x00007f8c172d41a2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffddac46100, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#27 0x00007f8c172dc6e4 in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#28 0x000055e78a1f158c in  ()
#29 0x00007f8c00000003 in  ()
#30 0x00007ffddac461c0 in  ()
#31 0x00007ffddac461e0 in  ()
#32 0x000055e78be4f5b0 in  ()
#33 0x000055e78bb93900 in  ()
#34 0x0000000000000000 in  ()
[Inferior 1 (process 112969) detached]

The reporter indicates this bug may be a duplicate of or related to bug 437081.

Possible duplicates by query: bug 444698, bug 444521, bug 444230, bug 443346, bug 443000.

Reported using DrKonqi
Comment 1 Nate Graham 2021-11-08 20:45:18 UTC

*** This bug has been marked as a duplicate of bug 414834 ***