Bug 442192 - [Wayland] Restore session not working
Summary: [Wayland] Restore session not working
Status: RESOLVED DUPLICATE of bug 436318
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: 5.22.5
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-08 19:34 UTC by Francisco Cribari
Modified: 2021-09-14 15:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Cribari 2021-09-08 19:34:24 UTC
SUMMARY

Under Wayland, the session is not restored upon reboot, even when the "Restore previous saved session" is selected in system settings. 


STEPS TO REPRODUCE
1. Start KDE Plasma under Wayland. 
2. Open some applications (konsole, kedit, Dolphin, etc.). 
3. Reboot. 

OBSERVED RESULT

The previous session is not restored. 


EXPECTED RESULT

The previous session should be restored. 


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Arch Linux
(available in About System)
KDE Plasma Version: 5.22.5-2
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2 

ADDITIONAL INFORMATION
Comment 1 David Edmundson 2021-09-09 09:15:01 UTC
This is expected at this point, see errata
Comment 2 Nate Graham 2021-09-14 15:07:58 UTC

*** This bug has been marked as a duplicate of bug 436318 ***