Bug 455900 - No session restore since ~April
Summary: No session restore since ~April
Status: CLOSED DUPLICATE of bug 436318
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.25.1
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-24 19:46 UTC by John E
Modified: 2022-06-27 11:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John E 2022-06-24 19:46:53 UTC
SUMMARY
Hello,

I'm running Plasma Framework 5.95 and Plasma Desktop 5.25.1 on Wayland on Arch Linux and I do not get the automatic session restore on login anymore. This is not a new issue, I've had this since late April I'd say. I have not noticed any other kind of issue but who knows.

Restoring the old ~/.config/session and ~/.config/ksmserverrc would work for one reboot and on the next it'd be an empty session again, removing write permissions on these would allow future restoring but not saving obviously... I've tried simply deleting these in case they were corrupt but still nothing better. At this point I do believe the issue is on my end, as if not I'm sure it would have been fixed by now but I do not know what else to try... Well I could try a new prefix I guess, maybe I'll do that later today.

Thank you for any idea!


SOFTWARE/OS VERSIONS
Linux: 5.18.6
KDE Plasma Version: 5.25.1
KDE Frameworks Version: 5.95
Qt Version: 5.15.5

ADDITIONAL INFORMATION
Comment 1 Shmerl 2022-06-26 05:06:42 UTC
I just switched to the Wayland session (Debian testing) and also encountered that session restore isn't working anymore.

The only restored application is Firefox somehow. Not restored: konsole, kmail, ksysguard.

Running Plasma 5.25.1 from experimental.
Comment 2 Shmerl 2022-06-26 05:08:57 UTC
I enabled systemd boot for KDE in the past if that makes a difference.
Comment 3 John E 2022-06-27 06:57:40 UTC
Thank you for confirming Shmerl!


(In reply to Shmerl from comment #2)
> I enabled systemd boot for KDE in the past if that makes a difference.

What do you mean by that so I can confirm if I've done that as well.
Comment 4 Shmerl 2022-06-27 07:04:06 UTC
(In reply to John E from comment #3)
> 
> What do you mean by that so I can confirm if I've done that as well.

See: https://blog.davidedmundson.co.uk/blog/plasma-and-the-systemd-startup/
Comment 5 David Edmundson 2022-06-27 11:10:43 UTC
>I just switched to the Wayland session (Debian testing) and also encountered that session restore isn't working anymore.

It is know that wayland will not have session restore.

*** This bug has been marked as a duplicate of bug 436318 ***
Comment 6 John E 2022-06-27 11:31:20 UTC
(In reply to Shmerl from comment #4)
> (In reply to John E from comment #3)
> > 
> > What do you mean by that so I can confirm if I've done that as well.
> 
> See: https://blog.davidedmundson.co.uk/blog/plasma-and-the-systemd-startup/

Oh I did not know about that, thank you!

(In reply to David Edmundson from comment #5)
> >I just switched to the Wayland session (Debian testing) and also encountered that session restore isn't working anymore.
> 
> It is know that wayland will not have session restore.
> 
> *** This bug has been marked as a duplicate of bug 436318 ***
Sorry for the duplicate, I'll close this.