Bug 442283 - Restore session in Wayland doesn't work
Summary: Restore session in Wayland doesn't work
Status: RESOLVED DUPLICATE of bug 436318
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: git-master
Platform: Neon Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-10 21:40 UTC by Piotr Mierzwinski
Modified: 2021-09-16 17:51 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Configuratio-Destkop_Session (33.41 KB, image/png)
2021-09-10 21:40 UTC, Piotr Mierzwinski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Mierzwinski 2021-09-10 21:40:18 UTC
Created attachment 141460 [details]
Configuratio-Destkop_Session

SUMMARY
I switched for tests to Wayland session. I have opened couple applications like Firefox, Dolphin, Konsole, Kate and Clementine (on one from 3 activities). After first login ot Wayland session was correctly restored. So I started Dolphin application in my second activity, back to my default activity and signed out. I signed it and turned out that only Firefox was restored.

STEPS TO REPRODUCE
1. Create couple activities
2. Start couple applications on 'default' activity
3. Sign off
4. Select Wayland session and sign in
5. On second activity start Dolphin
6. Sign out and Sign in

OBSERVED RESULT
Only Firefox is restored

EXPECTED RESULT
Should be restore all running applications in moment of signing out

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: YES
(available in About System)
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Up-to-date Neon/Linux on day 2021/09/10, 23:32
Comment 1 Piotr Mierzwinski 2021-09-10 21:45:52 UTC
I started again my all applications. Logged out and logged in. In result again nothing was restored. I back to x11 windowing system.
Comment 2 Piotr Mierzwinski 2021-09-10 21:49:23 UTC
After I back to x11 I got broken desktop,  I mean I lost the panel. Only Firefox was restored.
Comment 3 Paul Worrall 2021-09-15 14:25:06 UTC
I can reproduce

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-27-generic (64-bit)
Graphics Platform: Wayland
Processors: 2 × AMD A6-6400K APU with Radeon(tm) HD Graphics
Memory: 7.7 GiB of RAM
Graphics Processor: AMD CEDAR
Comment 4 Nate Graham 2021-09-16 17:51:46 UTC

*** This bug has been marked as a duplicate of bug 436318 ***