Bug 439025 - The system tray doesn't follow the panel opacity
Summary: The system tray doesn't follow the panel opacity
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: System Tray (show other bugs)
Version: 5.22.1
Platform: Archlinux Packages Linux
: HI normal
Target Milestone: 1.0
Assignee: Konrad Materka
URL:
Keywords:
: 439060 439235 439903 442787 444713 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-06-22 11:33 UTC by Reiddragon
Modified: 2021-12-30 17:29 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.23.5


Attachments
bug in action, other plasmoids like KickOff or the Calendar follow the panel, only the tray doesn't (115.66 KB, image/png)
2021-06-22 11:33 UTC, Reiddragon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reiddragon 2021-06-22 11:33:33 UTC
Created attachment 139591 [details]
bug in action, other plasmoids like KickOff or the Calendar follow the panel, only the tray doesn't

SUMMARY
The system tray doesn't follow the panel opacity (it's always transparent even when the setting is set to opaque or dynamic with a maximised window present)

STEPS TO REPRODUCE
1. set panel opacity to opaque
2. open any panel from the system tray
3. 

OBSERVED RESULT
Tray is still transparent regardless of setting

EXPECTED RESULT
It's supposed to follow the panel, not sure if this needed to be stated

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.22.1
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 Patrick Silva 2021-06-23 22:20:16 UTC
*** Bug 439060 has been marked as a duplicate of this bug. ***
Comment 2 Patrick Silva 2021-06-28 02:31:57 UTC
*** Bug 439235 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2021-09-21 21:30:37 UTC
*** Bug 442787 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2021-12-15 17:22:05 UTC
*** Bug 439903 has been marked as a duplicate of this bug. ***
Comment 5 Konrad Materka 2021-12-29 22:18:40 UTC
Git commit 8374098d68798a78ca10d06d9a829ee5a811e0bf by Konrad Materka.
Committed on 29/12/2021 at 22:15.
Pushed by kmaterka into branch '439025_systray_follow_planel_opacity'.

[applets/systemtray] Follow panel opacity

The system tray doesn't follow the panel opacity (it's always
transparent even when the setting is set to opaque or dynamic
with a maximised window present)
FIXED-IN: 5.24.0

M  +1    -0    applets/systemtray/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-workspace/commit/8374098d68798a78ca10d06d9a829ee5a811e0bf
Comment 6 Konrad Materka 2021-12-29 22:54:39 UTC
*** Bug 444713 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-12-30 17:29:05 UTC
Git commit a221d230ca5a480c1e8e51f062485f63ae7c039a by Nate Graham, on behalf of Konrad Materka.
Committed on 30/12/2021 at 17:28.
Pushed by ngraham into branch 'master'.

applets/systemtray: Follow panel opacity

The system tray doesn't follow the panel opacity (it's always
transparent even when the setting is set to opaque or dynamic
with a maximised window present)
FIXED-IN: 5.23.5

M  +1    -0    applets/systemtray/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-workspace/commit/a221d230ca5a480c1e8e51f062485f63ae7c039a
Comment 8 Nate Graham 2021-12-30 17:29:58 UTC
Git commit 10aa6382887be57526a259f2ba21251eb5a83c16 by Nate Graham, on behalf of Konrad Materka.
Committed on 30/12/2021 at 17:29.
Pushed by ngraham into branch 'Plasma/5.23'.

applets/systemtray: Follow panel opacity

The system tray doesn't follow the panel opacity (it's always
transparent even when the setting is set to opaque or dynamic
with a maximised window present)
FIXED-IN: 5.23.5
(cherry picked from commit a221d230ca5a480c1e8e51f062485f63ae7c039a)

M  +1    -0    applets/systemtray/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-workspace/commit/10aa6382887be57526a259f2ba21251eb5a83c16