Bug 439903 - System Tray does not respect Opaque panel setting for the panel it lives on
Summary: System Tray does not respect Opaque panel setting for the panel it lives on
Status: RESOLVED DUPLICATE of bug 439025
Alias: None
Product: plasmashell
Classification: Unclassified
Component: System Tray (show other bugs)
Version: 5.22.3
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-15 19:41 UTC by medin
Modified: 2021-12-15 17:22 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Opacity is not applied to Tray widgets and Widgets Adder (318.71 KB, image/png)
2021-07-15 19:41 UTC, medin
Details
Opacity problems (566.18 KB, image/png)
2021-07-16 20:58 UTC, medin
Details
Panel edit mode opacity (35.67 KB, image/png)
2021-07-16 21:03 UTC, medin
Details
Panel edit mode opacity 2 (32.27 KB, image/png)
2021-07-16 21:05 UTC, medin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description medin 2021-07-15 19:41:36 UTC
Created attachment 140095 [details]
Opacity is not applied to Tray widgets and Widgets Adder

If you set panel opacity to Opaque then it will not be applied to Tray widgets and Widgets Adder. See attached image for more info.
Comment 1 Nate Graham 2021-07-16 02:21:53 UTC
Seems like a bug; panel widgets other than the System Tray become opaque, but the System Tray does not.

As for the Add Widgets sidebar, that's intentional because it's not connected to the panel itself. The Panel opacity setting is only supposed to concern the panel and any widgets on it. It's not a general "turn off all transparency in Plasma" button.
Comment 2 medin 2021-07-16 20:58:16 UTC
The problem is not specific to only Tray system widgets, all "Show Alternatives" dialogs, desktop notifications, brightness/audio osd suffer from this problem. See attached image for more info.
Comment 3 medin 2021-07-16 20:58:56 UTC
Created attachment 140120 [details]
Opacity problems
Comment 4 medin 2021-07-16 21:03:27 UTC
Also the panel edit mode is affected.
Comment 5 medin 2021-07-16 21:03:54 UTC
Created attachment 140121 [details]
Panel edit mode opacity
Comment 6 medin 2021-07-16 21:05:37 UTC
Created attachment 140122 [details]
Panel edit mode opacity 2
Comment 7 Nate Graham 2021-07-23 21:26:39 UTC
Like ahe Add Widgets sidebar, desktop notifications and status OSDs are not connected to a panel so they are not expected to respect the per-panel transparency setting. Again, this is a *per-panel* setting, not a general transparency toggle for all of plasmashell.

However the Alternatives popup and the Edit Mode UI elements are connected to a panel, so it would make sense for them to respect the opacity setting. Can you file a new bug report in plasmashell | panel for those? If you could also mark it in the "See Also" field of this bug report, that would be lovely. :)
Comment 8 Nate Graham 2021-12-15 17:22:05 UTC

*** This bug has been marked as a duplicate of bug 439025 ***