Bug 442787 - System Tray does not respect "Opaque" panel background setting
Summary: System Tray does not respect "Opaque" panel background setting
Status: RESOLVED DUPLICATE of bug 439025
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Panel (show other bugs)
Version: 5.22.90
Platform: Neon Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-21 21:29 UTC by licibe2328
Modified: 2021-09-21 21:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description licibe2328 2021-09-21 21:29:06 UTC
SUMMARY
When setting the panel to be Opaque, some applets like Volume or Network will render their background with opacity whereas other applets like Kickoff or Calendar will render it opaque

STEPS TO REPRODUCE
1. Set panel opacity to Opaque
2. Open Volume applet: background has opacity
3. Open Calendar applet: background is opaque

OBSERVED RESULT
Inconsistent applet background behaviour: some with opacity, some are opaque

EXPECTED RESULT
All applets should render the background by using the same style. Opaque in this case since it was the one selected for the panel

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-09-21 21:30:01 UTC
Can confirm.
Comment 2 Nate Graham 2021-09-21 21:30:37 UTC
Ah, there's already a bug report for this: Bug 439025.

*** This bug has been marked as a duplicate of bug 439025 ***