Bug 444713 - System tray applets do not follow the adaptive transparency in some cases (stays transparent despite maximized window)
Summary: System tray applets do not follow the adaptive transparency in some cases (st...
Status: RESOLVED DUPLICATE of bug 439025
Alias: None
Product: plasmashell
Classification: Unclassified
Component: System Tray (show other bugs)
Version: 5.23.0
Platform: Other Linux
: NOR minor
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-31 13:30 UTC by KDamian
Modified: 2021-12-29 22:54 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Volume applet being transparent despite the transparency in panel settings set to Adaptive. (874.54 KB, image/png)
2021-10-31 13:30 UTC, KDamian
Details
Calendar applet being (correctly) opaque in the same situation. (609.49 KB, image/png)
2021-10-31 13:31 UTC, KDamian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KDamian 2021-10-31 13:30:51 UTC
Created attachment 143054 [details]
Volume applet being transparent despite the transparency in panel settings set to Adaptive.

SUMMARY

System tray applets do not follow the adaptive transparency in some cases (stay transparent despite maximized window)

STEPS TO REPRODUCE
1. Set Panel transparency to Adaptive
2. Open maximized window on a desktop
3. Open one of the applets from the system tray

OBSERVED RESULT

System tray applet is transparent.

EXPECTED RESULT

System tray applet should become opaque.

SOFTWARE/OS VERSIONS

Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.2
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-38-generic (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-2520M CPU @ 2.50GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 3000

ADDITIONAL INFORMATION

Calendar applet works okay as you can see in another attachment, problem looks to only be with System tray applets.
Comment 1 KDamian 2021-10-31 13:31:57 UTC
Created attachment 143055 [details]
Calendar applet being (correctly) opaque in the same situation.
Comment 2 Nate Graham 2021-11-01 16:35:05 UTC
Can confirm.
Comment 3 Konrad Materka 2021-12-29 22:54:39 UTC

*** This bug has been marked as a duplicate of bug 439025 ***