Bug 411462 - On X11, Plasma dialogs (applet popups, OSDs, notifications) should not be maximizable, or minimizable, or tilable
Summary: On X11, Plasma dialogs (applet popups, OSDs, notifications) should not be max...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Unclassified
Component: libplasma (show other bugs)
Version: 5.61.0
Platform: openSUSE RPMs Linux
: HI normal with 1 vote (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
: 385231 411437 416291 419764 426941 439546 441035 443077 444448 444477 445221 445663 445854 446379 447274 453393 455310 455797 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-31 06:56 UTC by Michail Vourlakos
Modified: 2022-06-22 20:37 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michail Vourlakos 2019-08-31 06:56:44 UTC
SUMMARY
Latte v0.9 introduced a way for the user to maximized and drag active window from the empty areas of a Latte panel. This behavior revealed that all plasma popups from applets are movable and maximizable

STEPS TO REPRODUCE
1. Use Latte panel v0.9
2. Activate an applet to show its popup
3. Double click at empty areas of a Latte panel

OBSERVED RESULT
Plasma popup is maximized

EXPECTED RESULT
Plasma popup should NOT be maximized


SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.16.4
KDE Frameworks Version: 5.61
Qt Version: Qt 5.12

ADDITIONAL INFORMATION
The Latte code is already adjusted to check the windows if they are movable of draggable like the plasma libtaskmanager is doing. The Latte checks can be found at:
https://phabricator.kde.org/source/latte-dock/browse/master/app/wm/xwindowinterface.cpp$397
https://phabricator.kde.org/source/latte-dock/browse/master/app/wm/waylandinterface.cpp$511
Comment 1 Michail Vourlakos 2019-08-31 06:57:10 UTC
*** Bug 411437 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2021-07-30 17:12:21 UTC
*** Bug 439546 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2021-08-16 18:22:30 UTC
*** Bug 441035 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2021-08-31 18:24:30 UTC
*** Bug 416291 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2021-09-24 21:01:38 UTC
*** Bug 419764 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2021-09-24 21:01:42 UTC
*** Bug 426941 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-09-28 20:26:41 UTC
*** Bug 443077 has been marked as a duplicate of this bug. ***
Comment 8 Patrick Silva 2021-10-27 11:27:20 UTC
*** Bug 444477 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2021-10-28 15:59:40 UTC
*** Bug 444448 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2021-11-09 21:54:20 UTC
*** Bug 445221 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2021-11-09 21:54:41 UTC
Can't reproduce on Wayland; seems to be X11-only
Comment 12 Patrick Silva 2021-11-21 23:09:50 UTC
*** Bug 445854 has been marked as a duplicate of this bug. ***
Comment 13 Nate Graham 2021-11-24 20:30:04 UTC
*** Bug 445663 has been marked as a duplicate of this bug. ***
Comment 14 Nate Graham 2021-11-24 20:30:27 UTC
Raising priority due to number of duplicates.
Comment 15 Jeff Tratt 2021-11-27 13:51:44 UTC
While I may not understand the severity of this problem, my initial thought is that these type of items should be at least allowed to be moved, resized, etc. When a display problem occurs such as a new install and something gets stuck in  horrible resolution, being able to move or resize a popup/notification or whatever is in the way can be critical. So, while no one wants some window maximizing on a generic click, removing the ability altogether, I would advise against. Again, apologize if I misunderstand the context.
Comment 16 mjeff 2021-11-27 13:56:52 UTC
(In reply to Jeff Tratt from comment #15)
> While I may not understand the severity of this problem, my initial thought
> is that these type of items should be at least allowed to be moved, resized,
> etc. When a display problem occurs such as a new install and something gets
> stuck in  horrible resolution, being able to move or resize a
> popup/notification or whatever is in the way can be critical. So, while no
> one wants some window maximizing on a generic click, removing the ability
> altogether, I would advise against. Again, apologize if I misunderstand the
> context.

I think that makes sense as well, the main thing is that the ability to adjust is either consistent or non-existent (and the ability to reset it to default should be somewhere as well if it's possible to adjust it)
Comment 17 Nate Graham 2021-12-02 21:28:52 UTC
*** Bug 446379 has been marked as a duplicate of this bug. ***
Comment 18 Nate Graham 2022-01-11 22:17:35 UTC
*** Bug 447274 has been marked as a duplicate of this bug. ***
Comment 19 Nate Graham 2022-01-11 22:18:04 UTC
Bug already fixed in the Plasma Wayland session, so this only affects X11.
Comment 20 Nate Graham 2022-02-01 17:12:15 UTC
*** Bug 385231 has been marked as a duplicate of this bug. ***
Comment 21 Patrick Silva 2022-05-05 12:57:13 UTC
*** Bug 453393 has been marked as a duplicate of this bug. ***
Comment 22 Nate Graham 2022-05-27 17:11:36 UTC
Git commit 7892a18c26cad6881a1cddc5b1b722c8c5533049 by Nate Graham, on behalf of Luca Carlon.
Committed on 27/05/2022 at 17:11.
Pushed by ngraham into branch 'master'.

Add a new window type named AppletPopup.

See discussion in https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/500.
Related: bug 332512

M  +2    -0    autotests/kwindowinfox11test.cpp
M  +1    -1    autotests/netrootinfotestwm.cpp
M  +1    -0    autotests/netwininfotestclient.cpp
M  +5    -0    src/netwm_def.h
M  +1    -0    src/platforms/xcb/atoms_p.h
M  +16   -0    src/platforms/xcb/netwm.cpp

https://invent.kde.org/frameworks/kwindowsystem/commit/7892a18c26cad6881a1cddc5b1b722c8c5533049
Comment 23 Nate Graham 2022-05-27 17:12:37 UTC
Git commit 590cc34c684b0c38ee895472a0e20f9787d5089d by Nate Graham, on behalf of Luca Carlon.
Committed on 27/05/2022 at 17:12.
Pushed by ngraham into branch 'master'.

Add AppletPopup window type to PlasmaShellSurface

See discussion in https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/500.
Related: bug 332512

M  +1    -0    autotests/client/test_plasmashell.cpp
M  +3    -0    src/client/plasmashell.cpp
M  +1    -0    src/client/plasmashell.h
M  +4    -1    src/server/plasmashell_interface.cpp
M  +1    -0    src/server/plasmashell_interface.h
M  +4    -0    tests/plasmasurfacetest.cpp

https://invent.kde.org/frameworks/kwayland/commit/590cc34c684b0c38ee895472a0e20f9787d5089d
Comment 24 Nate Graham 2022-05-27 21:49:52 UTC
Git commit da0dd1e367b638f7d7803f1eccfb8a36d54c3a43 by Nate Graham, on behalf of Luca Carlon.
Committed on 27/05/2022 at 21:49.
Pushed by ngraham into branch 'master'.

Support new AppletPopup window type

See the discussion in https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/500.
Related: bug 332512
FIXED-IN: 5.25

M  +2    -0    autotests/integration/internal_window.cpp
M  +2    -0    autotests/integration/plasma_surface_test.cpp
M  +2    -0    src/debug_console.cpp
M  +1    -0    src/effects.cpp
M  +1    -0    src/effects.h
M  +2    -1    src/effects/fadingpopups/package/contents/code/main.js
M  +4    -0    src/libkwineffects/kwineffects.h
M  +1    -0    src/wayland/autotests/client/test_plasmashell.cpp
M  +3    -0    src/wayland/plasmashell_interface.cpp
M  +1    -0    src/wayland/plasmashell_interface.h
M  +4    -0    src/wayland/tests/plasmasurfacetest.cpp
M  +5    -2    src/window.cpp
M  +11   -0    src/window.h
M  +1    -1    src/workspace.cpp
M  +12   -1    src/x11window.cpp
M  +10   -2    src/xdgshellwindow.cpp

https://invent.kde.org/plasma/kwin/commit/da0dd1e367b638f7d7803f1eccfb8a36d54c3a43
Comment 25 Nate Graham 2022-05-27 21:54:08 UTC
Git commit ace8a4a3515de002b2605fbe382b825394fad28b by Nate Graham, on behalf of Luca Carlon.
Committed on 27/05/2022 at 21:53.
Pushed by ngraham into branch 'master'.

Make widget popups resizable

See the discussion in https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/500.
Related: bug 332512

M  +6    -2    applets/analog-clock/contents/ui/analogclock.qml
M  +6    -2    applets/batterymonitor/package/contents/ui/main.qml
M  +5    -2    applets/calendar/package/contents/ui/main.qml
M  +5    -2    applets/clipboard/contents/ui/clipboard.qml
M  +3    -0    applets/devicenotifier/package/contents/ui/FullRepresentation.qml
M  +6    -9    applets/digital-clock/package/contents/ui/CalendarView.qml
M  +1    -1    applets/kicker/plugin/submenu.cpp
M  +5    -2    applets/mediacontroller/contents/ui/ExpandedRepresentation.qml
M  +8    -3    applets/notifications/package/contents/ui/FullRepresentation.qml
M  +7    -13   applets/systemtray/package/contents/ui/ExpandedRepresentation.qml
M  +3    -0    applets/systemtray/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-workspace/commit/ace8a4a3515de002b2605fbe382b825394fad28b
Comment 26 Nate Graham 2022-05-27 21:54:11 UTC
Git commit 23c4e82cdcb6c7f251c27c6eefa643415c8c5927 by Nate Graham, on behalf of Luca Carlon.
Committed on 27/05/2022 at 21:53.
Pushed by ngraham into branch 'master'.

Make widget popups resizable

See the discussion in https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/500.
Related: bug 332512

M  +4    -0    applets/kickoff/package/contents/ui/FullRepresentation.qml
M  +6    -0    desktoppackage/contents/applet/CompactApplet.qml

https://invent.kde.org/plasma/plasma-desktop/commit/23c4e82cdcb6c7f251c27c6eefa643415c8c5927
Comment 27 Patrick Silva 2022-06-15 13:38:24 UTC
*** Bug 455310 has been marked as a duplicate of this bug. ***
Comment 28 Yerrey Dev 2022-06-22 20:37:29 UTC
*** Bug 455797 has been marked as a duplicate of this bug. ***