Bug 394580 - Wrong icon size on network manager applet
Summary: Wrong icon size on network manager applet
Status: RESOLVED FIXED
Alias: None
Product: plasma-nm
Classification: Unclassified
Component: applet (show other bugs)
Version: master
Platform: Neon Packages Linux
: NOR normal with 22 votes (vote)
Target Milestone: ---
Assignee: Jan Grulich
URL:
Keywords:
: 395345 395387 395489 395568 395700 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-05-22 22:00 UTC by TYY331
Modified: 2018-06-21 19:21 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.13.1


Attachments
Wrong icon size in network manager applet (43.91 KB, image/png)
2018-05-22 22:00 UTC, TYY331
Details
oversized icons (154.48 KB, image/png)
2018-05-28 20:28 UTC, Benjamin Buch
Details
Apparent large icon problem and missing network and vpn connections (74.79 KB, image/png)
2018-06-15 23:06 UTC, George L. Emigh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TYY331 2018-05-22 22:00:59 UTC
Created attachment 112821 [details]
Wrong icon size in network manager applet

The network manager applet displays wrong sized icons causing missalignment and difficulties to select a network, see attached screenshot.
This behavior is present regardless of the theme used by plasma (Breeze,Arc-Dark, etc) and icon theme used.
This bug just appeared in the dev/stable branch of KDE Neon.
Comment 1 TYY331 2018-05-23 01:10:03 UTC
It was a cache corruption.
Comment 2 Jonathan 2018-05-23 15:37:36 UTC
(In reply to TYY331 from comment #1)
> It was a cache corruption.

and how to resolve it?
Comment 3 TYY331 2018-05-23 17:05:07 UTC
I can't reproduce the issue, all I did was to delete the cache files and folders associated with KDE in the ~.cache folder for example icon-cache.kcache but I really don't know what file did the trick.
These kinds of problems are frequent when have big Plasma updates (5.11->5.12->5.13)
Maybe it would be sensible to have these cache files removed when a plasma update is installed.
Comment 4 Jonathan 2018-05-23 21:51:42 UTC
(In reply to TYY331 from comment #3)
> I can't reproduce the issue, all I did was to delete the cache files and
> folders associated with KDE in the ~.cache folder for example
> icon-cache.kcache but I really don't know what file did the trick.
> These kinds of problems are frequent when have big Plasma updates
> (5.11->5.12->5.13)
> Maybe it would be sensible to have these cache files removed when a plasma
> update is installed.

thanks for response my ask.  Another question. This cache files will be regenerated after delete them?
Comment 5 TYY331 2018-05-23 22:39:26 UTC
> thanks for response my ask.  Another question. This cache files will be
> regenerated after delete them?

Every cache file by definition is regenerated if not found, Qt isn't the exception.
Comment 6 Jonathan 2018-05-23 22:55:11 UTC
(In reply to TYY331 from comment #5)
> > thanks for response my ask.  Another question. This cache files will be
> > regenerated after delete them?
> 
> Every cache file by definition is regenerated if not found, Qt isn't the
> exception.

thanks... I will try
Comment 7 K900 2018-05-26 13:39:26 UTC
I can reproduce the issue locally, clearing cache doesn't help :(
Comment 8 Benjamin Buch 2018-05-28 20:28:27 UTC
Created attachment 112932 [details]
oversized icons

Same here, I'm on KDE neon git stable branch. I use the oxygen theme.

I cleared ~/.cache/plasmashell/qmlcache/ (followed by logout and login again) but it didn't help.
Comment 9 Jonathan 2018-05-29 21:52:10 UTC
(In reply to Jonathan from comment #6)
> (In reply to TYY331 from comment #5)
> > > thanks for response my ask.  Another question. This cache files will be
> > > regenerated after delete them?
> > 
> > Every cache file by definition is regenerated if not found, Qt isn't the
> > exception.
> 
> thanks... I will try

Not work :(:(:(
Comment 10 TYY331 2018-06-07 02:56:58 UTC
I think what did the trick was change the name of /home/sebastian/.config/plasmashellrc, log out, log in (now the icons should be the correct size) then change back the name of the config file to get back the plasma layout, log out and in again, see if the problem persist.
Comment 11 Jonathan 2018-06-07 13:55:10 UTC
(In reply to Jonathan from comment #6)
> (In reply to TYY331 from comment #5)
> > > thanks for response my ask.  Another question. This cache files will be
> > > regenerated after delete them?
> > 
> > Every cache file by definition is regenerated if not found, Qt isn't the
> > exception.
> 
> thanks... I will try

Finally, I uninstaled and reinstaled plasma-nm5 package.  It's worked.  I work on opensuse leap 42.3, plasma 5.8.7, kde-framework 5.46 and QT 5.11.

greetings
Comment 12 Jan Grulich 2018-06-14 08:37:36 UTC
*** Bug 395345 has been marked as a duplicate of this bug. ***
Comment 13 Alex Sidorenko 2018-06-14 13:24:01 UTC
I started seeing this on _one_ of my PCs only after upgrading to 5.13.0 in Ubuntu16.04/Neon
Comment 14 Christoph Feck 2018-06-14 22:50:52 UTC
*** Bug 395387 has been marked as a duplicate of this bug. ***
Comment 15 Darryl 2018-06-15 02:03:45 UTC
(In reply to Alex Sidorenko from comment #13)
> I started seeing this on _one_ of my PCs only after upgrading to 5.13.0 in
> Ubuntu16.04/Neon

I am also affected by this bug, after upgrading to 5.13.0 on Manjaro.
Comment 16 varlesh 2018-06-15 03:22:21 UTC
Bug reproduced for mostly old themes.
For reproduce need remove cache and restart plasmashell:
rm -rf ~/.cache/plasm* ~/cache/ico*
killall -9 plasmashell
ALT+F2 > plasmashell

It's happened because network document not used size 22x22. For example, on Oxygen used network.svgz with:
width="403.04306"
height="399.01367"

For fix that need change document size too:
width="22"
height="22"

Also percent not supported too:
width="100%"
height="100%"

I think better solution  - this need fix on network manager widget, because new update broken compability with some(mostly) old plasma themes
Comment 17 varlesh 2018-06-15 03:26:10 UTC
Network widget not use ID's size on document, but use with and height on SVG document. It's wrong
Comment 18 Christoph Feck 2018-06-15 18:01:59 UTC
Does it mean that plasma-nm does not use Plasma's icons (loaded via KIconLoader), but just QtQuick image items?
Comment 19 varlesh 2018-06-15 18:46:59 UTC
No, plasma-nm used icons from plasma theme, but with wrong size on widget.
Widget use SVG-document sizes for icons and ignore  Layers ID sizes.

Any icons for plasma have ID and size - but after last update plasma-nm ignore ID size and use document size (width & height).
For example, Oxygen plasma theme:
- netowrk.svgz (document have size width="403.04306" & height="399.01367")
- network.svg contained ID network-wired-available with size width="24" & height="24".
- BUT plasma-nm widget use size width="403.04306" & height="399.01367" for network-wired-available and other icons too...

Open Oxygen plasma theme, kill cache, restart plasma theme and see.
Comment 20 Filip Fila 2018-06-15 22:00:23 UTC
This bug has happened to apparently some of us non-Breeze using Manjaro users: https://forum.manjaro.org/t/plasma-5-13-network-connections-gui-broken/49855

I can confirm that deleting the cache fixed it.
Comment 21 George L. Emigh 2018-06-15 23:06:15 UTC
Created attachment 113363 [details]
Apparent large icon problem and missing network and vpn connections

Deleting the .cache files did not make any difference.
Cannot select and connect with VPN, must use alternate method.
OS is Gentoo.
Comment 22 Antonio Rojas 2018-06-16 13:05:23 UTC
*** Bug 395489 has been marked as a duplicate of this bug. ***
Comment 23 Kai Uwe Broulik 2018-06-16 18:18:20 UTC
Depends on icon theme and probably caused by the switch to QtQuick Layouts where counterintuitively "width" has no effect when the item has an implicit size. This is probably an easy fix by changing width to Layout.preferredWidth (likewise for height) in ConnectionItem
Comment 24 Jan Grulich 2018-06-18 05:50:43 UTC
Git commit 6dc2fc113a89fd14d4b5144485c639ac1e500e40 by Jan Grulich.
Committed on 18/06/2018 at 05:50.
Pushed by grulich into branch 'Plasma/5.13'.

Attempt to fix icon size for connection delegate

M  +2    -1    applet/contents/ui/ConnectionItem.qml

https://commits.kde.org/plasma-nm/6dc2fc113a89fd14d4b5144485c639ac1e500e40
Comment 25 Jan Grulich 2018-06-18 08:51:34 UTC
Git commit c43ae59a06b7f2b6324a5bfaba1dec357c17499d by Jan Grulich.
Committed on 18/06/2018 at 07:32.
Pushed by grulich into branch 'Plasma/5.13'.

Properly fix icon size for connection delegate

M  +2    -2    applet/contents/ui/ConnectionItem.qml

https://commits.kde.org/plasma-nm/c43ae59a06b7f2b6324a5bfaba1dec357c17499d
Comment 26 Jan Grulich 2018-06-18 17:56:16 UTC
*** Bug 395568 has been marked as a duplicate of this bug. ***
Comment 27 Jonathan Marten 2018-06-19 10:16:01 UTC
Confirmed fixed with current Plasma/5.13 sources.
Comment 28 Nate Graham 2018-06-21 19:21:08 UTC
*** Bug 395700 has been marked as a duplicate of this bug. ***