Bug 372189 - Dysfunctional areas with 1.5 scaling
Summary: Dysfunctional areas with 1.5 scaling
Status: RESOLVED UPSTREAM
Alias: None
Product: kmail2
Classification: Applications
Component: composereditor-ng (show other bugs)
Version: 5.3.44 pre (QtWebEngine)
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Laurent Montel
URL:
Keywords:
: 351816 368136 368571 372026 373081 374206 381627 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-07 16:46 UTC by Vishnu
Modified: 2017-06-27 19:53 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of KMail (235.61 KB, image/png)
2016-11-07 16:46 UTC, Vishnu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vishnu 2016-11-07 16:46:40 UTC
Created attachment 102106 [details]
Screenshot of KMail

The message display area does not scale with the display, and also, is not functional (can't click anything in it) when I scale the display to 1.5
Comment 1 Vishnu 2016-11-09 15:29:53 UTC
Setting the scaling to '2' solves this problem and additional screan tearing as well as bad res icon problems. But that is not a solution, as then, one has to decrease font size, which again may not be read by all application.

But this means that this is probably a compositor issue, and not that of KMail. So I will shift it there.
Comment 2 Christoph Feck 2016-11-11 15:37:05 UTC
No, it is a QtWebEngine bug. Please report this issue directly to Qt developers via https://bugreports.qt.io/
Comment 3 Vishnu 2016-11-12 04:44:27 UTC
Done: https://bugreports.qt.io/browse/QTBUG-57094
Comment 4 Christoph Feck 2016-12-07 14:44:04 UTC
*** Bug 372026 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Feck 2016-12-07 14:44:37 UTC
*** Bug 351816 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Feck 2016-12-07 14:44:55 UTC
*** Bug 368136 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2016-12-07 14:45:11 UTC
*** Bug 373081 has been marked as a duplicate of this bug. ***
Comment 8 Vishnu 2016-12-08 04:09:24 UTC
Btw, at least for me, this isn't an issue that affects just KMail. Other things like the terminal, and settings dialogs, and icon resolutions are all also bad. I am assuming these things don't use QtWebEngine. Do they?
Comment 9 Christoph Feck 2016-12-30 18:25:05 UTC
*** Bug 374206 has been marked as a duplicate of this bug. ***
Comment 10 Bo Simonsen 2017-01-04 07:39:23 UTC
It seems like the upstream bug is stalled due to lack of example. I know QT programming but not qtWebEngine, anybody with the knowledge that can reproduce an example for them?
Comment 11 Andreas Schneider 2017-02-02 11:50:52 UTC
With Plasma 5.90 and KDE Frameworks 5.30.0 I don't have the issue anymore.
Comment 12 Mauricio 2017-02-03 14:48:55 UTC
Still on Plasma 5.8 but Frameworks updated to 5.30 and can corroborate this is not an issue anymore for me.k
Comment 13 Vishnu 2017-02-03 15:26:17 UTC
I still have the problem. I'm on Plasma 5.8 and Frameworks 5.30.0
Comment 14 Mauricio 2017-02-04 14:24:50 UTC
Actually, I hasten to add that though the scaling has been "fixed," rendering is really poor, making it really hard to read. Does anyone else have this problem? I don't think it's an issue with the font per se because it's the only area of KMail that renders fonts this poorly. Screenshot here: http://imgur.com/a/VCKjM
Comment 15 Vishnu 2017-02-04 21:00:51 UTC
For me, at 1.5, font rendering is horrible in a lot of other places ass well; For example the screen that comes when you click logout/shutdown. Also, at a scaling of 2 (what is my current workaround - with reduced font size) okular has the same problem of grainy font rendering. I'm having to read pdfs in my browser.
Comment 16 Andreas Schneider 2017-02-06 07:11:37 UTC
Today I got an KDE update and the issue is back. This might be a KDE issue and not Qt ...
Comment 17 Christoph Feck 2017-06-12 00:22:56 UTC
*** Bug 368571 has been marked as a duplicate of this bug. ***
Comment 18 Andreas Schneider 2017-06-19 06:34:41 UTC
FYI: It is not fixed with Qt 5.9 yet. I've opened https://bugreports.qt.io/browse/QTBUG-61502
Comment 19 Christoph Feck 2017-06-27 19:53:30 UTC
*** Bug 381627 has been marked as a duplicate of this bug. ***