Bug 351816 - Kmail 15.08 Message Body does not follow the Font DPI settings.
Summary: Kmail 15.08 Message Body does not follow the Font DPI settings.
Status: RESOLVED DUPLICATE of bug 372189
Alias: None
Product: kmail2
Classification: Applications
Component: UI (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR major with 40 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL: http://i.imgur.com/Ljuksmd.png
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-26 17:56 UTC by Daniel Shafer
Modified: 2016-12-07 14:44 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Shafer 2015-08-26 17:56:05 UTC
When viewing messages, the font in the message body does not conform to the Font DPI settings in KDE.

Everything else does, except that one part.  The image doesn't quiet justify it as I am on a 4K screen, but you should be able to notice the differences in font size.  On my screen it is impossible to read.

Reproducible: Always

Steps to Reproduce:
1. Set Font DPI settings to a higher value.
2. Open Kmail on High DPI screen
3. Select message or open it in window
4. Obverse that message body does not conform to the Font DPI settngs

Actual Results:  
Message is imposible to read due to extremely low fonts

Expected Results:  
Message body should conform to Font DPI settings in System Settings
Comment 1 Bo Simonsen 2016-11-20 11:37:05 UTC
I can confirm this on openSUSE LEAP 42.2
Comment 2 Laurent Montel 2016-11-25 11:35:24 UTC
Screenshot please from font configurate in kmail + font from system + messageview after settings them please ?

it's wierd as we use QCoreApplication::setAttribute(Qt::AA_EnableHighDpiScaling); so it seems ok.
Comment 3 Christian Hägele 2016-12-01 19:57:04 UTC
I can confirm this on openSUSE LEAP 42.2, too.

I also found this comment in forums: https://forum.kde.org/viewtopic.php?f=215&t=136652
there are alos screenshots attached.

This problem makes KMail pretty much unusable with high DPI. Not only is the font too smal, but also the mouseclicks don't end up correctly. It's hard to show in a picture, but should be pretty easy to reproduce.
Comment 4 Bo Simonsen 2016-12-01 20:13:08 UTC
(In reply to Christian Hägele from comment #3)

> I also found this comment in forums:
> https://forum.kde.org/viewtopic.php?f=215&t=136652
> there are alos screenshots attached.

Exactly the result here as well.

Bo
Comment 5 Laurent Montel 2016-12-02 05:41:27 UTC
What is your kmail version + qt version ?
Comment 6 Christoph Feck 2016-12-07 14:44:37 UTC

*** This bug has been marked as a duplicate of bug 372189 ***