Bug 368136 - email only renders to a quarter of its designated space
Summary: email only renders to a quarter of its designated space
Status: RESOLVED DUPLICATE of bug 372189
Alias: None
Product: kmail2
Classification: Applications
Component: UI (show other bugs)
Version: 5.2.1
Platform: Gentoo Packages Linux
: NOR normal with 30 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-02 05:58 UTC by Lukas Schneiderbauer
Modified: 2016-12-07 14:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of kmail (806.33 KB, image/png)
2016-09-02 05:59 UTC, Lukas Schneiderbauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Schneiderbauer 2016-09-02 05:58:07 UTC
Kmail version: 5.3.0 /16.08.0 (was not pickable above)
Qt: 5.6.1

Email on my hidpi screen only renders to a quarter of its designated space,
see screenshot soon to be attached.
This also happens when "opening" the email into a new window.

Let me know if you need additional info.

Reproducible: Always
Comment 1 Lukas Schneiderbauer 2016-09-02 05:59:03 UTC
Created attachment 100892 [details]
screenshot of kmail
Comment 2 Georg Herdt 2016-09-09 19:27:54 UTC
Same behaviour here on OpenSuse tumbleweed using kmail 5.3.0 with KDE 5.25.0 and Qt 5.6.1
My screensize 3840x2160.
KMail is unusable on such displays.
Comment 3 Georg Herdt 2016-09-09 20:35:22 UTC
I found a workaround.
Launch KMail with this additional settings:
> QT_SCALE_FACTOR=2 kmail 

See this blog post to get an idea what is happening:
https://blog.qt.io/blog/2016/01/26/high-dpi-support-in-qt-5-6/

Seems to me as if KHTMLpart compnent does not behave well in some scenarios ...
Comment 4 Lukas Schneiderbauer 2016-09-09 21:34:16 UTC
I already have QT_SCREEN_SCALE_FACTORS set.
Besides, setting QT_SCALE_FACTOR=2 in addition just scales the user interface again. The original problem is there nonetheless.
Comment 5 Lukas Schneiderbauer 2016-09-10 09:36:28 UTC
In addition I should mention that the mouse interactions (cursor and clicks, selections) behave as if the email text were in its correct position. So just the "drawing" is wrong.
Comment 6 jonathan.lucas 2016-12-04 17:54:32 UTC
issue persists in kmail 5.3.3. 
similarly, once a specific mail is opened via double click in new window, it keeps being non-scaled as seen in Lukas' screenshot.
Comment 7 Christoph Feck 2016-12-07 14:44:55 UTC

*** This bug has been marked as a duplicate of bug 372189 ***