Bug 373081 - kmail2 doesn't render messages correctly with HiDPI
Summary: kmail2 doesn't render messages correctly with HiDPI
Status: RESOLVED DUPLICATE of bug 372189
Alias: None
Product: kmail2
Classification: Applications
Component: UI (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Laurent Montel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-29 17:56 UTC by Andreas Schneider
Modified: 2016-12-07 14:45 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kmail2 with HiDPI (624.46 KB, image/png)
2016-11-29 17:56 UTC, Andreas Schneider
Details
HiDPI without scaling (341.03 KB, image/png)
2016-12-04 13:44 UTC, Jure Repinc
Details
mail content not properly scaled in vertical preview mode (494.70 KB, image/png)
2016-12-04 17:57 UTC, jonathan.lucas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2016-11-29 17:56:21 UTC
Created attachment 102523 [details]
kmail2 with HiDPI

Hi,

I use scaling (kscreen -> scale display) to have things in a reasonable size on a UHD display. However the messages are not rendered correctly as you can see on the attached screenshot.
In the message I'm also not able to click on any link.
Comment 1 Andreas Schneider 2016-11-30 07:24:27 UTC
Kmail version 5.3.3
Comment 2 Christian Hägele 2016-12-01 20:08:13 UTC
I can confirm that issue for openSUSE Leap 42.2

Also see https://forum.kde.org/viewtopic.php?f=215&t=136652
Comment 3 Christian Hägele 2016-12-01 20:11:20 UTC
https://bugs.kde.org/show_bug.cgi?id=372026 looks like a duplicate to me. I don't know how I can link those 2 issues in bugzilla.
Comment 4 Andreas Schneider 2016-12-02 12:43:36 UTC
*** Bug 372026 has been marked as a duplicate of this bug. ***
Comment 5 Jure Repinc 2016-12-04 13:44:25 UTC
Created attachment 102612 [details]
HiDPI without scaling

This is how it looks on my system where I don't use scaling from KDE display settings but Xorg server is set to use 200 DPI. Notice that email title/subject in message view is not properly sized.
Comment 6 jonathan.lucas 2016-12-04 17:57:16 UTC
Created attachment 102621 [details]
mail content not properly scaled in vertical preview mode

issue also present in vertical preview mode
Comment 7 Andreas Schneider 2016-12-04 21:18:00 UTC
As more people have this issue. I think we can set it to CONFIRMED.
Comment 8 Christoph Feck 2016-12-07 14:45:11 UTC

*** This bug has been marked as a duplicate of bug 372189 ***