Bug 359783 - Right-column-aligned desktop icons move all the way to the left when icons are added or moved
Summary: Right-column-aligned desktop icons move all the way to the left when icons ar...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Folder (show other bugs)
Version: master
Platform: OpenSUSE Linux
: VHI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
: 417644 422035 426043 426766 427001 429765 433696 438030 440034 441477 442667 449676 450403 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-25 07:24 UTC by Gary L. Greene, Jr.
Modified: 2022-10-19 13:10 UTC (History)
25 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27


Attachments
Screenshot (2.10 MB, image/png)
2021-01-08 10:13 UTC, Riccardo Robecchi
Details
Jumping icons without panels as well (1.12 MB, image/gif)
2021-01-08 10:30 UTC, vector
Details
vertical panel settings overlap (20.79 KB, image/jpeg)
2021-01-16 10:11 UTC, vector
Details
Changes after relogin (73.27 KB, image/png)
2021-01-20 16:17 UTC, vector
Details
screenshot of Containment Debug Plasmoid widget (574.10 KB, image/png)
2021-01-20 16:19 UTC, Patrick Silva
Details
Video of the issue (675.79 KB, video/x-matroska)
2021-03-02 18:35 UTC, Riccardo Robecchi
Details
Backtraces (8.43 KB, text/plain)
2021-06-04 09:26 UTC, Oleg Solovyov
Details
attachment-28640-0.html (1.43 KB, text/html)
2021-06-16 20:20 UTC, Juan Pablo Firrincieli
Details
Recording of the screen showing the bugs (1.04 MB, image/gif)
2021-08-17 11:20 UTC, Nuno Gomes
Details
video recorded on neon unstable (865.42 KB, video/webm)
2022-05-03 19:40 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gary L. Greene, Jr. 2016-02-25 07:24:36 UTC
After configuring my icons to be on the right, on login, they show on the left. Once I click on the desktop, the icons properly reposition themselves on the right side of the screen.

Reproducible: Always

Steps to Reproduce:
1. Configure folder view for the desktop containment and then set the icons to align top to bottom on the right hand side of the screen.
2. Log out.
3. Log back in.

Actual Results:  
On login, you'll see the icons aligned to the LEFT. Clicking on the desktop will cause them to reposition to the right, as they are configured to be.

Expected Results:  
On login, they should be aligned top-to-bottom, on the RIGHT of the screen.

I'm using OpenSuSE's Git built RPMs from their OBS, but I'm pretty sure this isn't caused by a distribution patch, but rather is a legitimate bug.
Comment 1 Eike Hein 2016-02-25 09:09:07 UTC
Upstream GridView bug, still needs fixing.
Comment 2 Juan Pablo Firrincieli 2019-11-22 15:16:22 UTC
I can confirm that this bug it's still present on KDE Plasma 5.17.3 using KDE Neon.

I configured them right aligned and they start at left and then some times they move at start to the right (with animation) and other they align as right aligned but keep on the left side of the screen.
Comment 3 Nate Graham 2020-01-23 19:32:31 UTC
Can still reproduce with git master and Qt 5.13.1.

Eike, do you happen to have the URL of the GridView bug handy? Let's not mark this as RESOLVED UPSTREAM until we have a known Qt bug tracking it.
Comment 4 Vlad Zahorodnii 2020-08-09 18:27:52 UTC
*** Bug 422035 has been marked as a duplicate of this bug. ***
Comment 5 Vlad Zahorodnii 2020-08-09 18:28:03 UTC
*** Bug 417644 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2020-09-01 00:44:05 UTC
*** Bug 426043 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2020-09-01 00:44:40 UTC
Dupes piling up, setting to VHI.
Comment 8 Patrick Silva 2020-09-21 03:03:20 UTC
*** Bug 426766 has been marked as a duplicate of this bug. ***
Comment 9 Riccardo Robecchi 2020-09-22 10:22:33 UTC
(In reply to Patrick Silva from comment #8)
> *** Bug 426766 has been marked as a duplicate of this bug. ***

I did a search, but could not find anything. Thanks for pointing me towards this bug report.
Comment 10 Patrick Silva 2020-09-27 00:15:50 UTC
*** Bug 427001 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2020-12-01 17:44:36 UTC
*** Bug 429765 has been marked as a duplicate of this bug. ***
Comment 12 Nate Graham 2021-01-08 05:40:45 UTC
This is reproducible for me when I restart Plasma with a vertical panel, but not with a horizontal panel.
Comment 13 Riccardo Robecchi 2021-01-08 10:13:31 UTC
Created attachment 134655 [details]
Screenshot

(In reply to Nate Graham from comment #12)
> This is reproducible for me when I restart Plasma with a vertical panel, but
> not with a horizontal panel.

This is reproducible for me:
- with a horizontal panel
- without the need to restart Plasma
I can just drag a file to the desktop and the files are moved. See screenshot attached. The current title is therefore not accurate and that's why I'm changing it to something broader.
Comment 14 Riccardo Robecchi 2021-01-08 10:15:01 UTC
(In reply to Riccardo Robecchi from comment #13)
> I can just drag a file to the desktop and the files are moved. 

I obviously meant the icons, sorry for the confusion.
Comment 15 vector 2021-01-08 10:30:52 UTC
Created attachment 134656 [details]
Jumping icons without panels as well

(In reply to Nate Graham from comment #12)
> This is reproducible for me when I restart Plasma with a vertical panel, but
> not with a horizontal panel.

I've tested without panels, the issue still exists...
Comment 16 Patrick Silva 2021-01-08 11:04:39 UTC
I also can reproduce on neon unstable even with horizontal panel on bottom.
Comment 17 Nate Graham 2021-01-08 14:43:42 UTC
Huh.
Comment 18 terkald 2021-01-11 11:29:19 UTC
I almost published a bug report before I realized that there was already one. 

This bug happens under the same circumstances in openSUSE Tumbleweed in the latest version. However, it happens for me that this bug does not happen (it seems random).
Comment 19 Marco Martin 2021-01-13 17:46:02 UTC
just to log my findings, i thought that there possibly could have a resize event of the desktop view early in startup from small to big, with the layout code of folderview not correctly updating.. does not seem the case though
Comment 20 vector 2021-01-16 10:11:06 UTC
Created attachment 134923 [details]
vertical panel settings overlap

(In reply to Marco Martin from comment #19)
> just to log my findings, i thought that there possibly could have a resize
> event of the desktop view early in startup from small to big, with the
> layout code of folderview not correctly updating.. does not seem the case
> though

Maybe related to this issue that settings (if opened - on attahed picture)  of vertical panel if vertical panel is exists, overlap the horizontal panel as well
Comment 21 Marco Martin 2021-01-19 16:54:16 UTC
a likely culript is indeed struts and availablescreenrect that gets wrong
Comment 22 Marco Martin 2021-01-20 16:03:30 UTC
can you (or anybody that can reproduce) install the simple plasmoid https://www.pling.com/p/1472837/ and put it in the desktop? it should show some numbers (upload a screenshot then) that may shed some light if my theory is correct
Comment 23 Riccardo Robecchi 2021-01-20 16:06:38 UTC
(In reply to Marco Martin from comment #22)
> can you (or anybody that can reproduce) install the simple plasmoid
> https://www.pling.com/p/1472837/ and put it in the desktop? it should show
> some numbers (upload a screenshot then) that may shed some light if my
> theory is correct

Just tried it, it doesn't seem to detect any changes.
Comment 24 vector 2021-01-20 16:10:43 UTC
(In reply to Marco Martin from comment #22)
> can you (or anybody that can reproduce) install the simple plasmoid
> https://www.pling.com/p/1472837/ and put it in the desktop? it should show
> some numbers (upload a screenshot then) that may shed some light if my
> theory is correct

I tried as well, changed/changes 0 times
Comment 25 vector 2021-01-20 16:17:21 UTC
Created attachment 135018 [details]
Changes after relogin

I tried with relogin, attached screenshot
Comment 26 Patrick Silva 2021-01-20 16:19:59 UTC
Created attachment 135019 [details]
screenshot of Containment Debug Plasmoid widget

here is my screenshot after I reproduce the bug on neon unstable by dragging an icon on desktop horizontally and restart Plasma running "plasmashell --replace".
Comment 27 Riccardo Robecchi 2021-01-20 16:32:07 UTC
I made an additional trial: I restarted plasma (kquitapp5 plasmashell && kstart5 plasmashell) and that spammed the widget with resizes. After that, though, reproducing the bug doesn't add anything new.
Comment 28 Nate Graham 2021-03-02 18:20:37 UTC
*** Bug 433696 has been marked as a duplicate of this bug. ***
Comment 29 Riccardo Robecchi 2021-03-02 18:35:58 UTC
Created attachment 136327 [details]
Video of the issue

It seems like moving icons to new columns, so that the number of columns changes, is what triggers the issue. See video for reference.
Comment 30 Chromer 2021-03-03 07:40:41 UTC
Reproducible on Arch Linux with kernel 5.11.2 and KDE Plasma 5.21.1, Vertical panel.
Comment 31 Nate Graham 2021-04-28 16:40:09 UTC
This annoying bug appears to be fixed by the change made to fix Bug 436216!

Thanks Oleg!
Comment 32 Patrick Silva 2021-05-04 17:22:27 UTC
This bug persists on Arch Linux after update to Plasma 5.21.5 and reboot.
Comment 33 Nate Graham 2021-05-04 18:32:26 UTC
I'm starting to think that your computer is cursed, with all these bugs you're re-opening. It's fixed for me. :/ Maybe the full fix requires Plasma 5.22? Can you try again with Neon Unstable?
Comment 34 Patrick Silva 2021-05-04 19:36:24 UTC
I can also reproduce on neon unstable installed on another computer.
If the bug really persists, probably another affected user will comment here later.
Comment 35 Riccardo Robecchi 2021-05-07 17:51:21 UTC
(In reply to Nate Graham from comment #31)
> This annoying bug appears to be fixed by the change made to fix Bug 436216!
> 
> Thanks Oleg!

I can confirm it's still present on my machines with Plasma 5.21.5, so I am marking it as "confirmed" once again (sigh...).
Comment 36 Patrick Silva 2021-06-03 23:01:04 UTC
*** Bug 438030 has been marked as a duplicate of this bug. ***
Comment 37 Oleg Solovyov 2021-06-04 06:27:57 UTC
(In reply to Patrick Silva from comment #36)
> *** Bug 438030 has been marked as a duplicate of this bug. ***

Thanks
Comment 38 Oleg Solovyov 2021-06-04 09:26:33 UTC
Created attachment 138989 [details]
Backtraces
Comment 39 Oleg Solovyov 2021-06-11 14:13:51 UTC
Can't reproduce with Qt 5.13.2
Comment 40 Oleg Solovyov 2021-06-16 07:38:04 UTC
(In reply to Eike Hein from comment #1)
> Upstream GridView bug, still needs fixing.

It's a qt-quickcontrols (not quickcontrols2) issue.
5.12 is fine, 5.13 is broken.
Comment 41 Oleg Solovyov 2021-06-16 08:46:29 UTC
Breaks since 3d44442331ba6f1ba7a5d5ad9f3834993911e288 in qtquickcontrols
Comment 42 Nate Graham 2021-06-16 14:55:15 UTC
That commit was in 2019 though, and the bug report was originally opened in 2016.

Either way, I guess we need a Qt bug report. If you don't know of one, would you be able to flie one?
Comment 43 Juan Pablo Firrincieli 2021-06-16 20:20:14 UTC
Created attachment 139414 [details]
attachment-28640-0.html

I've created an account in Qt but being of no company it seems that I can
only search for opened bugs instead of open a new one, I couldn't find this
issue in the open bugs, but maybe there is one with technical info on it.

El mié, 16 de jun. de 2021 a la(s) 11:55, Nate Graham (
bugzilla_noreply@kde.org) escribió:

> https://bugs.kde.org/show_bug.cgi?id=359783
>
> --- Comment #42 from Nate Graham <nate@kde.org> ---
> That commit was in 2019 though, and the bug report was originally opened in
> 2016.
>
> Either way, I guess we need a Qt bug report. If you don't know of one,
> would
> you be able to flie one?
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 44 Oleg Solovyov 2021-06-17 07:54:10 UTC
(In reply to Nate Graham from comment #42)
> That commit was in 2019 though, and the bug report was originally opened in
> 2016.
You can check yourself whether reverting that commit fixes this bug or not.

> Either way, I guess we need a Qt bug report. If you don't know of one, would
> you be able to flie one?
Cannot file a bug yet, sorry but I'll do it later since I have a Qt account
Comment 45 Nate Graham 2021-06-17 15:15:34 UTC
I can't reliably reproduce it though. :(
Comment 46 Oleg Solovyov 2021-06-17 15:26:19 UTC
(In reply to Nate Graham from comment #45)
> I can't reliably reproduce it though. :(

I'll try on my Gentoo (see 438030 for how I reproduce it)
Comment 47 Oleg Solovyov 2021-06-17 15:38:18 UTC
(In reply to Oleg Solovyov from comment #46)
> (In reply to Nate Graham from comment #45)
> > I can't reliably reproduce it though. :(
> 
> I'll try on my Gentoo (see 438030 for how I reproduce it)

Just tried, 438030 is fixed.
Don't think it's a duplicate.
Comment 48 Nate Graham 2021-06-17 16:44:09 UTC
OK, feel free to un-dupe and mark as resolved.
Comment 49 Oleg Solovyov 2021-06-18 08:45:54 UTC
(In reply to Nate Graham from comment #48)
> OK, feel free to un-dupe and mark as resolved.

Un-duped but it's not resolved unless 3d44442 is reverted.
AFAIK, KDE have the whole QT forked since 5.15 is not supported/published after Qt6 release.
Comment 50 Patrick Silva 2021-07-20 19:16:03 UTC
*** Bug 440034 has been marked as a duplicate of this bug. ***
Comment 51 Vlad Zahorodnii 2021-08-13 17:27:31 UTC
It seems like this bug is caused by QQC1.ScrollView. Getting rid of it or replacing it with QQC2.ScrollView sort of fixes the problem. I don't know why QQC1.ScrollView causes this bug.

With a quick-and-dirty patch that removes PlasmaExtras.ScrollArea (aka QQC1.ScrollView) https://invent.kde.org/-/snippets/1791, icons are aligned as expected.

https://invent.kde.org/plasma/plasma-desktop/-/blob/56f49e47479dc7fc040922f3062ceddb01639d02/containments/desktop/package/contents/ui/FolderView.qml#L622
Comment 52 vector 2021-08-14 12:46:34 UTC
(In reply to Vlad Zahorodnii from comment #51)
> With a quick-and-dirty patch that removes PlasmaExtras.ScrollArea (aka
> QQC1.ScrollView) https://invent.kde.org/-/snippets/1791, icons are aligned
> as expected.

Working! Big thank you
Comment 53 Nuno Gomes 2021-08-17 11:17:42 UTC
I can confirm this bug in Manjaro and Garuda Linux.

KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2

The bug happens anytime a new icon is added to the desktop, or an icon is deleted or shifted. There is no need to re-login.
Moreover, if icons are sorted by type, when a new icon is added to the desktop, they become automatically unsorted.
Comment 54 Nuno Gomes 2021-08-17 11:20:53 UTC
Created attachment 140793 [details]
Recording of the screen showing the bugs

The icons realign to the right whenever the desktop is left-clicked.
Comment 55 vector 2021-08-18 06:22:41 UTC
(In reply to Nuno Gomes from comment #54)
> Created attachment 140793 [details]
> Recording of the screen showing the bugs
> 
> The icons realign to the right whenever the desktop is left-clicked.

You need apply Vlad's patch to fix this issue on Manjaro as well. We updated already Plasma on blackPanther OS, and patch solve this issue
Comment 56 Nuno Gomes 2021-08-18 10:56:45 UTC
(In reply to vector from comment #55)

> You need apply Vlad's patch to fix this issue on Manjaro as well. We updated
> already Plasma on blackPanther OS, and patch solve this issue

Thanks. I don't know how to do it in an effective way, I mean, without going to FolderView.qml and change every line manually. Any hint how to do it quickly and safely?
Comment 57 Nate Graham 2021-08-18 15:40:09 UTC
I wouldn't recommend that distros use Vlad's patch. It removes scrollability entirely, so users with tons and tons of desktop icons will lose the ability to access some of them from the desktop. It's a fairly drastic patch.
Comment 58 Nuno Gomes 2021-08-19 08:53:08 UTC
(In reply to Nate Graham from comment #57)
> I wouldn't recommend that distros use Vlad's patch. It removes scrollability
> entirely, so users with tons and tons of desktop icons will lose the ability
> to access some of them from the desktop. It's a fairly drastic patch.

Good to know. Thanks for the heads-up!
Comment 59 Nate Graham 2021-08-29 21:35:19 UTC
*** Bug 438030 has been marked as a duplicate of this bug. ***
Comment 60 Patrick Silva 2021-09-19 10:59:20 UTC
*** Bug 442667 has been marked as a duplicate of this bug. ***
Comment 61 Patrick Silva 2022-01-17 13:12:28 UTC
Plasma 5.24 beta on Arch Linux is also affected.
Comment 62 K Freed 2022-01-25 08:58:43 UTC
This has been an issue forever and I’ve been too lazy to report it. Glad it’s not only me.

Best way to reproduce: Move a file from the desktop to a new, empty COLUMN. This is important. You will notice icons immediately shift. Click the desktop to revert them back to how they were before.
Comment 63 Patrick Silva 2022-02-06 17:03:21 UTC
*** Bug 449676 has been marked as a duplicate of this bug. ***
Comment 64 galder 2022-02-06 17:19:41 UTC
*** Bug 441477 has been marked as a duplicate of this bug. ***
Comment 65 Nate Graham 2022-02-16 19:23:23 UTC
*** Bug 450403 has been marked as a duplicate of this bug. ***
Comment 66 Hervé Marest 2022-03-05 15:03:25 UTC
Same bug for me on Endeavour OS, plasma 5.24.2. Something about default position on the grid.
Comment 67 Nate Graham 2022-04-27 03:54:21 UTC
This is working perfectly for me with current git master, which includes the fix for Bug 354802 that also got backported to Plasma 5.24.5. I suspect that change might have fixed this issue too. For any of the people who have experienced this issue in the past, can you test again with either the current git master version of Plasma or else Plasma 5.24.5 once it's released in a week? Thanks!
Comment 68 ryu.ketsueki 2022-04-27 12:03:35 UTC
Still happens for me but it's also in specific situations. They need to be right aligned first. Then if you add a new column of icons, nice the existing ones or resize the panel size, either with plama panels or latte ones, they move back to the left until you click on them again. This happens a lot with me. I can record a video demonstrating it if needed
Comment 69 ryu.ketsueki 2022-04-27 12:04:37 UTC
Move the existing ones. Sorry, that was auto correct
Comment 70 Nate Graham 2022-04-27 19:16:54 UTC
Ryu, are you using Plasma from the master or Plasma/5.24 branch? Because the change hasn't made it into any released version yet.
Comment 71 ryu.ketsueki 2022-04-27 23:34:12 UTC
(In reply to Nate Graham from comment #70)
> Ryu, are you using Plasma from the master or Plasma/5.24 branch? Because the
> change hasn't made it into any released version yet.

As I can't built using kdesrc-build, I am using KDE Unstable Repos available for openSUSE, so I am in master. I can't tell which commit, though. I updated to latest packages today, however.
Comment 72 Nate Graham 2022-05-02 18:00:22 UTC
It's been a few days, so hopefully the packages have been updated to include the changes. Can you test again?
Comment 73 Patrick Silva 2022-05-02 18:35:46 UTC
The bug is still happening when I drag an icon on desktop horizontally.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 74 ryu.ketsueki 2022-05-02 23:11:59 UTC
I just updated to the latest available. I'm also having the same behavior of the icons when I move them around
Comment 75 Nate Graham 2022-05-03 18:33:46 UTC
If all of you who are using git master software can still reproduce the issue, it must be real and I'm just failing to reproduce it myself. Can one of you make a screen recording that shows a specific set of steps to reproduce it?
Comment 76 Patrick Silva 2022-05-03 19:40:47 UTC
Created attachment 148544 [details]
video recorded on neon unstable
Comment 77 ryu.ketsueki 2022-05-04 17:14:18 UTC
(In reply to Patrick Silva from comment #76)
> Created attachment 148544 [details]
> video recorded on neon unstable

Same behavior with me. Though I may note that it also happens on activity change. I think it has to do with how the icons are, by default, left aligned, and the right alignment configuration is not processed every time a change happens to the desktop icons. May be costy to check the configuration file every time but maybe it could be loaded into cache. It's just a guess, though. I don't know how the technical side of all this is.
Comment 78 Nate Graham 2022-09-15 16:33:20 UTC
In progress with https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1144!
Comment 79 Nate Graham 2022-10-13 19:19:11 UTC
Git commit 9035b461fef9ebd1fe2aad6726996c9e2d6e29fe by Nate Graham, on behalf of Marco Martin.
Committed on 13/10/2022 at 19:19.
Pushed by ngraham into branch 'master'.

Folderview: port to use ScrollView instead of ScrollArea

ScrollArea uses Qtquickcontrols1, so won't be able to run on qt6.
Don't use a ScrollView there as it always accepts inputs, so have to use a scrollbar directly in the flickable
FIXED-IN: 5.27

M  +9    -2    containments/desktop/package/contents/ui/FolderView.qml

https://invent.kde.org/plasma/plasma-desktop/commit/9035b461fef9ebd1fe2aad6726996c9e2d6e29fe
Comment 80 Patrick Silva 2022-10-19 13:07:25 UTC
Finally it's fixed on neon unstable! \o/
Can the fix for this old bug be backported to 5.26 branch? It would be very nice.
Comment 81 Vlad Zahorodnii 2022-10-19 13:10:00 UTC
(In reply to Patrick Silva from comment #80)
> Finally it's fixed on neon unstable! \o/
> Can the fix for this old bug be backported to 5.26 branch? It would be very
> nice.

No, it depends on KF changes.