Bug 345174 - [kdelibs] [kdebase-dolphin] Added folders to left panel "Places" disappear
Summary: [kdelibs] [kdebase-dolphin] Added folders to left panel "Places" disappear
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Arch Linux Linux
: NOR minor
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 345008 345635 345730 346320 346494 346509 346617 346928 347422 347893 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-15 10:34 UTC by Luca
Modified: 2015-11-16 20:48 UTC (History)
51 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.14.8
Sentry Crash Report:


Attachments
Bug Persists (2.15 MB, video/ogg)
2015-05-06 01:00 UTC, Robert Charbonneau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luca 2015-03-15 10:34:53 UTC
Added folders to the left panel "Places" disappear when dolphin is closed and then reopened.
I found that this bug was already fixed in kdelibs 14.12.3 according to https://bugs.kde.org/show_bug.cgi?id=342685 but it seems the bug reappeared in kdelibs 4.14.6-1.



Reproducible: Always

Steps to Reproduce:
1. Add a folder to the left panel "Places".
2. Close dolphin.
3. Reopen dolphin and the folder just added disappeared.



Arch x86_64
kdelibs 4.14.6-1
kdebase-dolphin 14.12.3-1
plasma-desktop 5.2.1-2
Comment 1 Antonio Rojas 2015-03-15 10:41:52 UTC
Unlike bug 342685 this is consistently reproducible: new bookmarks are always lost when restarting dolphin. Downgrading kdelibs to 4.14.5 fixed this (but the sorting issues in bug 342685 reappear of course)
Comment 2 Emmanuel Pescosta 2015-03-16 08:06:07 UTC
Thanks for the bug report!
I can reproduce the problem with kdelibs 4.14.6
Comment 3 Emmanuel Pescosta 2015-03-16 08:07:09 UTC
*** Bug 345008 has been marked as a duplicate of this bug. ***
Comment 4 Emmanuel Pescosta 2015-03-16 09:55:42 UTC
Also reproducible with Dolphin git + KF 5.8

The problem persists after reverting commit 2a79feae in kde-baseapps.
Comment 5 Emmanuel Pescosta 2015-03-16 10:49:12 UTC
All bookmark changes are properly written to disk (.local/share/kfileplaces/bookmarks.xml for KF5 and .kde4/share/apps/kfileplaces/bookmarks.xml for kdelibs4)

e.g. when I add test as bookmark following element will be added to bookmarks.xml:

<bookmark href="file:///home/emmanuel/test">
  <title>test</title>
  <info>
   <metadata owner="http://freedesktop.org">
    <bookmark:icon name="inode-directory"/>
   </metadata>
   <metadata owner="http://www.kde.org">
    <ID>1426502493/1</ID>
    <IsHidden>false</IsHidden>
   </metadata>
  </info>
 </bookmark>

Also updating bookmarks on all running instances works properly.

The problem happens while loading the bookmarks.
Comment 6 Emmanuel Pescosta 2015-03-16 11:04:34 UTC
KBookmarkGroup doesn't contain the "test" bookmark, will test it with KBookmarkGroupTraverser.
Comment 7 Emmanuel Pescosta 2015-03-20 07:47:50 UTC
*** Bug 345347 has been marked as a duplicate of this bug. ***
Comment 8 Emmanuel Pescosta 2015-03-20 08:06:19 UTC
Maybe related to https://bugs.kde.org/show_bug.cgi?id=292236 (comment #5)
Comment 9 Emmanuel Pescosta 2015-03-20 08:07:05 UTC
(In reply to Emmanuel Pescosta from comment #8)
> Maybe related to https://bugs.kde.org/show_bug.cgi?id=292236 (comment #5)

Sorry wrong bug (too many tabs open :S)
Comment 10 Wolfgang Bauer 2015-03-21 12:24:35 UTC
(In reply to Emmanuel Pescosta from comment #5)
> All bookmark changes are properly written to disk
> (.local/share/kfileplaces/bookmarks.xml for KF5 and
> .kde4/share/apps/kfileplaces/bookmarks.xml for kdelibs4)
> 
> e.g. when I add test as bookmark following element will be added to
> bookmarks.xml:
> 
> <bookmark href="file:///home/emmanuel/test">
>   <title>test</title>
>   <info>
>    <metadata owner="http://freedesktop.org">
>     <bookmark:icon name="inode-directory"/>
>    </metadata>
>    <metadata owner="http://www.kde.org">
>     <ID>1426502493/1</ID>
>     <IsHidden>false</IsHidden>
>    </metadata>
>   </info>
>  </bookmark>
> 
> Also updating bookmarks on all running instances works properly.
> 
> The problem happens while loading the bookmarks.

It seems to me that dolphin (kdelibs) only loads/respects ~/.local/share/user-places.xbel now, but ignores ~/.kde4/share/apps/kfileplaces/bookmarks.xml. If I add a bookmark to the latter (using a text editor), it doesn't show in dolphin (and in the file open/save dialog neither); if I add it to user-places.xbel, it works (in both dolphin and the file open/save dialog).

BTW, adding an entry in the file open/save dialog makes it appear in dolphin as well.
Comment 11 Kristjan 2015-03-21 16:05:00 UTC
(In reply to Wolfgang Bauer from comment #10)

> It seems to me that dolphin (kdelibs) only loads/respects
> ~/.local/share/user-places.xbel now, but ignores
> ~/.kde4/share/apps/kfileplaces/bookmarks.xml. If I add a bookmark to the
> latter (using a text editor), it doesn't show in dolphin (and in the file
> open/save dialog neither); if I add it to user-places.xbel, it works (in
> both dolphin and the file open/save dialog).
> 
> BTW, adding an entry in the file open/save dialog makes it appear in dolphin
> as well.

I've been wondering the whole day why my user-places.xbel is empty and why I can't add entries by dragging and dropping in Dolphin.

Thanks for the helpful information:)
Comment 12 Luca 2015-03-21 16:20:52 UTC
(In reply to Wolfgang Bauer from comment #10)
> (In reply to Emmanuel Pescosta from comment #5)
> > All bookmark changes are properly written to disk
> > (.local/share/kfileplaces/bookmarks.xml for KF5 and
> > .kde4/share/apps/kfileplaces/bookmarks.xml for kdelibs4)
> > 
> > e.g. when I add test as bookmark following element will be added to
> > bookmarks.xml:
> > 
> > <bookmark href="file:///home/emmanuel/test">
> >   <title>test</title>
> >   <info>
> >    <metadata owner="http://freedesktop.org">
> >     <bookmark:icon name="inode-directory"/>
> >    </metadata>
> >    <metadata owner="http://www.kde.org">
> >     <ID>1426502493/1</ID>
> >     <IsHidden>false</IsHidden>
> >    </metadata>
> >   </info>
> >  </bookmark>
> > 
> > Also updating bookmarks on all running instances works properly.
> > 
> > The problem happens while loading the bookmarks.
> 
> It seems to me that dolphin (kdelibs) only loads/respects
> ~/.local/share/user-places.xbel now, but ignores
> ~/.kde4/share/apps/kfileplaces/bookmarks.xml. If I add a bookmark to the
> latter (using a text editor), it doesn't show in dolphin (and in the file
> open/save dialog neither); if I add it to user-places.xbel, it works (in
> both dolphin and the file open/save dialog).
> 
> BTW, adding an entry in the file open/save dialog makes it appear in dolphin
> as well.

(In reply to Kristjan from comment #11)
> (In reply to Wolfgang Bauer from comment #10)
> 
> > It seems to me that dolphin (kdelibs) only loads/respects
> > ~/.local/share/user-places.xbel now, but ignores
> > ~/.kde4/share/apps/kfileplaces/bookmarks.xml. If I add a bookmark to the
> > latter (using a text editor), it doesn't show in dolphin (and in the file
> > open/save dialog neither); if I add it to user-places.xbel, it works (in
> > both dolphin and the file open/save dialog).
> > 
> > BTW, adding an entry in the file open/save dialog makes it appear in dolphin
> > as well.
> 
> I've been wondering the whole day why my user-places.xbel is empty and why I
> can't add entries by dragging and dropping in Dolphin.
> 
> Thanks for the helpful information:)

I can confirm that adding an entry in the open/save dialog makes it appear in dolphin. Additionally,  both ~/.kde4/share/apps/kfileplaces/bookmarks.xml and ~/.local/share/user-places.xbel get a new entry. So it seems that entries in ~/.local/share/user-places.xbel are ignored like Wolfgang Bauer suggests. 
Thanks for the tip!
Comment 13 Wolfgang Bauer 2015-03-21 16:33:29 UTC
(In reply to Luca from comment #12)
> So it seems that
> entries in ~/.local/share/user-places.xbel are ignored like Wolfgang Bauer
> suggests. 
No. Apparently only ~/.local/share/user-places.xbel is respected, ~/.kde(4)/share/apps/kfileplaces/bookmarks.xml seems to be ignored.

And dolphin only seems to write the bookmarks to ~/.kde(4)/share/apps/kfileplaces/bookmarks.xml... The file open/save dialog writes it to both, that's why that workaround helps.
Comment 14 Luca 2015-03-21 16:36:05 UTC
(In reply to Wolfgang Bauer from comment #13)
> (In reply to Luca from comment #12)
> > So it seems that
> > entries in ~/.local/share/user-places.xbel are ignored like Wolfgang Bauer
> > suggests. 
> No. Apparently only ~/.local/share/user-places.xbel is respected,
> ~/.kde(4)/share/apps/kfileplaces/bookmarks.xml seems to be ignored.
> 
> And dolphin only seems to write the bookmarks to
> ~/.kde(4)/share/apps/kfileplaces/bookmarks.xml... The file open/save dialog
> writes it to both, that's why that workaround helps.

Yeah, sorry i meant the opposite. :)
Comment 15 Emmanuel Pescosta 2015-03-21 17:05:45 UTC
(In reply to Wolfgang Bauer from comment #10)
> It seems to me that dolphin (kdelibs) only loads/respects
> ~/.local/share/user-places.xbel now, but ignores
> ~/.kde4/share/apps/kfileplaces/bookmarks.xml. If I add a bookmark to the
> latter (using a text editor), it doesn't show in dolphin (and in the file
> open/save dialog neither); 

The file path is determined by KStandardDirs::locateLocal("data", "kfileplaces/bookmarks.xml"), nothing has been changed on the Dolphin side, maybe some adjustments were made in kdelibs4?

> if I add it to user-places.xbel, it works (in both dolphin and the file open/save dialog).

Hmm strange, we only have a bookmark manager for "kfileplaces/bookmarks.xml" in Dolphin.

> BTW, adding an entry in the file open/save dialog makes it appear in dolphin
> as well.

The KFilePlacesModel (which is used by the open/save dialog) has a (private) KFilePlacesSharedBookmarks class, which syncs the bookmarks (user-places.xbel and kfileplaces/bookmarks.xml) on each change. Before the bookmarks race condition has been fixed, each places change in Dolphin implicitly triggered a bookmarks sync in the KFilePlacesModel -> So I assume, that we need to sync the bookmarks in Dolphin as well, but why do we store the bookmarks in two files? Why not only in bookmarks.xml?
Comment 16 Emmanuel Pescosta 2015-03-21 17:11:38 UTC
@Everyone:
Thanks for your help! 
All your active cooperation is immensely helpful for us! Awesome :D
Comment 17 Emmanuel Pescosta 2015-03-21 17:36:17 UTC
Ah ok, the xbel file comes from the freedesktop specification: http://freedesktop.org/wiki/Specifications/desktop-bookmark-spec/ 

@Marco:
Is it possible to move away from bookmarks.xml to user-places.xbel only? So that we can avoid the syncing.

The following code moves Dolphin to user-places.xbel (fixes the problem of disappearing places):
const QString file = QStandardPaths::writableLocation(QStandardPaths::GenericDataLocation) + "/user-places.xbel";
m_bookmarkManager = KBookmarkManager::managerForExternalFile(file);
Comment 18 Emmanuel Pescosta 2015-03-29 15:06:27 UTC
*** Bug 345635 has been marked as a duplicate of this bug. ***
Comment 19 Siddhartha 2015-04-01 13:38:57 UTC
Hi. Any update on this?
Comment 20 Emmanuel Pescosta 2015-04-02 05:47:04 UTC
(In reply to Siddhartha Sahu from comment #19)
> Hi. Any update on this?

We are working on it.
Comment 21 Emmanuel Pescosta 2015-04-02 06:00:58 UTC
*** Bug 345730 has been marked as a duplicate of this bug. ***
Comment 22 Pavel Nedrigailov 2015-04-09 18:16:01 UTC
cool, thank you! because it is very annoying when you can't save, say, all of your loooong fish:// paths
Comment 23 Emmanuel Pescosta 2015-04-20 09:04:20 UTC
*** Bug 346320 has been marked as a duplicate of this bug. ***
Comment 24 vonswallow 2015-04-21 08:59:34 UTC
i have the same bug

is there a way to manually add bookmarks as a work around  for now until its fixed
Reproducible: Always

Steps to Reproduce:
1. Add a folder to the left panel "Places".
2. Close dolphin.
3. Reopen dolphin and the folder just added disappeared.

Arch x86_64
plasma-desktop 5
Comment 25 Siddhartha 2015-04-21 09:34:20 UTC
(In reply to vonswallow from comment #24)
> is there a way to manually add bookmarks as a work around  for now until its
> fixed

You can add bookmarks using a file open/save dialog. Eg, Kate -> Ctrl+o -> add your bookmarks -> close Kate. Bookmarks will be saved for dolphin too.
Comment 26 vonswallow 2015-04-21 10:46:16 UTC
(In reply to Siddhartha Sahu from comment #25)
> (In reply to vonswallow from comment #24)
> > is there a way to manually add bookmarks as a work around  for now until its
> > fixed
> 
> You can add bookmarks using a file open/save dialog. Eg, Kate -> Ctrl+o ->
> add your bookmarks -> close Kate. Bookmarks will be saved for dolphin too.

Awesome!  it worked. Thanks
Comment 27 Emmanuel Pescosta 2015-04-23 08:57:12 UTC
*** Bug 346494 has been marked as a duplicate of this bug. ***
Comment 28 Emmanuel Pescosta 2015-04-23 15:00:03 UTC
*** Bug 346509 has been marked as a duplicate of this bug. ***
Comment 29 Unknown 2015-04-24 23:12:30 UTC
I'm having this problem as well. See video here: https://www.youtube.com/watch?v=n02J22NdqYI.

Running Kubuntu 15.04 x64 w/ KDE Plasma 5.2.95 via ppa:kubuntu-ppa/beta.
Comment 30 James0r 2015-04-27 04:39:18 UTC
I can confirm the disappearing places bookmarks on Arch Linux using plasma-desktop 5.2.95-1 and kdebase-dolphin 15.04.0-2. Placing bookmarks in 'places' using the Open File dialog with Kate allows them to be appear both in Dolphin and Open File dialogs. Using the workaround for now.
Comment 31 Harikrishnan 2015-04-27 09:15:35 UTC
Same problem for me too.
Using Kubuntu 15.04
Dolphin Version 14.12.3
KDE Development Platform 4.14.6
Comment 32 bugs5.kde.org 2015-04-27 09:31:52 UTC
also I'd like to have "Recently Saved" and "Search For" sections disappear instead of my added entries.
Comment 33 Emmanuel Pescosta 2015-04-27 09:40:59 UTC
*** Bug 346617 has been marked as a duplicate of this bug. ***
Comment 34 Emmanuel Pescosta 2015-04-27 09:47:10 UTC
Thanks for all the feedback!

The result of the discussion on the frameworks ML is, that we'll remove the legacy bookmarks syncing code (which causes this problem) from KFilePlacesModel and in future all applications will only use the cross desktop user-places.xbel instead of bookmarks.xml.
Comment 35 kajalsinha 2015-04-29 04:30:13 UTC
Can be reproduced on Kubuntu 15.04
Comment 36 pavel223344 2015-04-29 10:50:13 UTC
I can also confirm the bug on Kubuntu 15.04. In addition bookmarks created by the workaround with Kate (ctrl+o - drag and drop) are not working if they contain umlauts such as the Swedish letters å, ä, ö. When clicking on the bookmark in Dolphin it just says that the place does not exist.
Comment 37 Emmanuel Pescosta 2015-04-29 13:38:34 UTC
Git commit e919daeb5b144b146dbf459fadb116729b866d21 by Emmanuel Pescosta.
Committed on 29/04/2015 at 13:28.
Pushed by emmanuelp into branch 'master'.

Remove bookmarks syncing from KFilePlacesModel and use user-places.xbel only.

REVIEW: 123525
FIXED-IN: 5.10

CHANGELOG: Store bookmarks only in user-places.xbel.

M  +0    -1    src/filewidgets/CMakeLists.txt
M  +3    -18   src/filewidgets/kfileplacesmodel.cpp
D  +0    -285  src/filewidgets/kfileplacessharedbookmarks.cpp
D  +0    -57   src/filewidgets/kfileplacessharedbookmarks_p.h

http://commits.kde.org/kio/e919daeb5b144b146dbf459fadb116729b866d21
Comment 38 Emmanuel Pescosta 2015-04-29 13:43:26 UTC
Git commit 7550ef029988626ba6249f1de90e2a42e7a9f632 by Emmanuel Pescosta.
Committed on 29/04/2015 at 13:39.
Pushed by emmanuelp into branch 'master'.

Use user-places.xbel instead of bookmarks.xml in places model.

REVIEW: 123526
FIXED-IN: 15.08.0

M  +2    -2    src/panels/places/placesitemmodel.cpp

http://commits.kde.org/dolphin/7550ef029988626ba6249f1de90e2a42e7a9f632
Comment 39 Antonio Rojas 2015-04-29 14:54:29 UTC
Is this going to be fixed in the 15.04 branch too?
Comment 40 Emmanuel Pescosta 2015-04-29 14:56:03 UTC
(In reply to Antonio Rojas from comment #39)
> Is this going to be fixed in the 15.04 branch too?

RR [1] is already open, need to wait for a "ship it" ;)

[1] https://git.reviewboard.kde.org/r/123568/
Comment 41 Emmanuel Pescosta 2015-04-30 07:54:44 UTC
*** Bug 346928 has been marked as a duplicate of this bug. ***
Comment 42 Emmanuel Pescosta 2015-04-30 08:03:11 UTC
Git commit 5c0a31a2f2a46aa44b8c34baae67b6951b2abcaf by Emmanuel Pescosta.
Committed on 29/04/2015 at 14:05.
Pushed by emmanuelp into branch 'KDE/4.14'.

Remove bookmarks syncing from KFilePlacesModel and use user-places.xbel only.

FIXED-IN: 4.14.8
REVIEW: 123568

M  +0    -1    kfile/CMakeLists.txt
M  +3    -18   kfile/kfileplacesmodel.cpp
D  +0    -276  kfile/kfileplacessharedbookmarks.cpp
D  +0    -56   kfile/kfileplacessharedbookmarks_p.h

http://commits.kde.org/kdelibs/5c0a31a2f2a46aa44b8c34baae67b6951b2abcaf
Comment 43 Emmanuel Pescosta 2015-04-30 08:13:37 UTC
Git commit 270d2affaafcc9e87ba14f82bfe579e22607e2d2 by Emmanuel Pescosta.
Committed on 30/04/2015 at 08:12.
Pushed by emmanuelp into branch 'Applications/15.04'.

Use user-places.xbel instead of bookmarks.xml in places model.

FIXED-IN: 15.04.1

M  +2    -2    dolphin/src/panels/places/placesitemmodel.cpp

http://commits.kde.org/kde-baseapps/270d2affaafcc9e87ba14f82bfe579e22607e2d2
Comment 44 Kubuntiac 2015-05-01 19:02:12 UTC
Any chance someone could give a pointer on how to apply the fix to a current install without having to wait for it to come down the line from my distro? I'm using Kubuntu 15.04.
Comment 45 Guillaume Debray 2015-05-03 09:13:21 UTC
@Emmanuel Pescosta : Thanks for this fix, but how apply it ? I can't see any make file to compile it ?
I'm using Kubuntu 15.04 x64, (fresh install)
Comment 46 Emmanuel Pescosta 2015-05-03 12:17:07 UTC
(In reply to Kubuntiac from comment #44)
> Any chance someone could give a pointer on how to apply the fix to a current
> install without having to wait for it to come down the line from my distro?
> I'm using Kubuntu 15.04.

(In reply to Guillaume Debray from comment #45)
> @Emmanuel Pescosta : Thanks for this fix, but how apply it ? I can't see any
> make file to compile it ?
> I'm using Kubuntu 15.04 x64, (fresh install)

Clone [0] kdelibs, kio and kde-baseapps, download and apply the patches [1], compile [2] and install [3] them.

[0] git clone git://anongit.kde.org/{REPO_NAME}.git && cd {REPO_NAME}
[1] git apply "path/to/the/patch"
[2] mkdir build && cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .. && make -j4
[3] sudo make install

Or ask downstream to rebuild patched kdelibs, kio and kde-baseapps packages (like the Arch developers did :))
Comment 47 Wojciech Więckowski 2015-05-05 05:25:26 UTC
After update to version 15.04.0, platform KDE 4.14.7 drag and drop adding works OK. Adding by right click menu "Add to places" works until Dolphin restart. Thanks!
Comment 48 Siddhartha 2015-05-05 18:41:16 UTC
*** Bug 347248 has been marked as a duplicate of this bug. ***
Comment 49 Robert Charbonneau 2015-05-06 01:00:18 UTC
Created attachment 92444 [details]
Bug Persists

Kubuntu 15.04 w/Backports PPA; Dolphin 15.04.0 w/KDE 4.14.7
Comment 50 Guillaume Debray 2015-05-06 06:58:10 UTC
Same for me, bug persists on 15.04 Kubuntu
- Tried to ppa-purge backports, no effect.
- Tried to come back with the na tive theme (brise), no effect.
- Tried to delete ~/.kde/share/apps/dolphin, no effect.
Comment 51 bugs5.kde.org 2015-05-06 07:01:38 UTC
Same here, newly added places still vanish in Kubuntu 15.04 + Beta Backport PPA.

However what works now is that I can move places in the list. E.g. move one from the bottom to the top and that perserves restarts of Dolphin. Before, the place entries were just going back to the "original" order
Comment 52 Yoann Laissus 2015-05-06 07:26:09 UTC
The bug will be fixed in 15.04.1 which isn't released yet. (tag tomorrow)
Kubuntu doesn't seem to have backported the patch in 15.04 so you'll have to wait some more days ;)
Comment 53 Emmanuel Pescosta 2015-05-08 11:13:14 UTC
*** Bug 347422 has been marked as a duplicate of this bug. ***
Comment 54 Peter Stolz 2015-05-11 08:49:00 UTC
Same problem here, Ubuntu 15.04 with Unity Desktop and Dolphin 14.12.3.
Comment 55 Wolfgang Bauer 2015-05-11 10:10:26 UTC
(In reply to Peter Stolz from comment #54)
> Same problem here, Ubuntu 15.04 with Unity Desktop and Dolphin 14.12.3.

Again, this will (hopefully) be fixed in KDE Applications 15.04.1, to be released tomorrow.
Bug your distribution to include the fix in their packages or to update them.

There's no need for more "I still see this with Dolphin 14.12.3" comments here, IMHO.
This bug has originally been reported against dolphin 14.12.3 anyway.
Comment 56 Alain Laporte 2015-05-12 00:45:58 UTC
FYI : seems fixed with latest packages on ArchLinux. And it's strange, I don't use yet KDE Applications 15.04.1 :

$pacman -Qs kde | grep '15\.04'
local/filelight 15.04.0-1 (kde-applications kdeutils)
local/kate 15.04.0-1 (kde-applications kdebase)
local/kcalc 15.04.0-1 (kde-applications kdeutils)
local/kde-base-artwork 15.04.0-1
local/kdeadmin-ksystemlog 15.04.0-1 (kde-applications kdeadmin)
local/kdebase-dolphin 15.04.0-3 (kde-applications kdebase)
local/kdebase-kdialog 15.04.0-3 (kde-applications kdebase)
local/kdebase-keditbookmarks 15.04.0-3 (kde-applications kdebase)
local/kdebase-kfind 15.04.0-3 (kde-applications kdebase)
local/kdebase-konq-plugins 15.04.0-3 (kde-applications kdebase)
local/kdebase-konqueror 15.04.0-3 (kde-applications kdebase)
local/kdebase-lib 15.04.0-3
local/kdebase-runtime 15.04.0-4
local/kdegraphics-kolourpaint 15.04.0-1 (kde-applications kdegraphics)
local/kdegraphics-ksnapshot 15.04.0-1 (kde-applications kdegraphics)
local/kdegraphics-mobipocket 15.04.0-1 (kde-applications kdegraphics)
local/kdegraphics-okular 15.04.0-1 (kde-applications kdegraphics)
local/kdegraphics-strigi-analyzer 15.04.0-1
local/kdemultimedia-kmix 15.04.0-1 (kde-applications kdemultimedia)
local/kdenetwork-strigi-analyzers 15.04.0-1 (kde-applications kdenetwork)
local/kdesdk-strigi-analyzers 15.04.0-1 (kde-applications kdesdk)
local/kdeutils-ark 15.04.0-1 (kde-applications kdeutils)
local/kdeutils-kgpg 15.04.0-1 (kde-applications kdeutils)
local/kdeutils-kwalletmanager 15.04.0-1 (kde-applications kdeutils)
local/kompare 15.04.0-2 (kde-applications kdesdk)
local/konsole 15.04.0-1 (kde-applications kdebase)
local/kwrite 15.04.0-1 (kde-applications kdebase)
local/libkipi 15.04.0-1
local/okteta 15.04.0-1 (kde-applications kdesdk)
Comment 57 Wolfgang Bauer 2015-05-12 09:45:22 UTC
(In reply to Alain Laporte from comment #56)
> FYI : seems fixed with latest packages on ArchLinux. And it's strange, I
> don't use yet KDE Applications 15.04.1 :

Well, that's not so strange really. Arch apparently added the fixes to their 15.04.0 packages on April 30th (i.e. kdebase-dolphin 15.04.0-3 and kdelibs 4.14.7-2):
https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/kdebase
https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/kdelibs

So you're basically confirming that the fix works... ;-)
Comment 58 Emmanuel Pescosta 2015-05-20 11:27:51 UTC
*** Bug 347893 has been marked as a duplicate of this bug. ***
Comment 59 André Verwijs 2015-05-25 09:57:48 UTC
- Linux 3.16.7-21-desktop
- openSUSE 13.2 (Harlequin) (x86_64)
- KDE:  4.14.6
- Dolphin 14.12.3-16.5


Same problem here,  "/local/share/user-places.xbel"  is not being updated.. (witch saves "places" i think)  

or merge  git update with OpenSUSE package.... 

André
Comment 60 Wolfgang Bauer 2015-05-26 13:48:54 UTC
(In reply to André Verwijs from comment #59)
> - Linux 3.16.7-21-desktop
> - openSUSE 13.2 (Harlequin) (x86_64)
> - KDE:  4.14.6
> - Dolphin 14.12.3-16.5
> 
> 
> Same problem here,  "/local/share/user-places.xbel"  is not being updated..
> (witch saves "places" i think)  
So once again:
Yes, this is a problem in Dolphin 14.12.3, that's the version it has been reported against.

For openSUSE an update to the fixed 15.04.1 is on the way, but it will take a while.
Comment 61 Guillaume Debray 2015-05-31 15:48:11 UTC
Solved for me with the backports update (Kubuntu 15.04).
Thanks to the devs.
Comment 62 Naufal Fachrian 2015-06-01 00:16:14 UTC
Solved on openSUSE 13.2 with http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_13.2/ repository enabled.
Just wanna to say this bug was fixed.. Thanks to the devs! :)
Comment 63 Hermann 2015-07-01 11:57:04 UTC
(In reply to Naufal Fachrian from comment #62)
> Solved on openSUSE 13.2 with
> http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_13.2/
> repository enabled.
> Just wanna to say this bug was fixed.. Thanks to the devs! :)

I think I'm also affected by this bug (openSUSE 13.2) and here when I rearrange a places entry or delete one or add a new one it gets deleted immediately again (<1sec).

Furthermore when I rearrange/delete/add a places entry my whole plasma-desktop crashes (and I have to do 'killall plasma-desktop && plasma-desktop &' to bring it back). I've recorded a short video to demonstrate this "places bug", see https://youtu.be/m04DCjboKnA

So by above mentioned solution to add the KDE:Applications repo doesn't work here. I've upgrade my kde packages to the Applications repo versions but the dolphin problem still exists.

What I'm wondering is also the fact that my ~/.kde4/share/apps/kfileplaces/bookmarks.xml file is really (!) huge and becomming bigger and bigger (3,5MB now).

~  ll ~/.kde4/share/apps/kfileplaces/bookmarks.xml
-rw-r--r-- 1 heart users 3,5M  1. Jul 13:30 /home/heart/.kde4/share/apps/kfileplaces/bookmarks.xml

There are ~15000 lines of code in there which looks like again and again like shown here https://paste.kde.org/pabbfnjtc

(.local/share/user-places.xbel file looking good with 2,9K)

S | Name                               | Typ        | Version      | Arch   | Repository              
--+------------------------------------+------------+--------------+--------+-------------------------
i | Dolphin                            | Anwendung  |              | noarch | (Systempakete)          
i | dolphin                            | Paket      | 15.04.2-3.8  | x86_64 | KDE:Applications        

~  kde4-config --version
Qt: 4.8.6
KDE: 4.14.9
kde4-config: 1.0
Comment 64 Wolfgang Bauer 2015-07-01 21:39:30 UTC
(In reply to Hermann from comment #63)
> So by above mentioned solution to add the KDE:Applications repo doesn't work
> here. I've upgrade my kde packages to the Applications repo versions but the
> dolphin problem still exists.
It works fine here.

But adding this repo and installing dolphin from there is not necessary any more anyway.
Dolphin 15.04.1 and kdelibs 4.14.9 are available as official update for openSUSE 13.2.

> What I'm wondering is also the fact that my
> ~/.kde4/share/apps/kfileplaces/bookmarks.xml file is really (!) huge and
> becomming bigger and bigger (3,5MB now).
> 
> ~  ll ~/.kde4/share/apps/kfileplaces/bookmarks.xml
> -rw-r--r-- 1 heart users 3,5M  1. Jul 13:30
> /home/heart/.kde4/share/apps/kfileplaces/bookmarks.xml
> 
> There are ~15000 lines of code in there which looks like again and again
> like shown here https://paste.kde.org/pabbfnjtc

Wow, a lot of garbage has accumulated in there.
Just delete the whole folder /home/heart/.kde4/share/apps/kfileplaces/, the "places" are not stored there any more to fix this bug (and others).

Strange that it is still growing though. It shouldn't be used at all any more.
Is your system fully up to date?
All kdelibs* and libkde* packages in particular?

> (.local/share/user-places.xbel file looking good with 2,9K)
Looks ok, yes. But verify that the file is writable.

If you still have problems with the latest versions, you might try to delete that one as well and start fresh. Maybe it's gotten corrupted somehow by the earlier problems...

And I don't see how your plasma crashes would be related to this bug at all.
Comment 65 Hermann 2015-07-02 11:04:23 UTC
> But adding this repo and installing dolphin from there is not necessary any
> more anyway.
> Dolphin 15.04.1 and kdelibs 4.14.9 are available as official update for
> openSUSE 13.2.
 
> Wow, a lot of garbage has accumulated in there.
> Just delete the whole folder /home/heart/.kde4/share/apps/kfileplaces/, the
> "places" are not stored there any more to fix this bug (and others).
> 
> Strange that it is still growing though. It shouldn't be used at all any
> more.
> Is your system fully up to date?
> All kdelibs* and libkde* packages in particular?
Yes, it's fully up to date.

# zypper se -si kdelibs libkde dolphin
S | Name                       | Typ       | Version        | Arch   | Repository              
--+----------------------------+-----------+----------------+--------+-------------------------
i | Dolphin                    | Anwendung |                | noarch | (Systempakete)          
i | dolphin                    | Paket     | 15.04.2-3.8    | x86_64 | KDE:Applications        
i | kdelibs3-default-style     | Paket     | 3.5.10-83.1.10 | x86_64 | openSUSE 13.2 OSS       
i | kdelibs4                   | Paket     | 4.14.9-24.2    | x86_64 | openSUSE 13.2 OSS Update
i | kdelibs4-branding-openSUSE | Paket     | 13.2-3.6.1     | noarch | openSUSE 13.2 OSS       
i | kdelibs4-core              | Paket     | 4.14.9-24.2    | x86_64 | openSUSE 13.2 OSS Update
i | libKF5KDELibs4Support5     | Paket     | 5.10.0-21.19   | x86_64 | openSUSE 13.2 OSS Update
i | libkde4                    | Paket     | 4.14.9-24.2    | x86_64 | openSUSE 13.2 OSS Update
i | libkdecore4                | Paket     | 4.14.9-24.2    | x86_64 | openSUSE 13.2 OSS Update
i | libkdegames                | Paket     | 15.04.2-3.6    | x86_64 | KDE:Applications        
i | libkdegames4               | Paket     | 14.12.3-9.5    | x86_64 | KDE:Applications        
i | libkdegames6               | Paket     | 14.12.3-9.5    | x86_64 | KDE:Applications        
i | libkdepim4                 | Paket     | 4.14.9-24.2    | x86_64 | openSUSE 13.2 OSS Update
i | libkdepimlibs4             | Paket     | 4.14.9-24.1    | x86_64 | openSUSE 13.2 OSS Update

> If you still have problems with the latest versions, you might try to delete
> that one as well and start fresh. Maybe it's gotten corrupted somehow by the
> earlier problems...

What I tried now is totally removed ~/.kde4/share/apps/kfileplaces/ and removed also ~/.local/share/user-places* files.
BUT after logout and back in there was now functional plasma-desktop there!?! No kicker, no taskbar/systemtray icons, no plasma widgets, no desktop background picture...
Also 'killall plasma-desktop && plasma-desktop &' didn't bring back a working desktop in this stage :(

I added then a new user in a console and logged me in with this new user and voila, there I have a perfectly working kde/dolphin (incl. places entries working here).
So I copied the working ~/.local/share/user-places.xbel file from this new user to my old user (chowned to old user, home folder name to old user) and logged in again with the old user. Now I had a working desktop again!

The situation now is... I CAN add a new place in dolphin (this new entry still gets deleted automatically after 1 sec) BUT after this addition of a new places entry plasma-desktop crashes again :(! 

(but 'killall plasma-desktop && plasma-desktop &' and starting dolphin again now shows this newly added places entry <- this is new behavior)

I uploaded again a video showing my total desktop when doing above mentioned new places entry so you can see the plasma-desktop crash too.
youtube link to that video -> http://youtu.be/IGbEOMQTn6A (rendering could take a few nire minutes/hours from now)

Really strange :(
Comment 66 Hermann 2015-07-02 11:06:27 UTC
...should be: "...BUT after logout and back in there was NO functional plasma-desktop there!?!"
Comment 67 Wolfgang Bauer 2015-07-02 18:02:19 UTC
(In reply to Hermann from comment #65)
> Yes, it's fully up to date.

Ok.

> What I tried now is totally removed ~/.kde4/share/apps/kfileplaces/ and
> removed also ~/.local/share/user-places* files.
> BUT after logout and back in there was now functional plasma-desktop
> there!?! No kicker, no taskbar/systemtray icons, no plasma widgets, no
> desktop background picture...
> Also 'killall plasma-desktop && plasma-desktop &' didn't bring back a
> working desktop in this stage :(

Strange, that should have absolutely no impact on plasma-desktop.

> I added then a new user in a console and logged me in with this new user and
> voila, there I have a perfectly working kde/dolphin (incl. places entries
> working here).
> So I copied the working ~/.local/share/user-places.xbel file from this new
> user to my old user (chowned to old user, home folder name to old user) and
> logged in again with the old user. Now I had a working desktop again!
> 
> The situation now is... I CAN add a new place in dolphin (this new entry
> still gets deleted automatically after 1 sec) BUT after this addition of a
> new places entry plasma-desktop crashes again :(! 

That it works with a new user account shows that the bug is fixed.
But again, check that the file is writeable for your user. Depending on how you copied it, that might not be the case.

> Really strange :(

Yes, and especially your Plasma crashes are totally unrelated to this fixed bug report.

And I still don't see any relation to Plasma, Plasma should not care at all whether user-places.xbel exists.
Probably you added some Plasmoid that makes use of it? In this case that might also be the reason why places get removed again automatically.
Try to delete (or at least temporary rename) Plasma's config as well: ~/.kde4/share/config/plasma*

And if Plasma crashes, you should file a bug report against Plasma. But it would be good to find out first which Plasmoid causes this.
Comment 68 Hermann 2015-07-03 07:30:45 UTC
Wolfgang, thank you for your patience.... I found it!

The plasma-widget "Homerun-Kicker" (https://blogs.kde.org/2014/01/29/homerun-120) causing this plasma-desktop crash!!!!

I removed the homerun-kicker plasmoid and voila, no more plasma-desktop crashes when editing my dolphin places entries!

~  zypper se -si homerun
S | Name           | Typ   | Version    | Arch   | Repository
--+----------------+-------+------------+--------+-----------
i | homerun        | Paket | 1.2.5-19.6 | x86_64 | KDE:Extra 
i | homerun-kicker | Paket | 1.2.5-19.6 | x86_64 | KDE:Extra 
i | libhomerun0    | Paket | 1.2.5-19.6 | x86_64 | KDE:Extra
Comment 69 Hermann 2015-07-03 07:41:01 UTC
sumbitted also a new bug in homerun project, https://bugs.kde.org/show_bug.cgi?id=349850
Comment 70 Wolfgang Bauer 2015-07-03 09:47:45 UTC
(In reply to Hermann from comment #68)
> Wolfgang, thank you for your patience.... I found it!
Great!

> The plasma-widget "Homerun-Kicker"
> (https://blogs.kde.org/2014/01/29/homerun-120) causing this plasma-desktop
> crash!!!!
And I suppose it also overwrote your changes to the places.

From a quick look at the source code it seems that this still uses both files, and probably tries to synchronize them as well. That's what mainly caused problems in the past, and got removed in kdelibs and dolphin to fix this (and other) bugs. They only use user-places.xbel now.

Maybe there would be an option to turn the "places" off in Homerun?
This might be a workaround.

(In reply to Hermann from comment #69)
> sumbitted also a new bug in homerun project,
> https://bugs.kde.org/show_bug.cgi?id=349850
Thanks.
Comment 71 Mateusz 2015-11-16 15:19:20 UTC
I would really like to know why are bugs like this one not being caught(and resolved) during the final testing.
At some point there was a situation in which the user downloads 'ready product', installs it and such important feature is not working. He/she decides to install other distro then.
All this hype, and fancy banners, and we receive unfinished product, even though they claim it to be stable. I know this bug is long gone by now, but I would really like to know the answer.
In my opinion:
- not saving bookmarks - not ready
- not working network manager - not ready
- random crashes when connecting second display - definitely not ready
- cpu stuck at pathetically low frequency after waking up from sleep - not ready;))
Comment 72 Stefan Gies 2015-11-16 20:48:56 UTC
@Mateusz: It seems, that this is "banana-software" :-))