Bug 340393 - Full path to search results is difficult to see
Summary: Full path to search results is difficult to see
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: search (show other bugs)
Version: 4.14.0
Platform: Debian testing Linux
: NOR wishlist with 45 votes (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: usability
: 268697 304890 402982 419304 432322 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-27 12:38 UTC by mau
Modified: 2022-03-28 19:15 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mau 2014-10-27 12:38:51 UTC
If one searches for a file or folder and gets several results, it is not easy to see where they belong to.

Example:
A user has a file called myFile.txt in several locations, assume $HOME/Documents and in $HOME/tmp.
If she searches for it by filename and does search in everywhere, she gets both as a result. But how can she distinguish between them? Only by the complete path.
Now she has to add the complete path as a column to dolphin and move it to the left in order to see it without the need to scroll, but then it's still there if she "closes" search, which might not be necessary at all or even disturb her.

So dolphin currently lacks the possibility to easily see where a search result has been found.

There should be a place where this Information is shown or can be shown, I think of either the information panel on the right or the status bar.

Reproducible: Always
Comment 1 Emmanuel Pescosta 2014-10-27 12:42:38 UTC
> So dolphin currently lacks the possibility to easily see where a search result has been found.

Enabling "Additional Information -> Other -> Path" should work.
Comment 2 mau 2014-10-28 13:46:18 UTC
As I've written in my report that works, but:
It adds the path to the columns that are always shown - not only during a search!
So someone who wants to keep the dolphin window light and clear and therefore only selects the most important columns (which don't include the path since it is quite long most of the time) cannot see where a search result belongs to.
But with my proposition of always showing the path of the selected search result in the status bar or inside the information panel, this problem is eased.
Comment 3 Emmanuel Pescosta 2014-10-28 14:08:56 UTC
> It adds the path to the columns that are always shown - not only during a search!

Do you have "Use common properties for all folders" enabled in Settings -> General -> Behavior?
It should work with "Remember properties for each folder" ;)
Comment 4 Emmanuel Pescosta 2014-10-28 14:12:35 UTC
> howing the path of the selected search result in the status bar

Good idea! Dolphin does something similar for links already, maybe we can reuse it. Will have a look at it ;)
Comment 5 mau 2014-10-29 07:18:08 UTC
Yeah that's true, for links the target is shown; would be great to have the same in the search results view!

Thanks for looking into this!
Comment 6 Emmanuel Pescosta 2014-10-29 07:37:57 UTC
KFileItem::getStatusBarInfo() has the functionality to detect "target url != url" matches already :)

So we have to adjust the filename- and baloosearch ioslaves, so that they report the target url properly.
Comment 7 Nate Graham 2017-09-03 05:55:27 UTC
*** Bug 304890 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2017-09-03 06:01:08 UTC
*** Bug 268697 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2019-10-27 22:44:09 UTC
*** Bug 402982 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2020-04-22 03:54:50 UTC
*** Bug 419304 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2021-02-01 16:44:38 UTC
*** Bug 432322 has been marked as a duplicate of this bug. ***
Comment 12 witchhunter 2021-02-02 19:59:10 UTC
(In reply to Nate Graham from comment #11)
> *** Bug 432322 has been marked as a duplicate of this bug. ***

OK, since this has been marked as a duplicate, I strongly suggest that solution would imply showing location on dolphin' information panel instead of on status bar, as it is already used for other things and enabling split view would make it even more difficult to see location even on maximized window.
Comment 13 witchhunter 2021-02-02 20:07:24 UTC
Also, possibly related Bug 186376
Comment 14 Nate Graham 2021-02-02 20:15:25 UTC
Definitely related, yeah. Adding this functionality to the Information Panel makes sense.
Comment 15 Kai Uwe Broulik 2022-03-28 15:08:50 UTC
Git commit 466fa20f7faf26ef2df2453da1622e0805564140 by Kai Uwe Broulik.
Committed on 28/03/2022 at 12:56.
Pushed by broulik into branch 'release/22.04'.

[ViewProperties] Apply better default roles for special views

This adds the following additional special view modes (some of them were
already there but broken because they weren't applied, or were
changed to have better defaults now that they are actually used):

* Recent Files and Recent Documents, timeline:
  Details view with grouped sorting enabled and Name, Path, Modified
* Search For Images:
  Icon view with Name, Dimensions, Date Time of the Picture
* Search For Audio:
  Details view with Name, Artist, Album, Duration
* Search For Videos:
  Icon view with just Name
* Search For everything else, including Documents:
  Details view with Name, Path, Modified
* Trash:
  Details view with Name, (Original) Path, Deletion Time
Related: bug 400969, bug 186376
FIXED-IN: 22.04.0

M  +31   -10   src/views/viewproperties.cpp

https://invent.kde.org/system/dolphin/commit/466fa20f7faf26ef2df2453da1622e0805564140
Comment 16 H.H. 2022-03-28 19:15:43 UTC
Great, thanks!