Bug 268697 - new file search does not show folder
Summary: new file search does not show folder
Status: RESOLVED DUPLICATE of bug 340393
Alias: None
Product: dolphin
Classification: Applications
Component: search (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-17 00:48 UTC by H.H.
Modified: 2017-09-03 06:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H.H. 2011-03-17 00:48:26 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

The new file search works (although I liked kfind better, and there is no possibility to place a kfind-button in the dolphin toolbar anymore :-( ), 

but it does only show the standard-columns. I think the folder-column is very important for a search (to know to location of the found file). There should be an extra configuration for that view. In normal folder-view you don't want to view the folder-column generally.

Reproducible: Always




OS: Linux (x86_64) release 2.6.37.1-1.2-desktop
Compiler: gcc
Comment 1 Peter Penz 2011-03-17 08:27:14 UTC
If it shows only the standard columns, then most probably you've activated the "[x] Use common view Properties for all folders". Per default in Dolphin the search-view is configured to show the path-column.
Comment 2 H.H. 2011-03-17 11:20:17 UTC
this is right, but this view should make an exception from that setting (and without that setting I would go mad!)
Comment 3 Peter Penz 2011-03-17 12:26:45 UTC
Well I have made an exception in KDE 4.6 beta and got bug-reports that this is not wanted, so I fixed it for 4.6.0 ;-)

I'm leaving this issue open as wish. If other users report a similar request I'll make a special case for this even if "Use common view properties for all folders" is activated.
Comment 4 H.H. 2011-03-17 13:15:22 UTC
ok, thanks
Comment 5 Christoph Feck 2011-03-17 14:23:45 UTC
> [x] Use common view Properties for all folders

Well, but the search result is only a "virtual" folder, containing files that are actually contained in a different folder.

> There should be an extra configuration for that view

Exactly. I wouldn't even mind if it is always visible, like in KFind. When I search something I would really like to know where it is found.
Comment 6 Peter Penz 2011-03-17 14:34:10 UTC
@Christoph: I agree with you, that's why I've implemented it this way in the beta-cycle (and reverted for 4.6.0 because of a bug-report). I'd just like to wait a little bit for further input before reverting this again...
Comment 7 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:18:40 UTC
Resetting assignee to default as per bug #305719
Comment 8 Nate Graham 2017-09-03 06:01:08 UTC
The sentiment expressed here is basically the same as what's asked for in https://bugs.kde.org/show_bug.cgi?id=340393

*** This bug has been marked as a duplicate of bug 340393 ***