Bug 186376 - Should be able to show original location for items placed in the trash
Summary: Should be able to show original location for items placed in the trash
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: details mode (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: usability
: 231537 389786 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-06 19:34 UTC by Angel Blue01
Modified: 2022-03-28 15:09 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Angel Blue01 2009-03-06 19:34:57 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    SuSE RPMs

The Trash should have an additional column for Original Location- the original location in the file system for all files in the Trash.

Trash already has a Restore feature, but there is no way to see where that location is. Months after sending a file to trash, this feature would help users know where this file came from and where it's going if they restore it.
Comment 1 FiNeX 2010-08-16 12:14:41 UTC
@Peter: what do you think about this? Recently I've seen a screenshot of the latest nautilus which display a column (only when displaying the trash) with the original path of the file and I've really liked the idea :-)
Comment 2 FiNeX 2010-08-16 12:16:05 UTC
bug #100801 is related to this
Comment 3 Alexander Potashev 2011-07-17 08:54:16 UTC
*** Bug 231537 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2018-04-16 19:39:30 UTC
*** Bug 389786 has been marked as a duplicate of this bug. ***
Comment 5 Patrick Silva 2018-11-13 10:41:51 UTC
bug 400969 is related.
Comment 6 Ahmad Samir 2020-12-06 19:42:46 UTC
KIO only provides kio_trash; this would be fixed in Dolphin, which creates/defines the columns.

And I think this is already implemented, sort of; right click the columns header bar, enable Other -> Path, that path is the original path. Maybe when Dolphin is at trash:/ it should say "Original Path" instead.
Comment 7 Nate Graham 2020-12-07 15:50:03 UTC
Oh that's a good idea.
Comment 8 Kai Uwe Broulik 2022-03-28 15:09:06 UTC
Git commit 466fa20f7faf26ef2df2453da1622e0805564140 by Kai Uwe Broulik.
Committed on 28/03/2022 at 12:56.
Pushed by broulik into branch 'release/22.04'.

[ViewProperties] Apply better default roles for special views

This adds the following additional special view modes (some of them were
already there but broken because they weren't applied, or were
changed to have better defaults now that they are actually used):

* Recent Files and Recent Documents, timeline:
  Details view with grouped sorting enabled and Name, Path, Modified
* Search For Images:
  Icon view with Name, Dimensions, Date Time of the Picture
* Search For Audio:
  Details view with Name, Artist, Album, Duration
* Search For Videos:
  Icon view with just Name
* Search For everything else, including Documents:
  Details view with Name, Path, Modified
* Trash:
  Details view with Name, (Original) Path, Deletion Time
Related: bug 400969, bug 340393
FIXED-IN: 22.04.0

M  +31   -10   src/views/viewproperties.cpp

https://invent.kde.org/system/dolphin/commit/466fa20f7faf26ef2df2453da1622e0805564140