Bug 400969 - Deletion Date should be shown for items in the trash
Summary: Deletion Date should be shown for items in the trash
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kio
Classification: Unclassified
Component: Trash (show other bugs)
Version: git master
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-12 17:00 UTC by sac
Modified: 2022-03-28 15:08 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sac 2018-11-12 17:00:50 UTC
SUMMARY
Currently there's no way to sort for the recent deleted files in the trash folder. Also verifying the file properties doesn't show the delete date or original path.

STEPS TO REPRODUCE
1. Open trash folder
2. Try to identify the file that was deleted most recently

OBSERVED RESULT
Delete Date & Original path is not shown within trash folder

EXPECTED RESULT
Delete Date & Original path should show within trash folder and one should be able to sort according to trash date.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Kubuntu
KDE Plasma Version: 5.14.3
KDE Frameworks Version: 5.51.0
Qt Version: 5.11.1

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2018-11-13 10:59:07 UTC
Bug 186376 tracks showing the original path. Let's use this for deletion date.
Comment 2 Kai Uwe Broulik 2022-03-28 15:08:58 UTC
Git commit 466fa20f7faf26ef2df2453da1622e0805564140 by Kai Uwe Broulik.
Committed on 28/03/2022 at 12:56.
Pushed by broulik into branch 'release/22.04'.

[ViewProperties] Apply better default roles for special views

This adds the following additional special view modes (some of them were
already there but broken because they weren't applied, or were
changed to have better defaults now that they are actually used):

* Recent Files and Recent Documents, timeline:
  Details view with grouped sorting enabled and Name, Path, Modified
* Search For Images:
  Icon view with Name, Dimensions, Date Time of the Picture
* Search For Audio:
  Details view with Name, Artist, Album, Duration
* Search For Videos:
  Icon view with just Name
* Search For everything else, including Documents:
  Details view with Name, Path, Modified
* Trash:
  Details view with Name, (Original) Path, Deletion Time
Related: bug 340393, bug 186376
FIXED-IN: 22.04.0

M  +31   -10   src/views/viewproperties.cpp

https://invent.kde.org/system/dolphin/commit/466fa20f7faf26ef2df2453da1622e0805564140