Bug 330699 - KPatience crash when starting "Aces Up"
Summary: KPatience crash when starting "Aces Up"
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-03 12:01 UTC by Jon Ahlquist
Modified: 2014-02-03 13:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Ahlquist 2014-02-03 12:01:45 UTC
Application: kpat (3.6)
KDE Platform Version: 4.11.5
Qt Version: 4.8.5
Operating System: Linux 3.12.7-300.fc20.i686+PAE i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed: I selected the game "Aces UP," which I had never tried before, and it crashed instantly.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#7  0x4f0d2a63 in lock (this=0x9721068) at /usr/src/debug/kdelibs-4.11.5/kdecore/util/kshareddatacache.cpp:1233
#8  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0xbf9e04a0) at /usr/src/debug/kdelibs-4.11.5/kdecore/util/kshareddatacache.cpp:1257
#9  0x4f0d369f in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0xbf9e04a0, _d=0x9721068) at /usr/src/debug/kdelibs-4.11.5/kdecore/util/kshareddatacache.cpp:1280
#10 0x4f0caee1 in KSharedDataCache::find (this=this@entry=0x96b8420, key=..., destination=destination@entry=0xbf9e0504) at /usr/src/debug/kdelibs-4.11.5/kdecore/util/kshareddatacache.cpp:1632
#11 0x5018aac8 in KImageCache::findPixmap (this=0x96b8420, key=..., destination=0xbf9e0570) at /usr/src/debug/kdelibs-4.11.5/kdeui/util/kimagecache.cpp:150
#12 0x413f8f93 in KAbstractCardDeckPrivate::submitRendering(QString const&, QImage const&) () from /lib/libkcardgame.so
#13 0x413f9366 in KAbstractCardDeckPrivate::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /lib/libkcardgame.so
#14 0x4eb1aceb in QMetaCallEvent::placeMetaCall (this=0xb1fa3f00, object=0x97303c8) at kernel/qobject.cpp:524
#15 0x4eb2302b in QObject::event (this=0x97303c8, e=0xb1fa3f00) at kernel/qobject.cpp:1194
#16 0x4f2c3054 in QApplicationPrivate::notify_helper (this=0x952d700, receiver=0x97303c8, e=0xb1fa3f00) at kernel/qapplication.cpp:4562
#17 0x4f2c9fac in QApplication::notify (this=0xbf9e0cdc, receiver=0x97303c8, e=e@entry=0xb1fa3f00) at kernel/qapplication.cpp:4348
#18 0x50117cd0 in KApplication::notify (this=0xbf9e0cdc, receiver=0x97303c8, event=0xb1fa3f00) at /usr/src/debug/kdelibs-4.11.5/kdeui/kernel/kapplication.cpp:311
#19 0x4eb08a86 in QCoreApplication::notifyInternal (this=0xbf9e0cdc, receiver=receiver@entry=0x97303c8, event=event@entry=0xb1fa3f00) at kernel/qcoreapplication.cpp:949
#20 0x4eb0befa in sendEvent (event=0xb1fa3f00, receiver=0x97303c8) at kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x9501018) at kernel/qcoreapplication.cpp:1573
#22 0x4eb0c3fd in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1466
#23 0x4eb3ae9f in sendPostedEvents () at kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=s@entry=0x9536f18) at kernel/qeventdispatcher_glib.cpp:280
#25 0x48c3a556 in g_main_dispatch (context=0x952d908) at gmain.c:3066
#26 g_main_context_dispatch (context=context@entry=0x952d908) at gmain.c:3642
#27 0x48c3a920 in g_main_context_iterate (context=context@entry=0x952d908, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
#28 0x48c3a9e9 in g_main_context_iteration (context=0x952d908, may_block=1) at gmain.c:3774
#29 0x4eb3a630 in QEventDispatcherGlib::processEvents (this=this@entry=0x9508000, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#30 0x4f37977c in QGuiEventDispatcherGlib::processEvents (this=0x9508000, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#31 0x4eb073c0 in QEventLoop::processEvents (this=this@entry=0xbf9e0be4, flags=...) at kernel/qeventloop.cpp:149
#32 0x4eb07751 in QEventLoop::exec (this=this@entry=0xbf9e0be4, flags=...) at kernel/qeventloop.cpp:204
#33 0x4eb0d40b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#34 0x4f2c1365 in QApplication::exec () at kernel/qapplication.cpp:3823
#35 0x0805b9d7 in main ()

The reporter indicates this bug may be a duplicate of or related to bug 309824.

Possible duplicates by query: bug 330402, bug 329564, bug 328177, bug 326875, bug 323698.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-02-03 13:30:01 UTC

*** This bug has been marked as a duplicate of bug 309824 ***