Bug 329564 - KPatience card game crashed
Summary: KPatience card game crashed
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kshareddatacache (show other bugs)
Version: 4.11.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-03 14:47 UTC by Jon Ahlquist
Modified: 2014-01-28 13:09 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.23 KB, text/plain)
2014-01-12 12:15 UTC, JAMES
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Ahlquist 2014-01-03 14:47:34 UTC
Application: kpat (3.6)
KDE Platform Version: 4.11.4
Qt Version: 4.8.5
Operating System: Linux 3.12.5-302.fc20.i686+PAE i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed: I was trying to resize the window by using the mouse cursor to grab the lower right corner of the window. I was using the trackpad on my laptop to control the cursor. I had a lot of trouble grabbing the window because the coner area of the window that will allowing resizing is too small. After trying mulltiple times to grab the corner of the window, KPatience crashed.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#6  0xb6ec49d3 in KSharedDataCache::Private::CacheLocker::cautiousLock() () from /lib/libkdecore.so.5
#7  0xb6ec560f in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /lib/libkdecore.so.5
#8  0xb6ebce51 in KSharedDataCache::find(QString const&, QByteArray*) const () from /lib/libkdecore.so.5
#9  0xb71c6968 in KImageCache::findPixmap(QString const&, QPixmap*) const () from /lib/libkdeui.so.5
#10 0xb775ff93 in KAbstractCardDeckPrivate::submitRendering(QString const&, QImage const&) () from /lib/libkcardgame.so
#11 0xb7760366 in KAbstractCardDeckPrivate::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /lib/libkcardgame.so
#12 0x49274cdb in QMetaCallEvent::placeMetaCall(QObject*) () from /lib/libQtCore.so.4
#13 0x4927d01b in QObject::event(QEvent*) () from /lib/libQtCore.so.4
#14 0x4b86e084 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/libQtGui.so.4
#15 0x4b874fdc in QApplication::notify(QObject*, QEvent*) () from /lib/libQtGui.so.4
#16 0xb7153b80 in KApplication::notify(QObject*, QEvent*) () from /lib/libkdeui.so.5
#17 0x49262a76 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib/libQtCore.so.4
#18 0x49265eea in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/libQtCore.so.4
#19 0x492663ed in QCoreApplication::sendPostedEvents(QObject*, int) () from /lib/libQtCore.so.4
#20 0x49294e7f in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib/libQtCore.so.4
#21 0x48c3a556 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x48c3a920 in g_main_context_iterate.isra.23 () from /lib/libglib-2.0.so.0
#23 0x48c3a9e9 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x49294610 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#25 0x4b9247ac in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtGui.so.4
#26 0x492613b0 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#27 0x49261741 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#28 0x492673fb in QCoreApplication::exec() () from /lib/libQtCore.so.4
#29 0x4b86c395 in QApplication::exec() () from /lib/libQtGui.so.4
#30 0x0805b997 in main ()

Possible duplicates by query: bug 328177, bug 326875, bug 323698, bug 323249, bug 322092.

Reported using DrKonqi
Comment 1 JAMES 2014-01-12 12:15:18 UTC
Created attachment 84596 [details]
New crash information added by DrKonqi

kpat (3.6) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:

I aborted the Grandfather's Clock Kpatient game.

-- Backtrace (Reduced):
#6  0x00007f2eee848d45 in lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff72cf4ee0) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f2eee8498d0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff72cf4ee0, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f2eee842ed6 in KSharedDataCache::find (this=0xf8c840, key=..., destination=0x7fff72cf4f50) at ../../kdecore/util/kshareddatacache.cpp:1630
#10 0x00007f2eeed7e8af in KImageCache::findPixmap (this=0xf8c840, key=..., destination=0x7fff72cf4fe0) at ../../kdeui/util/kimagecache.cpp:150
Comment 2 Jekyll Wu 2014-01-26 04:01:01 UTC

*** This bug has been marked as a duplicate of bug 309824 ***
Comment 3 JAMES 2014-01-27 04:27:45 UTC
Does this mean there is an update to solve the problem or just that this
report is being thrown out?


On Sat, Jan 25, 2014 at 9:01 PM, Jekyll Wu <adaptee@gmail.com> wrote:

> https://bugs.kde.org/show_bug.cgi?id=329564
>
> Jekyll Wu <adaptee@gmail.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |RESOLVED
>          Resolution|---                         |DUPLICATE
>
> --- Comment #2 from Jekyll Wu <adaptee@gmail.com> ---
>
>
> *** This bug has been marked as a duplicate of bug 309824 ***
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>
Comment 4 Christoph Feck 2014-01-27 12:17:30 UTC
It means the bug has already been reported, and we keep only one of them open.
Comment 5 JAMES 2014-01-28 13:09:05 UTC
I think the problem may be in what is called the skin. The only one that
does not have that fault is the 'Earth-like' skin.

I agree that it makes sense to retain only one report for each problem,
otherwise you may become overwhelmed by duplicate reports. The problem on
my end is how to word the title to find the appropriate report to append
the additional comment or data.

Thank you for your help.

*IN GOD WE TRUST*
James


On Mon, Jan 27, 2014 at 5:17 AM, Christoph Feck <christoph@maxiom.de> wrote:

> https://bugs.kde.org/show_bug.cgi?id=329564
>
> --- Comment #4 from Christoph Feck <christoph@maxiom.de> ---
> It means the bug has already been reported, and we keep only one of them
> open.
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>