Bug 330402 - Kpatience crash on opening
Summary: Kpatience crash on opening
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-25 17:57 UTC by Steven Schmidt
Modified: 2014-01-26 04:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Schmidt 2014-01-25 17:57:45 UTC
Application: kpat (3.6)
KDE Platform Version: 4.10.5
Qt Version: 4.8.5
Operating System: Linux 3.11.10-100.fc18.x86_64 x86_64
Distribution: "Fedora release 18 (Spherical Cow)"

-- Information about the crash:
- What I was doing when the application crashed:

Starting Kpatience
The next time it was ok, with a Forty & Eight saved game.

The crash does not seem to be reproducible.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  lock (this=0x26a0990) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1232
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff69627440) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1255
#8  0x0000003f6bc34190 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff69627440, _d=<optimized out>) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1278
#9  0x0000003f6bc2c1be in KSharedDataCache::find (this=0x2635fe0, key=..., destination=0x7fff696274b0) at /usr/src/debug/kdelibs-4.10.5/kdecore/util/kshareddatacache.cpp:1630
#10 0x0000003f6c6a7032 in KImageCache::findPixmap (this=0x2635fe0, key=..., destination=0x26bdc38) at /usr/src/debug/kdelibs-4.10.5/kdeui/util/kimagecache.cpp:150
#11 0x0000003f6ea165ba in KAbstractCardDeckPrivate::requestPixmap (this=0x26a06a0, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kpat-4.10.5/libkcardgame/kabstractcarddeck.cpp:205
#12 0x0000003f6ea167d0 in KAbstractCardDeck::cardPixmap (this=<optimized out>, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kpat-4.10.5/libkcardgame/kabstractcarddeck.cpp:506
#13 0x0000003f6ea18de7 in KCard::paint (this=0x26bd5c0, painter=0x7fff69627cd0, option=<optimized out>, widget=<optimized out>) at /usr/src/debug/kpat-4.10.5/libkcardgame/kcard.cpp:319
#14 0x00000030d21be895 in QGraphicsScenePrivate::draw (this=this@entry=0x26a2510, item=item@entry=0x26bd5d0, painter=painter@entry=0x7fff69627cd0, viewTransform=viewTransform@entry=0x7fff69627e60, transformPtr=transformPtr@entry=0x7fff69627970, exposedRegion=exposedRegion@entry=0x25bec28, widget=0x25e6c60, opacity=opacity@entry=1, effectTransform=effectTransform@entry=0x0, wasDirtyParentSceneTransform=wasDirtyParentSceneTransform@entry=true, drawItem=true) at graphicsview/qgraphicsscene.cpp:4964
#15 0x00000030d21bf615 in QGraphicsScenePrivate::drawSubtreeRecursive (this=this@entry=0x26a2510, item=0x26bd5d0, painter=painter@entry=0x7fff69627cd0, viewTransform=viewTransform@entry=0x7fff69627e60, exposedRegion=exposedRegion@entry=0x25bec28, widget=widget@entry=0x25e6c60, parentOpacity=parentOpacity@entry=1, effectTransform=effectTransform@entry=0x0) at graphicsview/qgraphicsscene.cpp:4857
#16 0x00000030d21c00ee in QGraphicsScenePrivate::drawItems (this=0x26a2510, painter=0x7fff69627cd0, viewTransform=0x7fff69627e60, exposedRegion=0x25bec28, widget=0x25e6c60) at graphicsview/qgraphicsscene.cpp:4739
#17 0x00000030d21dc288 in QGraphicsView::paintEvent (this=0x25be740, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#18 0x00000030d1c1a1ae in QWidget::event (this=0x25be740, event=0x7fff69628920) at kernel/qwidget.cpp:8533
#19 0x00000030d1fc5516 in QFrame::event (this=0x25be740, e=0x7fff69628920) at widgets/qframe.cpp:557
#20 0x00000030d21dd3bb in QGraphicsView::viewportEvent (this=0x25be740, event=0x7fff69628920) at graphicsview/qgraphicsview.cpp:2866
#21 0x00000030d0377eb6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x25e6c60, event=0x7fff69628920) at kernel/qcoreapplication.cpp:1059
#22 0x00000030d1bca65c in QApplicationPrivate::notify_helper (this=0x2426760, receiver=0x25e6c60, e=0x7fff69628920) at kernel/qapplication.cpp:4558
#23 0x00000030d1bceb0a in QApplication::notify (this=0x7fff6962a630, receiver=0x25e6c60, e=0x7fff69628920) at kernel/qapplication.cpp:4423
#24 0x0000003f6c6455c6 in KApplication::notify (this=0x7fff6962a630, receiver=0x25e6c60, event=0x7fff69628920) at /usr/src/debug/kdelibs-4.10.5/kdeui/kernel/kapplication.cpp:311
#25 0x00000030d0377d4e in QCoreApplication::notifyInternal (this=0x7fff6962a630, receiver=0x25e6c60, event=0x7fff69628920) at kernel/qcoreapplication.cpp:949
#26 0x00000030d1c15d74 in QWidgetPrivate::drawWidget (this=0x25e6c90, pdev=0x27144e0, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26265d0) at ../../src/corelib/kernel/qcoreapplication.h:234
#27 0x00000030d1c1686f in QWidgetPrivate::paintSiblingsRecursive (this=0x25be7a0, pdev=0x27144e0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26265d0) at kernel/qwidget.cpp:5808
#28 0x00000030d1c15905 in QWidgetPrivate::drawWidget (this=0x25be7a0, pdev=0x27144e0, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x26265d0) at kernel/qwidget.cpp:5652
#29 0x00000030d1c1686f in QWidgetPrivate::paintSiblingsRecursive (this=0x2593510, pdev=0x27144e0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26265d0) at kernel/qwidget.cpp:5808
#30 0x00000030d1c166b4 in QWidgetPrivate::paintSiblingsRecursive (this=0x2593510, pdev=0x27144e0, siblings=..., index=10, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26265d0) at kernel/qwidget.cpp:5795
#31 0x00000030d1c166b4 in QWidgetPrivate::paintSiblingsRecursive (this=0x2593510, pdev=0x27144e0, siblings=..., index=12, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26265d0) at kernel/qwidget.cpp:5795
#32 0x00000030d1c166b4 in QWidgetPrivate::paintSiblingsRecursive (this=0x2593510, pdev=0x27144e0, siblings=..., index=18, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26265d0) at kernel/qwidget.cpp:5795
#33 0x00000030d1c15905 in QWidgetPrivate::drawWidget (this=0x2593510, pdev=0x27144e0, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x26265d0) at kernel/qwidget.cpp:5652
#34 0x00000030d1de0678 in QWidgetBackingStore::sync (this=this@entry=0x26265d0) at painting/qbackingstore.cpp:1373
#35 0x00000030d1de0a3e in QWidgetBackingStore::sync (this=0x26265d0, exposedWidget=0x2593330, exposedRegion=...) at painting/qbackingstore.cpp:1161
#36 0x00000030d1c43f9a in QETWidget::translatePaintEvent (this=0x2593330, event=<optimized out>) at kernel/qapplication_x11.cpp:5258
#37 0x00000030d1c44ee5 in QApplication::x11ProcessEvent (this=0x7fff6962a630, event=0x7fff69629fd0) at kernel/qapplication_x11.cpp:3561
#38 0x00000030d1c6ac4c in x11EventSourceDispatch (s=s@entry=0x2427520, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#39 0x0000003a26847a55 in g_main_dispatch (context=0x2432b00) at gmain.c:2715
#40 g_main_context_dispatch (context=context@entry=0x2432b00) at gmain.c:3219
#41 0x0000003a26847d88 in g_main_context_iterate (context=context@entry=0x2432b00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3290
#42 0x0000003a26847e44 in g_main_context_iteration (context=0x2432b00, may_block=1) at gmain.c:3351
#43 0x00000030d03a6676 in QEventDispatcherGlib::processEvents (this=0x241f350, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#44 0x00000030d1c6a92e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#45 0x00000030d03769ff in QEventLoop::processEvents (this=this@entry=0x7fff6962a3a0, flags=...) at kernel/qeventloop.cpp:149
#46 0x00000030d0376c88 in QEventLoop::exec (this=0x7fff6962a3a0, flags=...) at kernel/qeventloop.cpp:204
#47 0x00000030d037bcb8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#48 0x000000000041838a in main (argc=3, argv=0x7fff6962a7e8) at /usr/src/debug/kpat-4.10.5/main.cpp:325

This bug may be a duplicate of or related to bug 329564.

Possible duplicates by query: bug 329564, bug 328177, bug 326875, bug 323698, bug 323249.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-26 04:01:05 UTC

*** This bug has been marked as a duplicate of bug 309824 ***