Bug 328177 - kpat crash when selecting "Simple Simon"
Summary: kpat crash when selecting "Simple Simon"
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-28 13:24 UTC by Claus Reibenstein
Modified: 2013-11-28 15:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claus Reibenstein 2013-11-28 13:24:04 UTC
Application: kpat (3.6)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-56-generic x86_64
Distribution: Ubuntu 12.04.3 LTS

-- Information about the crash:
- What I was doing when the application crashed: I selected "Einfach Simon" (German version, "Simple Simon" in the english version), and kpat crashed immediately.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9e49956780 (LWP 7956))]

Thread 2 (Thread 0x7f9e35502700 (LWP 7957)):
#0  0x00007f9e462f8a43 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9e422ebff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9e422ec124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9e47a44426 in QEventDispatcherGlib::processEvents (this=0x7f9e300008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9e47a13c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e47a13ed7 in QEventLoop::exec (this=0x7f9e35501dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9e47912fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9e479f39ff in QInotifyFileSystemWatcherEngine::run (this=0x286f8d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9e47915fcb in QThreadPrivate::start (arg=0x286f8d0) at thread/qthread_unix.cpp:298
#9  0x00007f9e42bb0e9a in start_thread (arg=0x7f9e35502700) at pthread_create.c:308
#10 0x00007f9e463043fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9e49956780 (LWP 7956)):
[KCrash Handler]
#6  0x00007f9e47fa9d45 in lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff990c6370) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f9e47faa8d0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff990c6370, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f9e47fa3ed6 in KSharedDataCache::find (this=0x275bfc0, key=..., destination=0x7fff990c63e0) at ../../kdecore/util/kshareddatacache.cpp:1630
#10 0x00007f9e484df8af in KImageCache::findPixmap (this=0x275bfc0, key=..., destination=0x7fff990c6470) at ../../kdeui/util/kimagecache.cpp:150
#11 0x00007f9e495518fb in KAbstractCardDeckPrivate::submitRendering (this=0x3ae8960, elementId=..., image=...) at ../../../kpat/libkcardgame/kabstractcarddeck.cpp:247
#12 0x00007f9e47a2e446 in QObject::event (this=0x3ae8960, e=<optimized out>) at kernel/qobject.cpp:1195
#13 0x00007f9e46d97894 in notify_helper (e=0x7f9e28004120, receiver=0x3ae8960, this=0x24df780) at kernel/qapplication.cpp:4559
#14 QApplicationPrivate::notify_helper (this=0x24df780, receiver=0x3ae8960, e=0x7f9e28004120) at kernel/qapplication.cpp:4531
#15 0x00007f9e46d9c713 in QApplication::notify (this=0x7fff990c6f00, receiver=0x3ae8960, e=0x7f9e28004120) at kernel/qapplication.cpp:4420
#16 0x00007f9e4847a3f6 in KApplication::notify (this=0x7fff990c6f00, receiver=0x3ae8960, event=0x7f9e28004120) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f9e47a14e9c in QCoreApplication::notifyInternal (this=0x7fff990c6f00, receiver=0x3ae8960, event=0x7f9e28004120) at kernel/qcoreapplication.cpp:876
#18 0x00007f9e47a18c6a in sendEvent (event=0x7f9e28004120, receiver=0x3ae8960) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x249bff0) at kernel/qcoreapplication.cpp:1500
#20 0x00007f9e47a43f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#22 0x00007f9e422ebd13 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f9e422ec060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f9e422ec124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f9e47a443bf in QEventDispatcherGlib::processEvents (this=0x249d4b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0x00007f9e46e3fd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f9e47a13c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007f9e47a13ed7 in QEventLoop::exec (this=0x7fff990c6df0, flags=...) at kernel/qeventloop.cpp:204
#29 0x00007f9e47a18f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x00000000004189ea in main (argc=3, argv=0x7fff990c7a88) at ../../kpat/main.cpp:325

This bug may be a duplicate of or related to bug 309824.

Possible duplicates by query: bug 326875, bug 323698, bug 323249, bug 322092, bug 321881.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-11-28 15:39:50 UTC

*** This bug has been marked as a duplicate of bug 309824 ***