Bug 330243 - Gwenview crashes on close
Summary: Gwenview crashes on close
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.11.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-21 11:01 UTC by fishears
Modified: 2014-10-24 18:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fishears 2014-01-21 11:01:35 UTC
Application: gwenview (4.11.4)
KDE Platform Version: 4.11.5
Qt Version: 4.8.5
Operating System: Linux 3.12.7-300.fc20.x86_64 x86_64
Distribution: "Fedora release 20 (Heisenbug)"

-- Information about the crash:
double-clicked a jpg from within Dolphin which launched Gwenview to view the photo and then clicked on the close window button. Gwenview crashed immediately on closing. Also noticed that the background on the image view was fully transparent and it isn't normally.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f3e1527a8c0 (LWP 26973))]

Thread 2 (Thread 0x7f3e03d65700 (LWP 26978)):
#0  0x00000033b748a2ea in g_mutex_get_impl (mutex=0x7f3dfc0009a0) at gthread-posix.c:124
#1  0x00000033b748a5c9 in g_mutex_unlock (mutex=mutex@entry=0x7f3dfc0009a0) at gthread-posix.c:232
#2  0x00000033b7448be0 in g_main_context_prepare (context=context@entry=0x7f3dfc0009a0, priority=priority@entry=0x7f3e03d64b80) at gmain.c:3338
#3  0x00000033b74494bb in g_main_context_iterate (context=context@entry=0x7f3dfc0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3693
#4  0x00000033b74496dc in g_main_context_iteration (context=0x7f3dfc0009a0, may_block=1) at gmain.c:3774
#5  0x00000033c29b31a6 in QEventDispatcherGlib::processEvents (this=0x7f3dfc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00000033c298312f in QEventLoop::processEvents (this=this@entry=0x7f3e03d64cc0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00000033c298347d in QEventLoop::exec (this=this@entry=0x7f3e03d64cc0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00000033c2879bdf in QThread::exec (this=this@entry=0x1aba9d0) at thread/qthread.cpp:536
#9  0x00000033c2963a93 in QInotifyFileSystemWatcherEngine::run (this=0x1aba9d0) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00000033c287c3df in QThreadPrivate::start (arg=0x1aba9d0) at thread/qthread_unix.cpp:338
#11 0x00000033b8007f33 in start_thread (arg=0x7f3e03d65700) at pthread_create.c:309
#12 0x00000033b78f4ead in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f3e1527a8c0 (LWP 26973)):
[KCrash Handler]
#6  0x00000033c45c71b9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x2153f00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00000033c45c7239 in QRasterWindowSurface::~QRasterWindowSurface (this=0x2153f00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00000033c45dfdfc in QWidgetBackingStore::~QWidgetBackingStore (this=0x1f3d0d0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00000033c440faa9 in QWidgetBackingStoreTracker::destroy (this=0x1cf8c20) at kernel/qwidget.cpp:225
#10 0x00000033c440fc59 in QWidgetPrivate::deleteExtra (this=this@entry=0x2166ea0) at kernel/qwidget.cpp:1833
#11 0x00000033c440fe6d in QWidgetPrivate::~QWidgetPrivate (this=0x2166ea0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#12 0x00000033c44100f9 in QWidgetPrivate::~QWidgetPrivate (this=0x2166ea0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#13 0x00000033c299e065 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x2166de8, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x2166de0, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00000033c44190fc in QWidget::~QWidget (this=0x2166de0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#17 0x00000033c4419399 in QWidget::~QWidget (this=0x2166de0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#18 0x00000033c49931b5 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x33c4edd100 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../src/corelib/global/qglobal.h:1950
#19 0x00000033b78394e9 in __run_exit_handlers (status=0, listp=0x33b7bb86c8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#20 0x00000033b7839535 in __GI_exit (status=<optimized out>) at exit.c:104
#21 0x00000033b7821d6c in __libc_start_main (main=0x427a70 <main(int, char**)>, argc=6, argv=0x7fffd77c29c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffd77c29b8) at libc-start.c:319
#22 0x0000000000428049 in _start ()

Possible duplicates by query: bug 330038, bug 328666, bug 327798, bug 327730, bug 327253.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-21 11:44:46 UTC

*** This bug has been marked as a duplicate of bug 261539 ***
Comment 2 Vavano 2014-10-24 18:59:24 UTC
Application: gwenview (4.13.1)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-38-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Every time closing Gwenview applikation it crashes
- Custom settings of the application:
Stock settings.

HELPFUL INFORMATION!!!

Maybe I have soliution

Just in file    
"/home/USER/.kde/share/config/kdeglobals"
I delete line "widgetStyle=oxygen transparent"(last line)  in [General]
after this file modification i don't have crash on Gwenview exit!

BEFORE modification

[General]
BrowserApplication=google-chrome.desktop
ColorScheme=Текущая схема
XftAntialias=true
XftSubPixel=none
desktopFont=Verdana,9,-1,5,50,0,0,0,0,0
fixed=Monospace,9,-1,5,50,0,0,0,0,0
font=Verdana,9,-1,5,50,0,0,0,0,0
menuFont=Verdana,9,-1,5,50,0,0,0,0,0
shadeSortColumn=true
smallestReadableFont=Verdana,8,-1,5,50,0,0,0,0,0
taskbarFont=Verdana,9,-1,5,50,0,0,0,0,0
toolBarFont=Verdana,9,-1,5,50,0,0,0,0,0
widgetStyle=oxygen transparent


AFTER

[General]
BrowserApplication=google-chrome.desktop
ColorScheme=Текущая схема
XftAntialias=true
XftSubPixel=none
desktopFont=Verdana,9,-1,5,50,0,0,0,0,0
fixed=Monospace,9,-1,5,50,0,0,0,0,0
font=Verdana,9,-1,5,50,0,0,0,0,0
menuFont=Verdana,9,-1,5,50,0,0,0,0,0
shadeSortColumn=true
smallestReadableFont=Verdana,8,-1,5,50,0,0,0,0,0
taskbarFont=Verdana,9,-1,5,50,0,0,0,0,0
toolBarFont=Verdana,9,-1,5,50,0,0,0,0,0

and in my case problem was solved

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ffc37dfa840 (LWP 7131))]

Thread 3 (Thread 0x7ffc1f683700 (LWP 7132)):
#0  0x00007ffc306c461a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ffc306c49a9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffc30682a59 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffc30682f7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffc306830ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ffc36c407be in QEventDispatcherGlib::processEvents (this=0x7ffc180008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007ffc36c120af in QEventLoop::processEvents (this=this@entry=0x7ffc1f682d60, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007ffc36c123a5 in QEventLoop::exec (this=this@entry=0x7ffc1f682d60, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007ffc36b0ec5f in QThread::exec (this=this@entry=0x270c950) at thread/qthread.cpp:537
#9  0x00007ffc36bf3823 in QInotifyFileSystemWatcherEngine::run (this=0x270c950) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007ffc36b1132f in QThreadPrivate::start (arg=0x270c950) at thread/qthread_unix.cpp:349
#11 0x00007ffc30b4e182 in start_thread (arg=0x7ffc1f683700) at pthread_create.c:312
#12 0x00007ffc348c6fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7ffc1e7a4700 (LWP 7133)):
#0  0x00007ffc348b9c6d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ffc30682fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffc306830ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffc36c407be in QEventDispatcherGlib::processEvents (this=0x7ffc100008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007ffc36c120af in QEventLoop::processEvents (this=this@entry=0x7ffc1e7a3d60, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ffc36c123a5 in QEventLoop::exec (this=this@entry=0x7ffc1e7a3d60, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ffc36b0ec5f in QThread::exec (this=this@entry=0x27893c0) at thread/qthread.cpp:537
#7  0x00007ffc36bf3823 in QInotifyFileSystemWatcherEngine::run (this=0x27893c0) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007ffc36b1132f in QThreadPrivate::start (arg=0x27893c0) at thread/qthread_unix.cpp:349
#9  0x00007ffc30b4e182 in start_thread (arg=0x7ffc1e7a4700) at pthread_create.c:312
#10 0x00007ffc348c6fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7ffc37dfa840 (LWP 7131)):
[KCrash Handler]
#6  0x00007ffc357138c9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x25fec30, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007ffc35713949 in QRasterWindowSurface::~QRasterWindowSurface (this=0x25fec30, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007ffc3572bc5c in QWidgetBackingStore::~QWidgetBackingStore (this=0x2af49d0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007ffc35564009 in QWidgetBackingStoreTracker::destroy (this=0x2c3fdd0) at kernel/qwidget.cpp:225
#10 0x00007ffc355641a9 in QWidgetPrivate::deleteExtra (this=this@entry=0x29b5f00) at kernel/qwidget.cpp:1833
#11 0x00007ffc355643bd in QWidgetPrivate::~QWidgetPrivate (this=0x29b5f00, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#12 0x00007ffc35564649 in QWidgetPrivate::~QWidgetPrivate (this=0x29b5f00, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#13 0x00007ffc36c2c735 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x29b5ce8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x29b5ce0, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00007ffc3556cdcc in QWidget::~QWidget (this=0x29b5ce0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#17 0x00007ffc3556d049 in QWidget::~QWidget (this=0x29b5ce0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#18 0x00007ffc35abc995 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7ffc360091a0 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1960
#19 0x00007ffc34808149 in __run_exit_handlers (status=0, listp=0x7ffc34b8b6c8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#20 0x00007ffc34808195 in __GI_exit (status=<optimized out>) at exit.c:104
#21 0x00007ffc347edecc in __libc_start_main (main=0x427580 <main(int, char**)>, argc=6, argv=0x7fff65b8f288, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff65b8f278) at libc-start.c:321
#22 0x0000000000427b22 in _start ()

Possible duplicates by query: bug 331005, bug 330831, bug 330243, bug 330038, bug 328666.

Отправить на https://bugs.kde.org/