Bug 331005 - Bug al Cerrar KDE o Dolphin
Summary: Bug al Cerrar KDE o Dolphin
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.12.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-11 03:58 UTC by Juanjo
Modified: 2014-02-11 18:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juanjo 2014-02-11 03:58:00 UTC
Application: gwenview (4.12.0)
KDE Platform Version: 4.12.1 (Compiled from sources)
Qt Version: 4.8.6
Operating System: Linux 3.11.0-12-generic x86_64
Distribution: Linux Mint 16 Petra

-- Information about the crash:
- What I was doing when the application crashed:

Crashea cuando intento cerrar KDE o cuando abro o cierro dolphin ojala puedan encontrar el bug y repararlo

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7c708527c0 (LWP 3552))]

Thread 3 (Thread 0x7f7c58f2f700 (LWP 3556)):
#0  g_private_get_impl (key=0x7f7c6946fba0 <g_thread_specific_private>) at /build/buildd/glib2.0-2.38.1/./glib/gthread-posix.c:996
#1  0x00007f7c691f8749 in g_private_get (key=key@entry=0x7f7c6946fba0 <g_thread_specific_private>) at /build/buildd/glib2.0-2.38.1/./glib/gthread-posix.c:1025
#2  0x00007f7c691dd590 in g_thread_self () at /build/buildd/glib2.0-2.38.1/./glib/gthread.c:994
#3  0x00007f7c691b77dc in g_main_context_acquire (context=0x7f7c4c0009a0) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3121
#4  0x00007f7c691b8565 in g_main_context_iterate (context=context@entry=0x7f7c4c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3662
#5  0x00007f7c691b87ac in g_main_context_iteration (context=0x7f7c4c0009a0, may_block=1) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3773
#6  0x00007f7c6f67aaf6 in QEventDispatcherGlib::processEvents (this=0x7f7c4c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#7  0x00007f7c6f64c30f in QEventLoop::processEvents (this=this@entry=0x7f7c58f2ed70, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f7c6f64c605 in QEventLoop::exec (this=this@entry=0x7f7c58f2ed70, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f7c6f548c4f in QThread::exec (this=this@entry=0x16700f0) at thread/qthread.cpp:537
#10 0x00007f7c6f62da33 in QInotifyFileSystemWatcherEngine::run (this=0x16700f0) at io/qfilesystemwatcher_inotify.cpp:265
#11 0x00007f7c6f54b31f in QThreadPrivate::start (arg=0x16700f0) at thread/qthread_unix.cpp:349
#12 0x00007f7c69687f6e in start_thread (arg=0x7f7c58f2f700) at pthread_create.c:311
#13 0x00007f7c6cfe29cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f7c53daf700 (LWP 3558)):
#0  0x00007f7c6cfd5f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7c691b86a4 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f7c48002bb0, timeout=-1, context=0x7f7c480009a0) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:4006
#2  g_main_context_iterate (context=context@entry=0x7f7c480009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3707
#3  0x00007f7c691b87ac in g_main_context_iteration (context=0x7f7c480009a0, may_block=1) at /build/buildd/glib2.0-2.38.1/./glib/gmain.c:3773
#4  0x00007f7c6f67aaf6 in QEventDispatcherGlib::processEvents (this=0x7f7c480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#5  0x00007f7c6f64c30f in QEventLoop::processEvents (this=this@entry=0x7f7c53daed70, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f7c6f64c605 in QEventLoop::exec (this=this@entry=0x7f7c53daed70, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f7c6f548c4f in QThread::exec (this=this@entry=0x16c64a0) at thread/qthread.cpp:537
#8  0x00007f7c6f62da33 in QInotifyFileSystemWatcherEngine::run (this=0x16c64a0) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f7c6f54b31f in QThreadPrivate::start (arg=0x16c64a0) at thread/qthread_unix.cpp:349
#10 0x00007f7c69687f6e in start_thread (arg=0x7f7c53daf700) at pthread_create.c:311
#11 0x00007f7c6cfe29cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f7c708527c0 (LWP 3552)):
[KCrash Handler]
#6  0x00007f7c6de3ca79 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1875880, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f7c6de3caf9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1875880, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f7c6de54e0c in QWidgetBackingStore::~QWidgetBackingStore (this=0x1860400, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f7c6dc8d0a9 in QWidgetBackingStoreTracker::destroy (this=0x1896fd0) at kernel/qwidget.cpp:225
#10 0x00007f7c6dc8d249 in QWidgetPrivate::deleteExtra (this=this@entry=0x1a12fe0) at kernel/qwidget.cpp:1833
#11 0x00007f7c6dc8d45d in QWidgetPrivate::~QWidgetPrivate (this=0x1a12fe0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#12 0x00007f7c6dc8d6e9 in QWidgetPrivate::~QWidgetPrivate (this=0x1a12fe0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#13 0x00007f7c6f6669b5 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x1a12f28, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x1a12f20, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00007f7c6dc95e6c in QWidget::~QWidget (this=0x1a12f20, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#17 0x00007f7c6dc960e9 in QWidget::~QWidget (this=0x1a12f20, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#18 0x00007f7c6e1e6405 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f7c6e7321a0 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1960
#19 0x00007f7c6cf24071 in __run_exit_handlers (status=0, listp=0x7f7c6d2a96a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#20 0x00007f7c6cf240f5 in __GI_exit (status=<optimized out>) at exit.c:99
#21 0x00007f7c6cf09dec in __libc_start_main (main=0x4273c0 <main(int, char**)>, argc=6, ubp_av=0x7fff2dd18638, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff2dd18628) at libc-start.c:294
#22 0x0000000000427942 in _start ()

Possible duplicates by query: bug 330831, bug 330243, bug 330038, bug 328666, bug 327798.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-02-11 18:15:57 UTC

*** This bug has been marked as a duplicate of bug 261539 ***