Bug 328666 - error al cerrar aplicaciones kde
Summary: error al cerrar aplicaciones kde
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.11.4
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-11 14:57 UTC by patoreyes
Modified: 2013-12-11 16:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description patoreyes 2013-12-11 14:57:25 UTC
Application: gwenview (4.11.4)
KDE Platform Version: 4.11.4
Qt Version: 4.8.5
Operating System: Linux 3.7.10-1.16-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: el error aparece al cerrar aplicaciones como: Amarok, kmix, gwenview. Actualice a KDE 4.11 esperando resolver el problema, pero este continua; poseo instalado el tema oxygen-transparent.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7c51bc7780 (LWP 5310))]

Thread 2 (Thread 0x7f7c37d05700 (LWP 5315)):
#0  0x00007f7c4e3664ed in poll () from /lib64/libc.so.6
#1  0x00007f7c4a3b7aa4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f7c4a3b7bc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f7c50a075d6 in QEventDispatcherGlib::processEvents (this=0x7f7c300008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00007f7c509d7bef in QEventLoop::processEvents (this=this@entry=0x7f7c37d04dd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7c509d7e78 in QEventLoop::exec (this=0x7f7c37d04dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f7c508da110 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#7  0x00007f7c509b83af in QInotifyFileSystemWatcherEngine::run (this=0x10fe6c0) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f7c508dd0ec in QThreadPrivate::start (arg=0x10fe6c0) at thread/qthread_unix.cpp:338
#9  0x00007f7c4c31be0f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f7c4e36f44d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f7c51bc7780 (LWP 5310)):
[KCrash Handler]
#5  0x00007f7c4f1ddc59 in QRasterWindowSurface::~QRasterWindowSurface (this=0x14303d0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#6  0x00007f7c4f1ddcd9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x14303d0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#7  0x00007f7c4f1f685e in QWidgetBackingStore::~QWidgetBackingStore (this=0x122fb50, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#8  0x00007f7c4f02d2b9 in QWidgetBackingStoreTracker::destroy (this=0x1678610) at kernel/qwidget.cpp:225
#9  0x00007f7c4f02d402 in QWidgetPrivate::deleteExtra (this=this@entry=0x14f4ac0) at kernel/qwidget.cpp:1833
#10 0x00007f7c4f02d61d in QWidgetPrivate::~QWidgetPrivate (this=0x14f4ac0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#11 0x00007f7c4f02d8a9 in QWidgetPrivate::~QWidgetPrivate (this=0x14f4ac0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#12 0x00007f7c509ef52c in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#13 ~QScopedPointer (this=0x14f4a18, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#14 QObject::~QObject (this=0x14f4a10, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#15 0x00007f7c4f02f718 in QWidget::~QWidget (this=0x14f4a10, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#16 0x00007f7c4f02f9c9 in QWidget::~QWidget (this=0x14f4a10, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#17 0x00007f7c4f593345 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f7c4fabdfe8 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../src/corelib/global/qglobal.h:1951
#18 0x00007f7c4e2bdf61 in __run_exit_handlers () from /lib64/libc.so.6
#19 0x00007f7c4e2bdfe5 in exit () from /lib64/libc.so.6
#20 0x00007f7c4e2a7a1c in __libc_start_main () from /lib64/libc.so.6
#21 0x000000000042a701 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 261539.

Possible duplicates by query: bug 327798, bug 327730, bug 327253, bug 326996, bug 326407.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-12-11 16:21:18 UTC

*** This bug has been marked as a duplicate of bug 261539 ***