Bug 330831 - Gwenview crash on close
Summary: Gwenview crash on close
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.11.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-06 00:10 UTC by Jan
Modified: 2014-02-06 05:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan 2014-02-06 00:10:56 UTC
Application: gwenview (4.11.3)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:
Opened a jpg (scanned document) and then closed the app.
Crash notification popped up on close.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f79c10967c0 (LWP 4715))]

Thread 3 (Thread 0x7f79a3fff700 (LWP 4721)):
#0  0x00007f79bd8246bd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f79b4c79e61 in ?? () from /usr/lib/nvidia-319-updates/tls/libnvidia-tls.so.319.60
#2  0x00007f79b9a4f670 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f79b9a101cc in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f79b9a1063b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f79b9a107ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f79bfec7a76 in QEventDispatcherGlib::processEvents (this=0x7f799c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007f79bfe995ef in QEventLoop::processEvents (this=this@entry=0x7f79a3ffed70, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f79bfe998e5 in QEventLoop::exec (this=this@entry=0x7f79a3ffed70, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f79bfd9888f in QThread::exec (this=this@entry=0x1ae7690) at thread/qthread.cpp:542
#10 0x00007f79bfe7ad13 in QInotifyFileSystemWatcherEngine::run (this=0x1ae7690) at io/qfilesystemwatcher_inotify.cpp:265
#11 0x00007f79bfd9af2f in QThreadPrivate::start (arg=0x1ae7690) at thread/qthread_unix.cpp:338
#12 0x00007f79b9edff6e in start_thread (arg=0x7f79a3fff700) at pthread_create.c:311
#13 0x00007f79bd8329cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f79a338f700 (LWP 4723)):
#0  0x00007f79b9a500ea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f79b9a50399 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f79b9a10286 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f79b9a10708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f79b9a107ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f79bfec7a76 in QEventDispatcherGlib::processEvents (this=0x7f79940008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f79bfe995ef in QEventLoop::processEvents (this=this@entry=0x7f79a338ed70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f79bfe998e5 in QEventLoop::exec (this=this@entry=0x7f79a338ed70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f79bfd9888f in QThread::exec (this=this@entry=0x1e3c860) at thread/qthread.cpp:542
#9  0x00007f79bfe7ad13 in QInotifyFileSystemWatcherEngine::run (this=0x1e3c860) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f79bfd9af2f in QThreadPrivate::start (arg=0x1e3c860) at thread/qthread_unix.cpp:338
#11 0x00007f79b9edff6e in start_thread (arg=0x7f79a338f700) at pthread_create.c:311
#12 0x00007f79bd8329cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f79c10967c0 (LWP 4715)):
[KCrash Handler]
#6  0x00007f79be68bf79 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1e406e0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f79be68bff9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1e406e0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f79be6a434c in QWidgetBackingStore::~QWidgetBackingStore (this=0x1e409e0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f79be4dce09 in QWidgetBackingStoreTracker::destroy (this=0x2292e50) at kernel/qwidget.cpp:221
#10 0x00007f79be4dcfa9 in QWidgetPrivate::deleteExtra (this=this@entry=0x207de60) at kernel/qwidget.cpp:1835
#11 0x00007f79be4dd1bd in QWidgetPrivate::~QWidgetPrivate (this=0x207de60, __in_chrg=<optimized out>) at kernel/qwidget.cpp:361
#12 0x00007f79be4dd449 in QWidgetPrivate::~QWidgetPrivate (this=0x207de60, __in_chrg=<optimized out>) at kernel/qwidget.cpp:366
#13 0x00007f79bfeb38e5 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x207dce8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x207dce0, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00007f79be4e5bcc in QWidget::~QWidget (this=0x207dce0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1556
#17 0x00007f79be4e5e49 in QWidget::~QWidget (this=0x207dce0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1705
#18 0x00007f79bea34f75 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f79bef81180 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1950
#19 0x00007f79bd774071 in __run_exit_handlers (status=0, listp=0x7f79bdaf96a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#20 0x00007f79bd7740f5 in __GI_exit (status=<optimized out>) at exit.c:99
#21 0x00007f79bd759dec in __libc_start_main (main=0x4279c0 <main(int, char**)>, argc=6, ubp_av=0x7fffc4680f08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc4680ef8) at libc-start.c:294
#22 0x0000000000427f42 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 326407.

Possible duplicates by query: bug 330243, bug 330038, bug 328666, bug 327798, bug 327730.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-02-06 05:03:21 UTC

*** This bug has been marked as a duplicate of bug 261539 ***