Bug 327730 - just closed the window
Summary: just closed the window
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.11.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-11-17 17:38 UTC by PinguinoGoku
Modified: 2013-11-18 13:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PinguinoGoku 2013-11-17 17:38:53 UTC
Application: gwenview (4.11.2)
KDE Platform Version: 4.11.2 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.11.0-13-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
just closed the window and begins to give me the error that was closed gwenwiew insperadamente.

only happens when I open an image and then close it.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8cba31b7c0 (LWP 3176))]

Thread 3 (Thread 0x7f8ca1652700 (LWP 3181)):
#0  0x00007f8cb31e705f in __pthread_mutex_unlock_usercnt (mutex=0x7f8c94000a80, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  0x00007f8cb2d5f3d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8cb2d1f119 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8cb2d1f63b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8cb2d1f7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f8cb9164a76 in QEventDispatcherGlib::processEvents (this=0x7f8c940008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f8cb91365ef in QEventLoop::processEvents (this=this@entry=0x7f8ca1651d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f8cb91368e5 in QEventLoop::exec (this=this@entry=0x7f8ca1651d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f8cb903588f in QThread::exec (this=this@entry=0xf3a920) at thread/qthread.cpp:542
#9  0x00007f8cb9117d13 in QInotifyFileSystemWatcherEngine::run (this=0xf3a920) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f8cb9037f2f in QThreadPrivate::start (arg=0xf3a920) at thread/qthread_unix.cpp:338
#11 0x00007f8cb31e3f6e in start_thread (arg=0x7f8ca1652700) at pthread_create.c:311
#12 0x00007f8cb6af19cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f8c9bfff700 (LWP 3183)):
#0  0x00007f8cb6ae36bd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f8cadff3e61 in ?? () from /usr/lib/nvidia-319-updates/tls/libnvidia-tls.so.319.60
#2  0x00007f8cb2d5e670 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8cb2d1f1cc in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8cb2d1f63b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f8cb2d1f7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f8cb9164a76 in QEventDispatcherGlib::processEvents (this=0x7f8c900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007f8cb91365ef in QEventLoop::processEvents (this=this@entry=0x7f8c9bffed70, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f8cb91368e5 in QEventLoop::exec (this=this@entry=0x7f8c9bffed70, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f8cb903588f in QThread::exec (this=this@entry=0x122b5c0) at thread/qthread.cpp:542
#10 0x00007f8cb9117d13 in QInotifyFileSystemWatcherEngine::run (this=0x122b5c0) at io/qfilesystemwatcher_inotify.cpp:265
#11 0x00007f8cb9037f2f in QThreadPrivate::start (arg=0x122b5c0) at thread/qthread_unix.cpp:338
#12 0x00007f8cb31e3f6e in start_thread (arg=0x7f8c9bfff700) at pthread_create.c:311
#13 0x00007f8cb6af19cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f8cba31b7c0 (LWP 3176)):
[KCrash Handler]
#6  0x00007f8cb793ff79 in QRasterWindowSurface::~QRasterWindowSurface (this=0x122f290, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f8cb793fff9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x122f290, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f8cb795834c in QWidgetBackingStore::~QWidgetBackingStore (this=0x122f730, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f8cb7790e09 in QWidgetBackingStoreTracker::destroy (this=0x12552a0) at kernel/qwidget.cpp:221
#10 0x00007f8cb7790fa9 in QWidgetPrivate::deleteExtra (this=this@entry=0x143b850) at kernel/qwidget.cpp:1835
#11 0x00007f8cb77911bd in QWidgetPrivate::~QWidgetPrivate (this=0x143b850, __in_chrg=<optimized out>) at kernel/qwidget.cpp:361
#12 0x00007f8cb7791449 in QWidgetPrivate::~QWidgetPrivate (this=0x143b850, __in_chrg=<optimized out>) at kernel/qwidget.cpp:366
#13 0x00007f8cb91508e5 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x143b6a8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x143b6a0, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00007f8cb7799bcc in QWidget::~QWidget (this=0x143b6a0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1556
#17 0x00007f8cb7799e49 in QWidget::~QWidget (this=0x143b6a0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1705
#18 0x00007f8cb7ce8f75 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f8cb8235180 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1950
#19 0x00007f8cb6a33071 in __run_exit_handlers (status=0, listp=0x7f8cb6db86a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#20 0x00007f8cb6a330f5 in __GI_exit (status=<optimized out>) at exit.c:99
#21 0x00007f8cb6a18dec in __libc_start_main (main=0x4279c0, argc=6, ubp_av=0x7fff7a7e85e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7a7e85d8) at libc-start.c:294
#22 0x0000000000427f42 in _start ()

Possible duplicates by query: bug 327253, bug 326996, bug 326407, bug 326249, bug 320766.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-11-18 13:45:10 UTC

*** This bug has been marked as a duplicate of bug 261539 ***