Bug 327253 - close bug apps kde
Summary: close bug apps kde
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.11.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-11-07 02:12 UTC by seb.an.perez
Modified: 2014-02-14 08:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (3.63 KB, text/plain)
2014-02-14 08:55 UTC, e.lopvet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description seb.an.perez 2013-11-07 02:12:08 UTC
Application: gwenview (4.11.2)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-12-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
to close applications like amarok and gwenview dialog appears informing you that the application has failed

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f192470c7c0 (LWP 4296))]

Thread 3 (Thread 0x7f190d29a700 (LWP 4302)):
#0  0x00007f191d10d7af in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1923551a76 in QEventDispatcherGlib::processEvents (this=0x7f19000008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#2  0x00007f19235235ef in QEventLoop::processEvents (this=this@entry=0x7f190d299d70, flags=...) at kernel/qeventloop.cpp:149
#3  0x00007f19235238e5 in QEventLoop::exec (this=this@entry=0x7f190d299d70, flags=...) at kernel/qeventloop.cpp:204
#4  0x00007f192342288f in QThread::exec (this=this@entry=0x137cfb0) at thread/qthread.cpp:542
#5  0x00007f1923504d13 in QInotifyFileSystemWatcherEngine::run (this=0x137cfb0) at io/qfilesystemwatcher_inotify.cpp:265
#6  0x00007f1923424f2f in QThreadPrivate::start (arg=0x137cfb0) at thread/qthread_unix.cpp:338
#7  0x00007f191d5d1f6e in start_thread (arg=0x7f190d29a700) at pthread_create.c:311
#8  0x00007f1920ede9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f1907fff700 (LWP 4304)):
#0  0x00007fff69bfe7d2 in clock_gettime ()
#1  0x00007f1920ef396d in clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f1923479757 in do_gettime (frac=0x7f1907ffeb00, sec=0x7f1907ffeaf8) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f1923552fe5 in updateCurrentTime (this=0x7f18fc002860) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0x7f18fc002860, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0x00007f192355182c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f1907ffebb4) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f19235518d5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f191d10cd4d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f191d10d5c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f191d10d7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f1923551a76 in QEventDispatcherGlib::processEvents (this=0x7f18fc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f19235235ef in QEventLoop::processEvents (this=this@entry=0x7f1907ffed70, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f19235238e5 in QEventLoop::exec (this=this@entry=0x7f1907ffed70, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f192342288f in QThread::exec (this=this@entry=0x14caa00) at thread/qthread.cpp:542
#15 0x00007f1923504d13 in QInotifyFileSystemWatcherEngine::run (this=0x14caa00) at io/qfilesystemwatcher_inotify.cpp:265
#16 0x00007f1923424f2f in QThreadPrivate::start (arg=0x14caa00) at thread/qthread_unix.cpp:338
#17 0x00007f191d5d1f6e in start_thread (arg=0x7f1907fff700) at pthread_create.c:311
#18 0x00007f1920ede9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f192470c7c0 (LWP 4296)):
[KCrash Handler]
#6  0x00007f1921d2cf79 in QRasterWindowSurface::~QRasterWindowSurface (this=0x18f0900, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f1921d2cff9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x18f0900, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f1921d4534c in QWidgetBackingStore::~QWidgetBackingStore (this=0x1446f00, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f1921b7de09 in QWidgetBackingStoreTracker::destroy (this=0x1bb3b60) at kernel/qwidget.cpp:221
#10 0x00007f1921b7dfa9 in QWidgetPrivate::deleteExtra (this=this@entry=0x190dbc0) at kernel/qwidget.cpp:1835
#11 0x00007f1921b7e1bd in QWidgetPrivate::~QWidgetPrivate (this=0x190dbc0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:361
#12 0x00007f1921b7e449 in QWidgetPrivate::~QWidgetPrivate (this=0x190dbc0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:366
#13 0x00007f192353d8e5 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x190db98, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x190db90, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00007f1921b86bcc in QWidget::~QWidget (this=0x190db90, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1556
#17 0x00007f1921b86e49 in QWidget::~QWidget (this=0x190db90, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1705
#18 0x00007f19220d5f75 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f1922622180 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1950
#19 0x00007f1920e20071 in __run_exit_handlers (status=0, listp=0x7f19211a56a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#20 0x00007f1920e200f5 in __GI_exit (status=<optimized out>) at exit.c:99
#21 0x00007f1920e05dec in __libc_start_main (main=0x4279c0 <main(int, char**)>, argc=6, ubp_av=0x7fff69bdda38, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff69bdda28) at libc-start.c:294
#22 0x0000000000427f42 in _start ()

Possible duplicates by query: bug 326996, bug 326407, bug 326249, bug 320766.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-11-07 02:52:05 UTC
See https://bugs.kde.org/show_bug.cgi?id=261539#c30

*** This bug has been marked as a duplicate of bug 261539 ***
Comment 2 e.lopvet 2014-02-14 08:55:48 UTC
Created attachment 85140 [details]
New crash information added by DrKonqi

gwenview (4.11.4) on KDE Platform 4.11.5 using Qt 4.8.5

- What I was doing when the application crashed:

Looking at pictures with Gwenview. Each times I close the application, it crashes.

-- Backtrace (Reduced):
#5  0x00007f07c6d7a789 in QRasterWindowSurface::~QRasterWindowSurface (this=0xf0cf10, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#6  0x00007f07c6d7a809 in QRasterWindowSurface::~QRasterWindowSurface (this=0xf0cf10, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#7  0x00007f07c6d92b1c in QWidgetBackingStore::~QWidgetBackingStore (this=0xc47d20, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#8  0x00007f07c6bcf8f9 in QWidgetBackingStoreTracker::destroy (this=0xeeda70) at kernel/qwidget.cpp:225
#9  0x00007f07c6bcfa99 in QWidgetPrivate::deleteExtra (this=this@entry=0xf1f490) at kernel/qwidget.cpp:1833