Bug 329697 - digiKam crash when browsing albums (qt-sqlite plugin broken due to BC issue with libsqlite)
Summary: digiKam crash when browsing albums (qt-sqlite plugin broken due to BC issue w...
Status: RESOLVED UPSTREAM
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Sqlite (show other bugs)
Version: 3.5.0
Platform: Fedora RPMs Linux
: NOR crash with 40 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-07 21:07 UTC by André Hübert Johansen
Modified: 2022-01-14 14:16 UTC (History)
96 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments
New crash information added by DrKonqi (36.36 KB, text/plain)
2014-04-26 08:36 UTC, pierre_metzner
Details
New crash information added by DrKonqi (13.91 KB, text/plain)
2014-04-30 06:24 UTC, Nikita Melnichenko
Details
New crash information added by DrKonqi (12.95 KB, text/plain)
2014-06-17 17:47 UTC, RJVB
Details
New crash information added by DrKonqi (15.10 KB, text/plain)
2015-05-07 22:41 UTC, Ben
Details
New crash information added by DrKonqi (14.07 KB, text/plain)
2015-06-06 23:13 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description André Hübert Johansen 2014-01-07 21:07:28 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.11.4
Qt Version: 4.8.5
Operating System: Linux 3.12.6-300.fc20.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
When browsing albums, digiCam crashed.  I was able to reproduce it once; it did not seem to be related to a specific album.

The crash can be reproduced sometimes.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7eff5fdedac0 (LWP 3182))]

Thread 5 (Thread 0x7eff598bf700 (LWP 3183)):
#0  0x0000003bd4a0eccd in recvmsg () from /lib64/libpthread.so.0
#1  0x0000003bdf208f31 in udev_monitor_receive_device () from /lib64/libudev.so.1
#2  0x0000003bf7c0ec6b in linux_udev_event_thread_main () from /lib64/libusb-1.0.so.0
#3  0x0000003bd4a07f33 in start_thread () from /lib64/libpthread.so.0
#4  0x0000003bd42f4ead in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7eff52d9c700 (LWP 3184)):
#0  0x0000003bd4a0bd20 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003bdf67c906 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQtCore.so.4
#2  0x00000000005e251e in Digikam::ScanController::run() ()
#3  0x0000003bdf67c3df in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#4  0x0000003bd4a07f33 in start_thread () from /lib64/libpthread.so.0
#5  0x0000003bd42f4ead in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7eff5259b700 (LWP 3185)):
#0  0x0000003bd4a0b1fe in pthread_mutex_unlock () from /lib64/libpthread.so.0
#1  0x0000003bd6a8a5d1 in g_mutex_unlock () from /lib64/libglib-2.0.so.0
#2  0x0000003bd6a494ae in g_main_context_iterate.isra.24 () from /lib64/libglib-2.0.so.0
#3  0x0000003bd6a496dc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x0000003bdf7b31a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#5  0x0000003bdf78312f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#6  0x0000003bdf78347d in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#7  0x0000003bdf679bdf in QThread::exec() () from /lib64/libQtCore.so.4
#8  0x0000003bdf763a93 in QInotifyFileSystemWatcherEngine::run() () from /lib64/libQtCore.so.4
#9  0x0000003bdf67c3df in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#10 0x0000003bd4a07f33 in start_thread () from /lib64/libpthread.so.0
#11 0x0000003bd42f4ead in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7eff51d9a700 (LWP 3187)):
#0  0x0000003bd4a0bd20 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003bdf67c906 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQtCore.so.4
#2  0x0000003c0bf6298a in Digikam::ParkingThread::run() () from /lib64/libdigikamcore.so.3
#3  0x0000003bdf67c3df in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#4  0x0000003bd4a07f33 in start_thread () from /lib64/libpthread.so.0
#5  0x0000003bd42f4ead in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7eff5fdedac0 (LWP 3182)):
[KCrash Handler]
#5  0x000000000000004b in ?? ()
#6  0x0000003bf1231edc in sqlite3MemCompare () from /lib64/libsqlite3.so.0
#7  0x0000003bf12320a3 in sqlite3VdbeRecordCompare () from /lib64/libsqlite3.so.0
#8  0x0000003bf1246d59 in sqlite3BtreeMovetoUnpacked () from /lib64/libsqlite3.so.0
#9  0x0000003bf126fa05 in sqlite3VdbeExec () from /lib64/libsqlite3.so.0
#10 0x0000003bf1277f37 in sqlite3_step () from /lib64/libsqlite3.so.0
#11 0x00007eff5139442c in QSQLiteResultPrivate::fetchNext(QVector<QVariant>&, int, bool) () from /usr/lib64/qt4/plugins/sqldrivers/libqsqlite.so
#12 0x00007eff51395188 in QSQLiteResult::exec() () from /usr/lib64/qt4/plugins/sqldrivers/libqsqlite.so
#13 0x0000003bebe10c5d in QSqlQuery::exec() () from /lib64/libQtSql.so.4
#14 0x0000003c0bf19456 in Digikam::DatabaseCoreBackend::exec(Digikam::SqlQuery&) () from /lib64/libdigikamcore.so.3
#15 0x0000003c0bf194ec in Digikam::DatabaseCoreBackend::execQuery(Digikam::SqlQuery&, QVariant const&) () from /lib64/libdigikamcore.so.3
#16 0x0000003c0bf1a6e0 in Digikam::DatabaseCoreBackend::execQuery(QString const&, QVariant const&) () from /lib64/libdigikamcore.so.3
#17 0x0000003c0bf1a737 in Digikam::DatabaseCoreBackend::execSql(QString const&, QVariant const&, QList<QVariant>*, QVariant*) () from /lib64/libdigikamcore.so.3
#18 0x0000003c0d865dae in Digikam::AlbumDB::getSetting(QString const&) () from /lib64/libdigikamdatabase.so.3
#19 0x0000003c0d86676f in Digikam::AlbumDB::getFilterSettings(QStringList*, QStringList*, QStringList*) () from /lib64/libdigikamdatabase.so.3
#20 0x000000000064c4f3 in Digikam::AlbumSettings::getRawFileFilter() const ()
#21 0x00000000005395ca in Digikam::KipiInterface::hostSetting(QString const&) ()
#22 0x0000000000539034 in Digikam::KipiInterface::currentAlbum() ()
#23 0x00007efefcbf5624 in KIPIAdvancedSlideshowPlugin::Plugin_AdvancedSlideshow::slotAlbumChanged(bool) () from /usr/lib64/kde4/kipiplugin_advancedslideshow.so
#24 0x0000003bdf798fa8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib64/libQtCore.so.4
#25 0x0000003bef015342 in KIPI::Interface::currentAlbumChanged(bool) () from /lib64/libkipi.so.11
#26 0x0000003bdf798fa8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib64/libQtCore.so.4
#27 0x00000000005acc34 in Digikam::AlbumManager::setCurrentAlbum(Digikam::Album*) ()
#28 0x00000000005d3e0d in Digikam::AbstractAlbumTreeView::mousePressEvent(QMouseEvent*) ()
#29 0x0000003be1c1cd83 in QWidget::event(QEvent*) () from /lib64/libQtGui.so.4
#30 0x0000003be1fd3bbe in QFrame::event(QEvent*) () from /lib64/libQtGui.so.4
#31 0x0000003be20efe13 in QAbstractItemView::viewportEvent(QEvent*) () from /lib64/libQtGui.so.4
#32 0x0000003be21310f0 in QTreeView::viewportEvent(QEvent*) () from /lib64/libQtGui.so.4
#33 0x00000000005cb7b8 in Digikam::AlbumSelectionTreeView::viewportEvent(QEvent*) ()
#34 0x0000003bdf784756 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /lib64/libQtCore.so.4
#35 0x0000003be1bc9ddc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#36 0x0000003be1bd08e9 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#37 0x0000003be3e4a9ca in KApplication::notify(QObject*, QEvent*) () from /lib64/libkdeui.so.5
#38 0x0000003bdf7845ed in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib64/libQtCore.so.4
#39 0x0000003be1bd0017 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /lib64/libQtGui.so.4
#40 0x0000003be1c457cb in QETWidget::translateMouseEvent(_XEvent const*) () from /lib64/libQtGui.so.4
#41 0x0000003be1c4423c in QApplication::x11ProcessEvent(_XEvent*) () from /lib64/libQtGui.so.4
#42 0x0000003be1c6bc34 in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQtGui.so.4
#43 0x0000003bd6a492a6 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#44 0x0000003bd6a49628 in g_main_context_iterate.isra.24 () from /lib64/libglib-2.0.so.0
#45 0x0000003bd6a496dc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#46 0x0000003bdf7b3185 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#47 0x0000003be1c6bdb6 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtGui.so.4
#48 0x0000003bdf78312f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#49 0x0000003bdf78347d in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#50 0x0000003bdf7889bb in QCoreApplication::exec() () from /lib64/libQtCore.so.4
#51 0x00000000004922bd in main ()

Reported using DrKonqi
Comment 1 caulier.gilles 2014-01-08 09:20:39 UTC
It crash in Qt SQlite plugin. There is no reason for that typically...

Gilles Caulier
Comment 2 Jekyll Wu 2014-01-18 05:40:39 UTC
*** Bug 330104 has been marked as a duplicate of this bug. ***
Comment 3 Jekyll Wu 2014-01-19 16:22:09 UTC
*** Bug 330155 has been marked as a duplicate of this bug. ***
Comment 4 umberto valentinotti 2014-01-19 20:14:01 UTC
sorry I'm a new entry for bugtracking system, I would only help tio improve digikam
i use dk with two distro mint16kde and fedora 20 kde, with only one database localized in a separated formatting disk
I use sqlite not mysql
on mint digikam 3.4 go correctly (its seem) but in fedora with the last version 3.5 sometime crash
I have 100.000 photo, two dbase, one for work and one for hobby
when i use the flag or label, when I use workflow,  there is not an exact reason or exact moment.
I note that the workflow, also in 3.4 and 3.5  is not perfect
I noticed that the workflow (button B) does not store the actions previously saved, and I have to set it again every time you open the action (conversion to jpeg-resize-watermark ...)
thanks that all
do you think that is bettere to compile youself digikam? or is the same to download from the repo?
Comment 5 Jekyll Wu 2014-01-23 01:16:07 UTC
*** Bug 330302 has been marked as a duplicate of this bug. ***
Comment 6 Jekyll Wu 2014-01-25 02:42:13 UTC
*** Bug 330370 has been marked as a duplicate of this bug. ***
Comment 7 caulier.gilles 2014-02-01 14:15:46 UTC
*** Bug 330633 has been marked as a duplicate of this bug. ***
Comment 8 caulier.gilles 2014-02-01 21:41:51 UTC
*** Bug 330644 has been marked as a duplicate of this bug. ***
Comment 9 Jekyll Wu 2014-02-02 17:42:32 UTC
*** Bug 330674 has been marked as a duplicate of this bug. ***
Comment 10 Teemu Rytilahti 2014-02-03 10:48:55 UTC
Crashes here on current master, this happened while trying to open a file to editor window:

Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6e01e40980 (LWP 684))]

Thread 9 (Thread 0x7f6dd9d2a700 (LWP 689)):
#0  0x00007f6df47b387d in poll () from /usr/lib/libc.so.6
#1  0x00007f6decbe3908 in ?? () from /usr/lib/libusb-1.0.so.0
#2  0x00007f6df99730a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f6df47bc32d in clone () from /usr/lib/libc.so.6

Thread 8 (Thread 0x7f6dd36ef700 (LWP 690)):
#0  0x00007f6df997703f in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f6df55b9aa8 in wait (time=18446744073709551615, this=0x1d4b030) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1d4af68, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x0000000000696d41 in Digikam::ScanController::run (this=0x1cf1a50) at /home/tpr/storage/kde/digikam-sc/core/digikam/database/scancontroller.cpp:725
#4  0x00007f6df55b95b5 in QThreadPrivate::start (arg=0x1cf1a50) at thread/qthread_unix.cpp:338
#5  0x00007f6df99730a2 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f6df47bc32d in clone () from /usr/lib/libc.so.6

Thread 7 (Thread 0x7f6dd2eee700 (LWP 691)):
#0  0x00007f6df47b387d in poll () from /usr/lib/libc.so.6
#1  0x00007f6df115d584 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f6df115d68c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f6df56f5286 in QEventDispatcherGlib::processEvents (this=0x7f6dc40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00007f6df56c3b5f in QEventLoop::processEvents (this=this@entry=0x7f6dd2eedc20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6df56c3e05 in QEventLoop::exec (this=this@entry=0x7f6dd2eedc20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6df55b706d in QThread::exec (this=this@entry=0x1b01060) at thread/qthread.cpp:536
#7  0x00007f6df56a3ce8 in QInotifyFileSystemWatcherEngine::run (this=0x1b01060) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f6df55b95b5 in QThreadPrivate::start (arg=0x1b01060) at thread/qthread_unix.cpp:338
#9  0x00007f6df99730a2 in start_thread () from /usr/lib/libpthread.so.0
#10 0x00007f6df47bc32d in clone () from /usr/lib/libc.so.6

Thread 6 (Thread 0x7f6dd26ed700 (LWP 693)):
#0  0x00007f6df997703f in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f6df55b9aa8 in wait (time=18446744073709551615, this=0x1e8d450) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1e8dbd8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6dfeecd9c0 in Digikam::ParkingThread::run (this=0x1e8dbc0) at /home/tpr/storage/kde/digikam-sc/core/libs/threads/threadmanager.cpp:119
#4  0x00007f6df55b95b5 in QThreadPrivate::start (arg=0x1e8dbc0) at thread/qthread_unix.cpp:338
#5  0x00007f6df99730a2 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f6df47bc32d in clone () from /usr/lib/libc.so.6

Thread 5 (Thread 0x7f6dacff9700 (LWP 704)):
#0  0x00007f6df99773e8 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f6df55b9a84 in wait (time=30000, this=0x1e2edd0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=mutex@entry=0x1bda998, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6df55acf05 in QThreadPoolThread::run (this=0x3c23080) at concurrent/qthreadpool.cpp:141
#4  0x00007f6df55b95b5 in QThreadPrivate::start (arg=0x3c23080) at thread/qthread_unix.cpp:338
#5  0x00007f6df99730a2 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f6df47bc32d in clone () from /usr/lib/libc.so.6

Thread 4 (Thread 0x7f6d9f7fe700 (LWP 706)):
#0  0x00007f6df99773e8 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f6df55b9a84 in wait (time=30000, this=0x1e2edd0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=mutex@entry=0x1bda998, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6df55acf05 in QThreadPoolThread::run (this=0x3c23940) at concurrent/qthreadpool.cpp:141
#4  0x00007f6df55b95b5 in QThreadPrivate::start (arg=0x3c23940) at thread/qthread_unix.cpp:338
#5  0x00007f6df99730a2 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f6df47bc32d in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f6d83fff700 (LWP 712)):
#0  0x00007f6df99773e8 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f6df55b9a84 in wait (time=30000, this=0x1e2edd0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=mutex@entry=0x1bda998, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6df55acf05 in QThreadPoolThread::run (this=0x3c25380) at concurrent/qthreadpool.cpp:141
#4  0x00007f6df55b95b5 in QThreadPrivate::start (arg=0x3c25380) at thread/qthread_unix.cpp:338
#5  0x00007f6df99730a2 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f6df47bc32d in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f6d7bfef700 (LWP 728)):
#0  0x00007f6df47b54f3 in select () from /usr/lib/libc.so.6
#1  0x00007f6df56a09d3 in QProcessManager::run (this=0x7f6df5a39520 <processManager()::processManager>) at io/qprocess_unix.cpp:247
#2  0x00007f6df55b95b5 in QThreadPrivate::start (arg=0x7f6df5a39520 <processManager()::processManager>) at thread/qthread_unix.cpp:338
#3  0x00007f6df99730a2 in start_thread () from /usr/lib/libpthread.so.0
#4  0x00007f6df47bc32d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f6e01e40980 (LWP 684)):
[KCrash Handler]
#5  0x00007f6ddd419419 in sqlite3MemCompare (pMem1=pMem1@entry=0x7fff04c04700, pMem2=<optimized out>, pColl=0x1c57810) at sqlite3.c:60482
#6  0x00007f6ddd4195d3 in sqlite3VdbeRecordCompare (nKey1=32, pKey1=0x7f6dcc02bddc, pPKey2=pPKey2@entry=0x7fff04c04a10) at sqlite3.c:64160
#7  0x00007f6ddd42da99 in sqlite3BtreeMovetoUnpacked (pCur=0x6513b90, pIdxKey=0x7fff04c04a10, intKey=0, biasRight=<optimized out>, pRes=0x7fff04c04a00) at sqlite3.c:55075
#8  0x00007f6ddd455d42 in sqlite3VdbeExec (p=p@entry=0x6513db8) at sqlite3.c:70166
#9  0x00007f6ddd45e267 in sqlite3Step (p=0x6513db8) at sqlite3.c:64826
#10 sqlite3_step (pStmt=<optimized out>) at sqlite3.c:64892
#11 0x00007f6dd1ce6f88 in QSQLiteResultPrivate::fetchNext (this=this@entry=0x65145f0, values=..., idx=idx@entry=0, initialFetch=initialFetch@entry=true) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:235
#12 0x00007f6dd1ce7e57 in QSQLiteResult::exec (this=0x64e2c00) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:447
#13 0x00007f6e01aa3ced in QSqlQuery::exec (this=0x7fff04c04ff0) at kernel/qsqlquery.cpp:949
#14 0x00007f6dfee65947 in Digikam::DatabaseCoreBackend::exec (this=0x1a81d10, query=...) at /home/tpr/storage/kde/digikam-sc/core/libs/database/core/databasecorebackend.cpp:1415
#15 0x00007f6dfee65a79 in Digikam::DatabaseCoreBackend::execQuery (this=0x1a81d10, query=..., boundValue1=...) at /home/tpr/storage/kde/digikam-sc/core/libs/database/core/databasecorebackend.cpp:1057
#16 0x00007f6dfee651e8 in Digikam::DatabaseCoreBackend::execQuery (this=0x1a81d10, sql=..., boundValue1=...) at /home/tpr/storage/kde/digikam-sc/core/libs/database/core/databasecorebackend.cpp:1006
#17 0x00007f6dfee6512a in Digikam::DatabaseCoreBackend::execSql (this=0x1a81d10, sql=..., boundValue1=..., values=0x7fff04c050b8, lastInsertId=0x0) at /home/tpr/storage/kde/digikam-sc/core/libs/database/core/databasecorebackend.cpp:903
#18 0x00007f6dfe815324 in Digikam::AlbumDB::getSetting (this=0x1a801a0, keyword=...) at /home/tpr/storage/kde/digikam-sc/core/libs/database/albumdb.cpp:970
#19 0x00007f6dfe8154fc in Digikam::AlbumDB::getFilterSettings (this=0x1a801a0, imageFilter=0x7fff04c05310, videoFilter=0x0, audioFilter=0x0) at /home/tpr/storage/kde/digikam-sc/core/libs/database/albumdb.cpp:1017
#20 0x000000000074c906 in Digikam::AlbumSettings::getImageFileFilter (this=0x1bfef50) at /home/tpr/storage/kde/digikam-sc/core/digikam/utils/albumsettings.cpp:919
#21 0x00000000006f2ad7 in Digikam::ImageViewUtilities::openInEditor (this=0x20dc960, info=..., allInfosToOpen=..., currentAlbum=0x4676e80) at /home/tpr/storage/kde/digikam-sc/core/digikam/items/imageviewutilities.cpp:267
#22 0x00000000007752ce in Digikam::DigikamView::slotEditor (this=0x1f85940) at /home/tpr/storage/kde/digikam-sc/core/digikam/views/digikamview.cpp:1666
#23 0x00000000007747a5 in Digikam::DigikamView::slotImageEdit (this=0x1f85940) at /home/tpr/storage/kde/digikam-sc/core/digikam/views/digikamview.cpp:1700
#24 0x000000000077123d in Digikam::DigikamView::qt_static_metacall (_o=0x1f85940, _c=QMetaObject::InvokeMetaMethod, _id=60, _a=0x7fff04c05750) at /home/tpr/storage/kde/digikam-sc/core/build/digikam/digikamview.moc:308
#25 0x00007f6df56dae48 in QMetaObject::activate (sender=sender@entry=0x2f59030, m=m@entry=0x7f6df6eab1a0 <QAction::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff04c05750) at kernel/qobject.cpp:3547
#26 0x00007f6df633ecc2 in QAction::triggered (this=this@entry=0x2f59030, _t1=false) at .moc/debug-shared/moc_qaction.cpp:276
#27 0x00007f6df6340813 in QAction::activate (this=this@entry=0x2f59030, event=event@entry=QAction::Trigger) at kernel/qaction.cpp:1257
#28 0x00007f6df67c26c9 in QMenuPrivate::activateCausedStack (this=this@entry=0x5eb0ad0, causedStack=..., action=action@entry=0x2f59030, action_e=action_e@entry=QAction::Trigger, self=self@entry=true) at widgets/qmenu.cpp:1038
#29 0x00007f6df67c7149 in QMenuPrivate::activateAction (this=0x5eb0ad0, action=0x2f59030, action_e=QAction::Trigger, self=<optimized out>) at widgets/qmenu.cpp:1130
#30 0x00007f6df71df355 in KMenu::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libkdeui.so.5
#31 0x00007f6df639dab8 in QWidget::event (this=this@entry=0x7fff04c068a0, event=event@entry=0x7fff04c05e80) at kernel/qwidget.cpp:8376
#32 0x00007f6df67cb75b in QMenu::event (this=0x7fff04c068a0, e=0x7fff04c05e80) at widgets/qmenu.cpp:2481
#33 0x00007f6df63454a1 in QApplicationPrivate::notify_helper (this=this@entry=0x19c06c0, receiver=receiver@entry=0x7fff04c068a0, e=e@entry=0x7fff04c05e80) at kernel/qapplication.cpp:4562
#34 0x00007f6df634dd10 in QApplication::notify (this=<optimized out>, receiver=0x7fff04c068a0, e=0x7fff04c05e80) at kernel/qapplication.cpp:4105
#35 0x00007f6df712877a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#36 0x00007f6df56c572d in QCoreApplication::notifyInternal (this=0x7fff04c080a8, receiver=receiver@entry=0x7fff04c068a0, event=event@entry=0x7fff04c05e80) at kernel/qcoreapplication.cpp:949
#37 0x00007f6df634bb82 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#38 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x7fff04c068a0, event=event@entry=0x7fff04c05e80, alienWidget=alienWidget@entry=0x0, nativeWidget=nativeWidget@entry=0x7fff04c068a0, buttonDown=buttonDown@entry=0x7f6df6ee6358 <qt_button_down>, lastMouseReceiver=..., spontaneous=spontaneous@entry=true) at kernel/qapplication.cpp:3173
#39 0x00007f6df63c8bfc in QETWidget::translateMouseEvent (this=this@entry=0x7fff04c068a0, event=event@entry=0x7fff04c061c0) at kernel/qapplication_x11.cpp:4451
#40 0x00007f6df63c72a1 in QApplication::x11ProcessEvent (this=0x7fff04c080a8, event=event@entry=0x7fff04c061c0) at kernel/qapplication_x11.cpp:3640
#41 0x00007f6df63ef2f2 in x11EventSourceDispatch (s=0x19bf050, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#42 0x00007f6df115d296 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#43 0x00007f6df115d5e8 in ?? () from /usr/lib/libglib-2.0.so.0
#44 0x00007f6df115d68c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#45 0x00007f6df56f5265 in QEventDispatcherGlib::processEvents (this=0x18b92f0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#46 0x00007f6df63ef3e6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007f6df56c3b5f in QEventLoop::processEvents (this=this@entry=0x7fff04c065c0, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007f6df56c3e05 in QEventLoop::exec (this=this@entry=0x7fff04c065c0, flags=...) at kernel/qeventloop.cpp:204
#49 0x00007f6df67ca507 in QMenu::exec (this=0x7fff04c068a0, p=..., action=0x0) at widgets/qmenu.cpp:2125
#50 0x000000000075ac14 in Digikam::ContextMenuHelper::exec (this=0x7fff04c06888, pos=..., at=0x0) at /home/tpr/storage/kde/digikam-sc/core/digikam/utils/contextmenuhelper.cpp:1132
#51 0x0000000000780462 in Digikam::ImagePreviewView::slotShowContextMenu (this=0x20b32f0, event=0x7fff04c06ec0) at /home/tpr/storage/kde/digikam-sc/core/digikam/views/imagepreviewview.cpp:418
#52 0x000000000077ec3c in Digikam::ImagePreviewView::qt_static_metacall (_o=0x20b32f0, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0x7fff04c06a70) at /home/tpr/storage/kde/digikam-sc/core/build/digikam/imagepreviewview.moc:126
#53 0x00007f6df56dae48 in QMetaObject::activate (sender=0x207d0c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff04c06a70) at kernel/qobject.cpp:3547
#54 0x00007f6dfefc074f in Digikam::GraphicsDImgItem::showContextMenu (this=0x207d0c0, _t1=0x7fff04c06ec0) at /home/tpr/storage/kde/digikam-sc/core/build/digikam/graphicsdimgitem.moc:103
#55 0x00007f6dfefc1a6d in Digikam::GraphicsDImgItem::contextMenuEvent (this=0x207d0c0, e=0x7fff04c06ec0) at /home/tpr/storage/kde/digikam-sc/core/libs/widgets/graphicsview/graphicsdimgitem.cpp:236
#56 0x00007f6dfefc1aaf in non-virtual thunk to Digikam::GraphicsDImgItem::contextMenuEvent(QGraphicsSceneContextMenuEvent*) () at /home/tpr/storage/kde/digikam-sc/core/libs/widgets/graphicsview/graphicsdimgitem.cpp:237
#57 0x00007f6df6968f97 in QGraphicsItem::sceneEvent (this=0x207d0d0, event=0x7fff04c06ec0) at graphicsview/qgraphicsitem.cpp:6720
#58 0x00007f6df69948af in QGraphicsScene::contextMenuEvent (this=<optimized out>, contextMenuEvent=0x7fff04c06ec0) at graphicsview/qgraphicsscene.cpp:3617
#59 0x00007f6df69ab8e5 in QGraphicsScene::event (this=0x20cfdc0, event=0x7fff04c06ec0) at graphicsview/qgraphicsscene.cpp:3412
#60 0x00007f6df63454a1 in QApplicationPrivate::notify_helper (this=this@entry=0x19c06c0, receiver=receiver@entry=0x20cfdc0, e=e@entry=0x7fff04c06ec0) at kernel/qapplication.cpp:4562
#61 0x00007f6df634c33d in QApplication::notify (this=0x7fff04c080a8, receiver=0x20cfdc0, e=0x7fff04c06ec0) at kernel/qapplication.cpp:4348
#62 0x00007f6df712877a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#63 0x00007f6df56c572d in QCoreApplication::notifyInternal (this=0x7fff04c080a8, receiver=0x20cfdc0, event=event@entry=0x7fff04c06ec0) at kernel/qcoreapplication.cpp:949
#64 0x00007f6df69c6117 in sendEvent (event=0x7fff04c06ec0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#65 QGraphicsView::contextMenuEvent (this=0x20b32f0, event=0x7fff04c073a0) at graphicsview/qgraphicsview.cpp:2892
#66 0x00007f6df639de3a in QWidget::event (this=this@entry=0x20b32f0, event=event@entry=0x7fff04c073a0) at kernel/qwidget.cpp:8554
#67 0x00007f6df678592e in QFrame::event (this=0x20b32f0, e=0x7fff04c073a0) at widgets/qframe.cpp:557
#68 0x00007f6df69c5bb8 in QGraphicsView::viewportEvent (this=0x20b32f0, event=0x7fff04c073a0) at graphicsview/qgraphicsview.cpp:2866
#69 0x00007f6df56c5907 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=this@entry=0x19c06c0, receiver=receiver@entry=0x20d1c90, event=event@entry=0x7fff04c073a0) at kernel/qcoreapplication.cpp:1059
#70 0x00007f6df6345491 in QApplicationPrivate::notify_helper (this=this@entry=0x19c06c0, receiver=receiver@entry=0x20d1c90, e=e@entry=0x7fff04c073a0) at kernel/qapplication.cpp:4558
#71 0x00007f6df634da3f in QApplication::notify (this=<optimized out>, receiver=0x20d1c90, e=0x7fff04c073a0) at kernel/qapplication.cpp:4184
#72 0x00007f6df712877a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#73 0x00007f6df56c572d in QCoreApplication::notifyInternal (this=0x7fff04c080a8, receiver=receiver@entry=0x20d1c90, event=event@entry=0x7fff04c073a0) at kernel/qcoreapplication.cpp:949
#74 0x00007f6df63c88f0 in sendSpontaneousEvent (event=0x7fff04c073a0, receiver=0x20d1c90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#75 QETWidget::translateMouseEvent (this=this@entry=0x20b32f0, event=event@entry=0x7fff04c076e0) at kernel/qapplication_x11.cpp:4522
#76 0x00007f6df63c72a1 in QApplication::x11ProcessEvent (this=0x7fff04c080a8, event=event@entry=0x7fff04c076e0) at kernel/qapplication_x11.cpp:3640
#77 0x00007f6df63ef2f2 in x11EventSourceDispatch (s=0x19bf050, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#78 0x00007f6df115d296 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#79 0x00007f6df115d5e8 in ?? () from /usr/lib/libglib-2.0.so.0
#80 0x00007f6df115d68c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#81 0x00007f6df56f5265 in QEventDispatcherGlib::processEvents (this=0x18b92f0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#82 0x00007f6df63ef3e6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#83 0x00007f6df56c3b5f in QEventLoop::processEvents (this=this@entry=0x7fff04c07ad0, flags=...) at kernel/qeventloop.cpp:149
#84 0x00007f6df56c3e05 in QEventLoop::exec (this=this@entry=0x7fff04c07ad0, flags=...) at kernel/qeventloop.cpp:204
#85 0x00007f6df56c9c89 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#86 0x000000000082248b in main (argc=1, argv=0x7fff04c082c8) at /home/tpr/storage/kde/digikam-sc/core/digikam/main/main.cpp:236
Comment 11 caulier.gilles 2014-02-03 12:37:33 UTC
It's not reproducible here...

digiKam version 4.0.0-beta3
Demosaic GPL2 pack support: No
Demosaic GPL3 pack support: No
Exiv2 can write to Jp2: Yes
Exiv2 can write to Jpeg: Yes
Exiv2 can write to Pgf: Yes
Exiv2 can write to Png: Yes
Exiv2 can write to Tiff: Yes
Exiv2 supports XMP metadata: Yes
LibCImg: 130
LibEigen: 3.1.2
LibExiv2: 0.23
LibJPEG: 80
LibJasper: 1.900.1
LibKDE: 4.10.5
LibKExiv2: 2.3.1
LibKGeoMap: 2.0.0
LibKdcraw: 2.4.2
LibLCMS: 2050
LibLensFun: 0.2.6-0
LibPGF: 6.13.45 - internal library
LibPNG: 1.5.13
LibQt: 4.8.5
LibRaw: 0.16.0-Alpha2
LibTIFF: LIBTIFF, Version 4.0.3 Copyright (c) 1988-1996 Sam Leffler Copyright (c) 1991-1996 Silicon Graphics, Inc.
Marble Widget: 0.15.1 (stable version)
Parallelized PGF codec: No
Parallelized demosaicing: Yes
RawSpeed codec support: No
Database backend: QSQLITE
Kipi-Plugins: 4.0.0-beta3
LibGphoto2: 2.5.2
LibKface: 3.0.0
LibKipi: 2.1.0
LibOpenCV: 2.4.3
Comment 12 Jekyll Wu 2014-02-17 02:58:58 UTC
*** Bug 331220 has been marked as a duplicate of this bug. ***
Comment 13 Andreas Mair 2014-02-18 11:46:13 UTC
After a recent Gentoo Linux update I also had lots of those crashes. It really drove me nuts because they all happened by simply selecting an image of a folder and it didn't take many clicks (sometimes 2-3 were enough).
Searching the Internet soon showed the right direction: sqlite 3.8

After downgrading sqlite 3.8.2 to 3.7.17 everything is fine again. No more crashes!

So I wonder what sqlite the OP uses.

Best regards,
Andreas
Comment 14 André Hübert Johansen 2014-02-18 22:06:28 UTC
sqlite-3.8.2-1.fc20.x86_64
Comment 15 Andreas Mair 2014-02-19 07:05:39 UTC
@André Johansen: Already tried to downgrade sqlite to 3.7.17?
Comment 16 caulier.gilles 2014-03-13 16:05:58 UTC
*** Bug 332100 has been marked as a duplicate of this bug. ***
Comment 17 Jekyll Wu 2014-04-10 00:32:50 UTC
*** Bug 333243 has been marked as a duplicate of this bug. ***
Comment 18 Peter Albrecht 2014-04-11 09:35:14 UTC
I can confirm experiences of Andreas Mair in comment #13:
I also use Gentoo Linux. Since a few weeks, digikam crashes at all kinds of actions: Editing photos, assigning tags, ...

KDE crash handler always lists sqlite:
  Thread 1 (Thread 0x7f6245ec5800 (LWP 1870)):
  [KCrash Handler]
  #6  0x00000000036ed770 in ?? ()
  #7  0x00007f62310d0dae in sqlite3MemCompare (pMem1=<optimized out>, pMem2=0x3ea0728, pColl=0x4a647b8) at sqlite3.c:60468
  #8  0x00007f62310d10dd in sqlite3VdbeRecordCompare (nKey1=18, pKey1=0x7f62242528e9, pPKey2=0x7ffff2e9cbe0) at sqlite3.c:64160
  #9  0x00007f62310f277b in sqlite3BtreeMovetoUnpacked (pRes=<optimized out>, biasRight=<optimized out>, intKey=<optimized out>, pIdxKey=<optimized out>, pCur=<optimized out>) at sqlite3.c:55075
  #10 sqlite3BtreeMovetoUnpacked (pCur=0x42fc920, pIdxKey=0x7ffff2e9cbe0, intKey=0, biasRight=<optimized out>, pRes=0x7ffff2e9cbd0) at sqlite3.c:54960
  #11 0x00007f62310fde0e in sqlite3VdbeExec (p=0xaf72d78) at sqlite3.c:70166
  #12 0x00007f623110645f in sqlite3Step (p=0xaf72d78) at sqlite3.c:64826
  ...

Looking at my emerge.log, I did an update of "dev-db/sqlite-3.7.17" to "dev-db/sqlite-3.8.2" 8 weeks ago.

> After downgrading sqlite 3.8.2 to 3.7.17 everything is fine again. No more crashes!
Thanks for the tip! By today, there is no more "sqlite-3.7.x" in portage tree. So I will try the current top up-to-date version "dev-db/sqlite-3.8.4.3".
Comment 19 Peter Albrecht 2014-04-11 09:57:00 UTC
I filed a bug report at gentoo's bugtracker, too: https://bugs.gentoo.org/show_bug.cgi?id=507394
Comment 20 Jekyll Wu 2014-04-14 01:19:49 UTC
*** Bug 333389 has been marked as a duplicate of this bug. ***
Comment 21 caulier.gilles 2014-04-20 07:42:58 UTC
*** Bug 333642 has been marked as a duplicate of this bug. ***
Comment 22 Jekyll Wu 2014-04-21 05:52:39 UTC
*** Bug 333671 has been marked as a duplicate of this bug. ***
Comment 23 Jekyll Wu 2014-04-21 06:00:10 UTC
*** Bug 333660 has been marked as a duplicate of this bug. ***
Comment 24 Jekyll Wu 2014-04-23 00:41:18 UTC
*** Bug 333741 has been marked as a duplicate of this bug. ***
Comment 25 Jekyll Wu 2014-04-23 01:03:46 UTC
*** Bug 333700 has been marked as a duplicate of this bug. ***
Comment 26 Jekyll Wu 2014-04-24 00:45:47 UTC
*** Bug 333791 has been marked as a duplicate of this bug. ***
Comment 27 Jekyll Wu 2014-04-24 00:46:18 UTC
*** Bug 333792 has been marked as a duplicate of this bug. ***
Comment 28 Jekyll Wu 2014-04-24 00:47:59 UTC
*** Bug 333790 has been marked as a duplicate of this bug. ***
Comment 29 pierre_metzner 2014-04-26 08:36:47 UTC
Created attachment 86274 [details]
New crash information added by DrKonqi

digikam (3.5.0) on KDE Platform 4.13.0 using Qt 4.8.6

- What I was doing when the application crashed:

I add Tags to potos. But digicam crashes als in other situations. I have this problem after the update to Kubuntu 14.04.

-- Backtrace (Reduced):
#6  0x00007fbcf3bc3da9 in sqlite3MemCompare (pMem1=pMem1@entry=0x7fffecb86cf0, pMem2=<optimized out>, pColl=0x8695a98) at sqlite3.c:60484
#7  0x00007fbcf3bc3f63 in sqlite3VdbeRecordCompare (nKey1=17, pKey1=0x7fbcdc342557, pPKey2=pPKey2@entry=0x7fffecb87008) at sqlite3.c:64162
#8  0x00007fbcf3bd8579 in sqlite3BtreeMovetoUnpacked (pCur=0xb3d6418, pIdxKey=0x7fffecb87008, intKey=0, biasRight=<optimized out>, pRes=0x7fffecb86ff0) at sqlite3.c:55077
#9  0x00007fbcf3c00848 in sqlite3VdbeExec (p=p@entry=0xa9dda78) at sqlite3.c:70345
#10 0x00007fbcf3c08ed7 in sqlite3Step (p=0xa9dda78) at sqlite3.c:64828
Comment 30 caulier.gilles 2014-04-26 09:44:23 UTC
It sound like a binary compatibility issue with sqlite package against digiKam (through Qt4 Sqlite plugin). digiKam is not linked to Sqlite directly.

A lots of people report the same problem at the same time. Nothing has changed in digiKam DB interface since a long time. So for me, it's a side effect in packaging, perhaps in Qt4, perhaps in Sqlite, i don't know.

Crash is not reproducible here under Mageia 3 and OSX (through updated macport) 

Which Sqlite version is used ?
Which distro is used ?
Which Qt4 version is used ?

Gilles Caulier
Comment 31 pierre_metzner 2014-04-26 13:12:24 UTC
Dear Gilles Caulier,

thanks for the answer.

I belive it's a problem with the database. When I make changes in the tags, a process starts and after a while DigiKam crashes.

I have installed:
sqlite3 --> 3.8.2 2013-12-06 14:53:30
qt --> 4.8.5
distro --> Kubuntu 14.04

Pierre Metzner
Comment 32 Marcel Wiesweg 2014-04-26 15:54:12 UTC
Some users have clearly pointed the problem to an update SQLite 3.7 -> 3.8.
There could be incompatibilities with the Qt SQLite driver, I would not assume that the problem can be in any digikam code  - multiple code paths from within digikam lead through the Qt SQL driver to a crash in a common location.
valgrind may or may not give some further information.
Comment 33 ki-mech 2014-04-26 17:19:53 UTC
(In reply to comment #30)
Same problem here with versions

$ sqlite3 -version
3.8.2 2013-12-06 14:53:30 

Ubuntu 14.04 LTS

libqtcore4 has version 4.8.5
Comment 34 caulier.gilles 2014-04-27 10:12:41 UTC
*** Bug 333952 has been marked as a duplicate of this bug. ***
Comment 35 caulier.gilles 2014-04-27 11:23:52 UTC
*** Bug 333953 has been marked as a duplicate of this bug. ***
Comment 36 Jekyll Wu 2014-04-28 02:14:06 UTC
*** Bug 333976 has been marked as a duplicate of this bug. ***
Comment 37 Fero 2014-04-28 07:04:51 UTC
(In reply to comment #31)

Hello,

I confirm the issue in kubuntu 14.04 + sqlite + qt4. Digikam often crashes, mostly when working with tags.

Best regards

Frantisek
Comment 38 caulier.gilles 2014-04-28 12:40:44 UTC
*** Bug 334017 has been marked as a duplicate of this bug. ***
Comment 39 Jekyll Wu 2014-04-29 02:17:44 UTC
*** Bug 334042 has been marked as a duplicate of this bug. ***
Comment 40 Jekyll Wu 2014-04-29 17:02:29 UTC
*** Bug 333787 has been marked as a duplicate of this bug. ***
Comment 41 caulier.gilles 2014-04-29 21:10:51 UTC
*** Bug 334105 has been marked as a duplicate of this bug. ***
Comment 42 Teemu Rytilahti 2014-04-29 21:17:16 UTC
Has this been reported to an upstream (Qt/Sqlite?), perhaps they could have an idea what'd be the problem?
Comment 43 caulier.gilles 2014-04-29 21:27:38 UTC
Hi Teemu,

No i think it don't have been yet reported as upstream.

Gilles
Comment 44 Nikita Melnichenko 2014-04-30 06:24:44 UTC
Created attachment 86363 [details]
New crash information added by DrKonqi

digikam (3.5.0) on KDE Platform 4.11.5 using Qt 4.8.5

- What I was doing when the application crashed:
Browsing albums. I confirm this started to frequently happen after upgrading sqlite from 3.7 to 3.8.

-- Backtrace (Reduced):
#7  0x00007fd62f57a566 in sqlite3MemCompare (pMem1=pMem1@entry=0x7fff88c12e30, pMem2=<optimized out>, pColl=0xef7948) at sqlite3.c:60482
#8  0x00007fd62f57a968 in sqlite3VdbeRecordCompare (nKey1=19, pKey1=0x7fd62417a018, pPKey2=pPKey2@entry=0x7fff88c13290) at sqlite3.c:64160
#9  0x00007fd62f59eeb7 in sqlite3BtreeMovetoUnpacked (pRes=<optimized out>, biasRight=<optimized out>, intKey=<optimized out>, pIdxKey=<optimized out>, pCur=<optimized out>) at sqlite3.c:55075
#10 sqlite3BtreeMovetoUnpacked (pCur=0x32880e0, pIdxKey=0x7fff88c13290, intKey=0, biasRight=<optimized out>, pRes=0x7fff88c13280) at sqlite3.c:54960
#11 0x00007fd62f5a777e in sqlite3VdbeExec (p=p@entry=0x114ebd8) at sqlite3.c:70166
Comment 45 Christoph Feck 2014-05-01 15:29:00 UTC
*** Bug 334186 has been marked as a duplicate of this bug. ***
Comment 46 caulier.gilles 2014-05-01 19:23:10 UTC
*** Bug 334189 has been marked as a duplicate of this bug. ***
Comment 47 Malcolm Beckett 2014-05-01 22:02:43 UTC
Since an auto-update to sqlite 3.8.3, this bug seems to have stopped occurring, in my Fedora 20 system.
Comment 48 caulier.gilles 2014-05-02 07:14:50 UTC
Hi Malcolm,

This what i suspected a lot...

Gilles Caulier
Comment 49 Peter Albrecht 2014-05-02 16:58:08 UTC
I have similar results as Malcolm in comment #47:
Since I am using "dev-db/sqlite-3.8.4.3" (see comment #18), I been working several hours with digikam 3.5.0 by now and processing more than 640 picture without one single sqlite-crash as mentioned above. :)

So this problem seems to be limited to sqlite version 3.8.2.x.
Comment 50 caulier.gilles 2014-05-04 06:06:30 UTC
*** Bug 334310 has been marked as a duplicate of this bug. ***
Comment 51 Christoph Feck 2014-05-04 19:00:14 UTC
*** Bug 334344 has been marked as a duplicate of this bug. ***
Comment 52 Jekyll Wu 2014-05-05 01:13:25 UTC
*** Bug 334350 has been marked as a duplicate of this bug. ***
Comment 53 Jekyll Wu 2014-05-07 00:38:09 UTC
*** Bug 334443 has been marked as a duplicate of this bug. ***
Comment 54 Nikita Melnichenko 2014-05-08 05:01:57 UTC
Looks like dev-db/sqlite-3.8.4.3 fixed issues for me too.
Comment 55 caulier.gilles 2014-05-08 05:28:39 UTC
Ok thanks

I close this file as UPSTREAM

Gilles Caulier
Comment 56 Axel Krebs 2014-05-08 05:52:07 UTC
Any recommendation?
-> migrate to mysql
-> downgrade sqlite,

e.g.?

Axel
Comment 57 caulier.gilles 2014-05-08 08:59:59 UTC
It's a Sqlite bug. You must upgrate to new sqlite release, including an upgrate of QtSlqite plugin, else plroblem will not resolved for digiKam.

This a weird side-effect of downstream bug which downgrade stability of client application.

As Sqlite is used in a lots of appplication, i'm sure that digiKam is not the only one affected by this problem. Sqlite package will be certainly updated in your distro quickly...

No need to use Mysql here. Mysql interface in digiKam as old dysfunctions not yet fixed.

Gilles Caulier
Comment 58 b3nmore 2014-05-11 08:43:55 UTC
FYI, I reported this issue for ubuntu at https://bugs.launchpad.net/ubuntu/+source/digikam/+bug/1315932 and asked for updating sqlite3 at https://bugs.launchpad.net/ubuntu/+source/sqlite3/+bug/1317449 . As a temporary workaround I use the sqlite3 (3.8.4) packages from debian testing, which solves this issue for me.
Comment 59 Jekyll Wu 2014-05-13 15:51:40 UTC
*** Bug 334712 has been marked as a duplicate of this bug. ***
Comment 60 caulier.gilles 2014-05-13 17:04:51 UTC
*** Bug 334718 has been marked as a duplicate of this bug. ***
Comment 61 Christoph Feck 2014-05-16 04:35:51 UTC
*** Bug 334852 has been marked as a duplicate of this bug. ***
Comment 62 Jekyll Wu 2014-05-16 06:59:51 UTC
*** Bug 334853 has been marked as a duplicate of this bug. ***
Comment 63 Jekyll Wu 2014-05-18 09:57:35 UTC
*** Bug 334986 has been marked as a duplicate of this bug. ***
Comment 64 Jekyll Wu 2014-05-19 02:21:28 UTC
*** Bug 335020 has been marked as a duplicate of this bug. ***
Comment 65 Brylie Christopher Oxley 2014-05-19 06:19:34 UTC
Hi all,
If you use Ubuntu, or any derivative such as Kububtu, please mark "This bug affects me" by clicking on "Does this bug affect you?" on the following page:
https://bugs.launchpad.net/ubuntu/+source/sqlite3/+bug/1317449
Comment 66 Adam Porter 2014-05-19 06:43:28 UTC
Done.  Thanks, Brylie.
Comment 67 Adam Porter 2014-05-19 06:47:27 UTC
By the way, the Ubuntu bug is marked as a Wishlist bug since the fix seems to be upgrading the minor version of SQLite.  However, since it's causing crashes, I believe it should be classified as a bug, not a wishlist item.  Please also encourage Ubuntu to step up and fix this.  Wishlist items in released distros tend to get ignored.
Comment 68 Jekyll Wu 2014-05-19 20:26:28 UTC
*** Bug 335052 has been marked as a duplicate of this bug. ***
Comment 69 Jekyll Wu 2014-05-20 02:04:45 UTC
*** Bug 335055 has been marked as a duplicate of this bug. ***
Comment 70 caulier.gilles 2014-05-20 05:30:11 UTC
*** Bug 335059 has been marked as a duplicate of this bug. ***
Comment 71 caulier.gilles 2014-05-21 12:14:29 UTC
*** Bug 335136 has been marked as a duplicate of this bug. ***
Comment 72 Christoph Feck 2014-05-22 22:44:33 UTC
*** Bug 335226 has been marked as a duplicate of this bug. ***
Comment 73 caulier.gilles 2014-05-23 09:58:57 UTC
*** Bug 335234 has been marked as a duplicate of this bug. ***
Comment 74 Jekyll Wu 2014-05-24 00:37:13 UTC
*** Bug 335260 has been marked as a duplicate of this bug. ***
Comment 75 Jekyll Wu 2014-05-25 03:28:27 UTC
*** Bug 335297 has been marked as a duplicate of this bug. ***
Comment 76 H Law 2014-05-27 14:05:59 UTC
The same problem here.   A similar extract:

Thread 1 (Thread 0x7f47e1b86840 (LWP 18412)):
[KCrash Handler]
#5  0x0000000000000052 in ?? ()
#6  0x00007f47c5eccdac in sqlite3MemCompare (pMem1=pMem1@entry=0x7fffb076d470, pMem2=<optimized out>, pColl=0x569c298) at sqlite3.c:60484
#7  0x00007f47c5eccf63 in sqlite3VdbeRecordCompare (nKey1=18, pKey1=0x7f47ac07489a, pPKey2=pPKey2@entry=0x7fffb076d770) at sqlite3.c:64162
#8  0x00007f47c5ee1579 in sqlite3BtreeMovetoUnpacked (pCur=0x54f45c0, pIdxKey=0x7fffb076d770, intKey=0, biasRight=<optimized out>, pRes=0x7fffb076d760) at sqlite3.c:55077
#9  0x00007f47c5f099c5 in sqlite3VdbeExec (p=p@entry=0x5dbce58) at sqlite3.c:70168
#10 0x00007f47c5f11ed7 in sqlite3Step (p=0x5dbce58) at sqlite3.c:64828
#11 sqlite3_step (pStmt=<optimized out>) at sqlite3.c:64894
#12 0x00007f47b28d211c in QSQLiteResultPrivate::fetchNext (this=this@entry=0x65e1ea0, values=..., idx=idx@entry=0, initialFetch=initialFetch@entry=true) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:235

I compiled digikam 4.0.0 from source.  It was fine under ubuntu (12.10) but after upgrading to ubuntu 14.04 (sqlite 3.8.2) and recompiling, random crashes appeared.  Since almost the same code base is used to compile in both cases, it could be confirmed that this is not an issue of digikam. (I have since made patches to other areas but should not be relevant to db access).
Will try upgrading sqlite.
Comment 77 caulier.gilles 2014-05-29 13:33:28 UTC
*** Bug 335526 has been marked as a duplicate of this bug. ***
Comment 78 caulier.gilles 2014-05-29 16:00:52 UTC
*** Bug 335529 has been marked as a duplicate of this bug. ***
Comment 79 caulier.gilles 2014-05-30 12:43:13 UTC
*** Bug 335574 has been marked as a duplicate of this bug. ***
Comment 80 caulier.gilles 2014-05-31 12:15:14 UTC
*** Bug 335622 has been marked as a duplicate of this bug. ***
Comment 81 Christoph Feck 2014-05-31 23:10:18 UTC
*** Bug 335630 has been marked as a duplicate of this bug. ***
Comment 82 Jekyll Wu 2014-06-02 00:37:07 UTC
*** Bug 335667 has been marked as a duplicate of this bug. ***
Comment 83 caulier.gilles 2014-06-02 06:42:18 UTC
*** Bug 335684 has been marked as a duplicate of this bug. ***
Comment 84 caulier.gilles 2014-06-02 06:42:42 UTC
*** Bug 335685 has been marked as a duplicate of this bug. ***
Comment 85 caulier.gilles 2014-06-05 18:12:16 UTC
*** Bug 335847 has been marked as a duplicate of this bug. ***
Comment 86 Christoph Feck 2014-06-09 00:40:23 UTC
*** Bug 335978 has been marked as a duplicate of this bug. ***
Comment 87 caulier.gilles 2014-06-09 15:24:27 UTC
*** Bug 336005 has been marked as a duplicate of this bug. ***
Comment 88 caulier.gilles 2014-06-14 10:52:01 UTC
*** Bug 336208 has been marked as a duplicate of this bug. ***
Comment 89 caulier.gilles 2014-06-15 13:32:08 UTC
*** Bug 336261 has been marked as a duplicate of this bug. ***
Comment 90 caulier.gilles 2014-06-15 13:32:45 UTC
*** Bug 336260 has been marked as a duplicate of this bug. ***
Comment 91 caulier.gilles 2014-06-15 13:33:30 UTC
*** Bug 336259 has been marked as a duplicate of this bug. ***
Comment 92 RJVB 2014-06-17 17:47:38 UTC
Created attachment 87235 [details]
New crash information added by DrKonqi

digikam (4.0.0) on KDE Platform 4.13.1 using Qt 4.8.6

- What I was doing when the application crashed:
Another sample of the sql-related crash-when-opening-an-image-for-editing issue, on a freshly updated Kubuntu 14.04/KDE 4.13.1 system (Digikam was installed after said update).

-- Backtrace (Reduced):
#7  0x00007f1181b96dac in sqlite3MemCompare (pMem1=pMem1@entry=0x7fffe1e68ce0, pMem2=<optimized out>, pColl=0xa4ee338) at sqlite3.c:60484
#8  0x00007f1181b96f63 in sqlite3VdbeRecordCompare (nKey1=24, pKey1=0x7f11600979ae, pPKey2=pPKey2@entry=0x7fffe1e68fe0) at sqlite3.c:64162
#9  0x00007f1181bab579 in sqlite3BtreeMovetoUnpacked (pCur=0xadd9a50, pIdxKey=0x7fffe1e68fe0, intKey=0, biasRight=<optimized out>, pRes=0x7fffe1e68fd0) at sqlite3.c:55077
#10 0x00007f1181bd39c5 in sqlite3VdbeExec (p=p@entry=0x6b3e418) at sqlite3.c:70168
#11 0x00007f1181bdbed7 in sqlite3Step (p=0x6b3e418) at sqlite3.c:64828
Comment 93 caulier.gilles 2014-06-17 18:13:08 UTC
Qt SQL driver need to be updated and also libsqlite. Updating digiKAm is not enough especially if packager don't take a care about this UPSTREAM problem..

As it have already said in this file, problem is located into sqlite implementation.

Gilles Caulier
Comment 94 RJVB 2014-06-19 18:37:33 UTC
Anyone managed to find updated (4.8.6) Qt packages for (K)Ubuntu?
Comment 95 caulier.gilles 2014-06-20 20:52:38 UTC
*** Bug 336514 has been marked as a duplicate of this bug. ***
Comment 96 caulier.gilles 2014-06-29 14:21:06 UTC
*** Bug 336869 has been marked as a duplicate of this bug. ***
Comment 97 Christoph Feck 2014-07-03 18:52:26 UTC
*** Bug 337018 has been marked as a duplicate of this bug. ***
Comment 98 caulier.gilles 2014-07-06 18:21:37 UTC
*** Bug 337146 has been marked as a duplicate of this bug. ***
Comment 99 caulier.gilles 2014-07-09 07:30:17 UTC
*** Bug 337258 has been marked as a duplicate of this bug. ***
Comment 100 caulier.gilles 2014-07-09 15:28:15 UTC
*** Bug 337278 has been marked as a duplicate of this bug. ***
Comment 101 rbk1rbk 2014-07-14 20:32:06 UTC
- What I was doing when the application crashed:

I was adding a new tag to a picture. For some time I ran digikam against mysql, then I migrated back to sqlite. Since then digikam is crashing frequently. Also I enabled face detection.
After migration from mysql to sqlite I hit an issue where tags were missing and digikam ran from a console reported, that there is no parent tag (-1). I changed parent tag from -1 to 0 (zero) in sqlite database, now tags are back.
Comment 102 Christoph Feck 2014-07-19 16:13:49 UTC
*** Bug 337607 has been marked as a duplicate of this bug. ***
Comment 103 Christoph Feck 2014-07-27 16:39:49 UTC
*** Bug 337839 has been marked as a duplicate of this bug. ***
Comment 104 caulier.gilles 2014-08-10 09:22:58 UTC
*** Bug 338164 has been marked as a duplicate of this bug. ***
Comment 105 Christoph Feck 2014-08-12 17:30:06 UTC
*** Bug 338144 has been marked as a duplicate of this bug. ***
Comment 106 caulier.gilles 2014-08-18 18:38:57 UTC
*** Bug 338358 has been marked as a duplicate of this bug. ***
Comment 107 caulier.gilles 2014-08-21 21:50:46 UTC
*** Bug 338448 has been marked as a duplicate of this bug. ***
Comment 108 caulier.gilles 2014-08-27 17:26:19 UTC
*** Bug 338600 has been marked as a duplicate of this bug. ***
Comment 109 caulier.gilles 2014-09-14 14:46:53 UTC
*** Bug 339068 has been marked as a duplicate of this bug. ***
Comment 110 caulier.gilles 2014-09-14 14:47:13 UTC
*** Bug 339070 has been marked as a duplicate of this bug. ***
Comment 111 caulier.gilles 2014-09-21 08:52:42 UTC
*** Bug 339263 has been marked as a duplicate of this bug. ***
Comment 112 caulier.gilles 2014-10-03 20:38:58 UTC
*** Bug 339650 has been marked as a duplicate of this bug. ***
Comment 113 caulier.gilles 2014-11-09 22:41:55 UTC
*** Bug 340792 has been marked as a duplicate of this bug. ***
Comment 114 caulier.gilles 2014-12-03 13:40:49 UTC
*** Bug 341529 has been marked as a duplicate of this bug. ***
Comment 115 caulier.gilles 2014-12-15 21:42:02 UTC
*** Bug 341929 has been marked as a duplicate of this bug. ***
Comment 116 caulier.gilles 2014-12-20 19:40:28 UTC
*** Bug 342050 has been marked as a duplicate of this bug. ***
Comment 117 Christoph Feck 2014-12-23 00:27:09 UTC
*** Bug 342143 has been marked as a duplicate of this bug. ***
Comment 118 caulier.gilles 2015-01-03 08:11:27 UTC
*** Bug 342433 has been marked as a duplicate of this bug. ***
Comment 119 Matthias Andree 2015-01-06 20:37:20 UTC
(In reply to b3nmore from comment #58)
> FYI, I reported this issue for ubuntu at
> https://bugs.launchpad.net/ubuntu/+source/digikam/+bug/1315932 and asked for
> updating sqlite3 at
> https://bugs.launchpad.net/ubuntu/+source/sqlite3/+bug/1317449 . As a
> temporary workaround I use the sqlite3 (3.8.4) packages from debian testing,
> which solves this issue for me.

I set up a PPA for Ubuntu 14.04 LTS that has a newer sqlite3 build. I made my life easy and just rebuilt the utopic unicorn src dpkg, and I do not intend to support this; it's a makeshift arrangement.
https://launchpad.net/~matthias-andree/+archive/ubuntu/trusty-fixes

Ubuntu packagers aren't helpful and are asking that someone isolates the fix from the upgraded sqlite3 package.
Comment 120 caulier.gilles 2015-01-11 21:38:34 UTC
*** Bug 342750 has been marked as a duplicate of this bug. ***
Comment 121 caulier.gilles 2015-01-13 19:23:29 UTC
*** Bug 342802 has been marked as a duplicate of this bug. ***
Comment 122 Christoph Feck 2015-01-18 19:39:06 UTC
*** Bug 343014 has been marked as a duplicate of this bug. ***
Comment 123 caulier.gilles 2015-01-24 16:07:44 UTC
*** Bug 343243 has been marked as a duplicate of this bug. ***
Comment 124 caulier.gilles 2015-02-16 06:14:17 UTC
*** Bug 344216 has been marked as a duplicate of this bug. ***
Comment 125 caulier.gilles 2015-02-17 22:00:36 UTC
*** Bug 344299 has been marked as a duplicate of this bug. ***
Comment 126 caulier.gilles 2015-02-26 11:19:30 UTC
*** Bug 344587 has been marked as a duplicate of this bug. ***
Comment 127 caulier.gilles 2015-03-11 10:53:28 UTC
*** Bug 345044 has been marked as a duplicate of this bug. ***
Comment 128 caulier.gilles 2015-03-21 22:55:12 UTC
*** Bug 345402 has been marked as a duplicate of this bug. ***
Comment 129 caulier.gilles 2015-04-06 08:08:52 UTC
*** Bug 345907 has been marked as a duplicate of this bug. ***
Comment 130 caulier.gilles 2015-05-02 13:06:55 UTC
*** Bug 347054 has been marked as a duplicate of this bug. ***
Comment 131 caulier.gilles 2015-05-03 15:18:23 UTC
*** Bug 347107 has been marked as a duplicate of this bug. ***
Comment 132 caulier.gilles 2015-05-06 22:18:53 UTC
*** Bug 347340 has been marked as a duplicate of this bug. ***
Comment 133 Ben 2015-05-07 22:41:58 UTC
Created attachment 92487 [details]
New crash information added by DrKonqi

digikam (4.0.0) on KDE Platform 4.14.2 using Qt 4.8.6

- What I was doing when the application crashed:

Upon selecting a new album digiKam crashes 5 times out of 10. This happens especially when the album I just selected is stil generating thumbnails.

-- Backtrace (Reduced):
#6  0x00007f9ac91d0da9 in sqlite3MemCompare (pMem1=pMem1@entry=0x7fff2e5c2b90, pMem2=<optimized out>, pColl=0x137c098) at sqlite3.c:60484
#7  0x00007f9ac91d0f63 in sqlite3VdbeRecordCompare (nKey1=18, pKey1=0x7f9ab411c1af, pPKey2=pPKey2@entry=0x7fff2e5c2e90) at sqlite3.c:64162
#8  0x00007f9ac91e5579 in sqlite3BtreeMovetoUnpacked (pCur=0x430c220, pIdxKey=0x7fff2e5c2e90, intKey=0, biasRight=<optimized out>, pRes=0x7fff2e5c2e80) at sqlite3.c:55077
#9  0x00007f9ac920d9c5 in sqlite3VdbeExec (p=p@entry=0x500ebe8) at sqlite3.c:70168
#10 0x00007f9ac9215ed7 in sqlite3Step (p=0x500ebe8) at sqlite3.c:64828
Comment 134 Christoph Feck 2015-05-07 23:01:20 UTC
Ben, and you also get these crashes if you upgrade sqlite3 package to version 3.8.4 or newer, as is suggested in the comments of this bug report?
Comment 135 caulier.gilles 2015-05-09 04:59:38 UTC
*** Bug 347450 has been marked as a duplicate of this bug. ***
Comment 136 Ben 2015-05-09 11:22:31 UTC
(In reply to Christoph Feck from comment #134)
> Ben, and you also get these crashes if you upgrade sqlite3 package to
> version 3.8.4 or newer, as is suggested in the comments of this bug report?

I did update sqlite3 to the latest version available on my distro. The crash still happens, on a less regular bases though.

It happens mainly when am switching albums while the album I am in still loads thumbnails.
Comment 137 caulier.gilles 2015-05-09 11:58:45 UTC
This is not enough to update sqlite. The qt-sqlite plugin must be updated too.

Gilles Caulier
Comment 138 caulier.gilles 2015-05-10 08:28:25 UTC
*** Bug 341424 has been marked as a duplicate of this bug. ***
Comment 139 caulier.gilles 2015-05-16 10:38:51 UTC
*** Bug 347786 has been marked as a duplicate of this bug. ***
Comment 140 Otto Dämon 2015-06-02 19:50:05 UTC
First I tried to update some single packages in synaptic as also
described in some comments. In the end I made a mistake and practically
my complete GUI was deinstalled. At best I am a script kid...
After a new install of ubuntu 14.04, the problem was still comparable.
Now I tried the ppa made by Matthias Andree (Comment 119). This worked
very well for me too. Digikam is now stable!
Thanks a lot to Matthias!

Am Sonntag, den 10.05.2015, 08:28 +0000 schrieb Gilles Caulier:
> https://bugs.kde.org/show_bug.cgi?id=329697
> 
> Gilles Caulier <caulier.gilles@gmail.com> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |jabog6@yahoo.com
> 
> --- Comment #138 from Gilles Caulier <caulier.gilles@gmail.com> ---
> *** Bug 341424 has been marked as a duplicate of this bug. ***
>
Comment 141 Ben 2015-06-06 23:13:01 UTC
Created attachment 93046 [details]
New crash information added by DrKonqi

digikam (4.0.0) on KDE Platform 4.14.2 using Qt 4.8.6

Selecting a picture in an album

It reproduces sometimes and is not related to any specific album.

-- Backtrace (Reduced):
#7  0x00007fe71a6d7dac in sqlite3MemCompare (pMem1=pMem1@entry=0x7fffc4a3c1f0, pMem2=<optimized out>, pColl=0x10d01118) at sqlite3.c:60484
#8  0x00007fe71a6d7f63 in sqlite3VdbeRecordCompare (nKey1=18, pKey1=0x7fe7041e026f, pPKey2=pPKey2@entry=0x7fffc4a3c4f0) at sqlite3.c:64162
#9  0x00007fe71a6ec579 in sqlite3BtreeMovetoUnpacked (pCur=0x110cfed0, pIdxKey=0x7fffc4a3c4f0, intKey=0, biasRight=<optimized out>, pRes=0x7fffc4a3c4e0) at sqlite3.c:55077
#10 0x00007fe71a7149c5 in sqlite3VdbeExec (p=p@entry=0x1226c408) at sqlite3.c:70168
#11 0x00007fe71a71ced7 in sqlite3Step (p=0x1226c408) at sqlite3.c:64828
Comment 142 caulier.gilles 2015-07-11 20:08:15 UTC
*** Bug 350130 has been marked as a duplicate of this bug. ***
Comment 143 caulier.gilles 2015-08-16 18:28:55 UTC
*** Bug 351374 has been marked as a duplicate of this bug. ***
Comment 144 caulier.gilles 2015-08-20 13:57:40 UTC
*** Bug 351521 has been marked as a duplicate of this bug. ***
Comment 145 caulier.gilles 2015-09-02 20:18:14 UTC
*** Bug 352174 has been marked as a duplicate of this bug. ***
Comment 146 caulier.gilles 2015-09-05 17:09:15 UTC
*** Bug 352313 has been marked as a duplicate of this bug. ***
Comment 147 caulier.gilles 2015-11-25 19:21:42 UTC
*** Bug 355903 has been marked as a duplicate of this bug. ***
Comment 148 caulier.gilles 2015-11-26 17:13:08 UTC
*** Bug 355950 has been marked as a duplicate of this bug. ***
Comment 149 caulier.gilles 2015-12-04 17:13:14 UTC
*** Bug 356282 has been marked as a duplicate of this bug. ***
Comment 150 caulier.gilles 2015-12-13 16:16:26 UTC
*** Bug 356598 has been marked as a duplicate of this bug. ***
Comment 151 caulier.gilles 2016-01-02 13:00:12 UTC
*** Bug 357421 has been marked as a duplicate of this bug. ***
Comment 152 caulier.gilles 2016-01-22 06:00:37 UTC
*** Bug 358337 has been marked as a duplicate of this bug. ***
Comment 153 caulier.gilles 2016-01-22 09:06:56 UTC
*** Bug 358356 has been marked as a duplicate of this bug. ***
Comment 154 caulier.gilles 2016-01-24 15:55:09 UTC
*** Bug 358488 has been marked as a duplicate of this bug. ***
Comment 155 caulier.gilles 2016-01-31 19:01:15 UTC
*** Bug 358829 has been marked as a duplicate of this bug. ***
Comment 156 caulier.gilles 2016-01-31 19:01:36 UTC
*** Bug 358832 has been marked as a duplicate of this bug. ***
Comment 157 caulier.gilles 2016-02-18 17:28:17 UTC
*** Bug 359540 has been marked as a duplicate of this bug. ***
Comment 158 caulier.gilles 2016-03-02 04:07:32 UTC
*** Bug 359977 has been marked as a duplicate of this bug. ***
Comment 159 caulier.gilles 2016-03-17 15:23:17 UTC
*** Bug 360665 has been marked as a duplicate of this bug. ***
Comment 160 caulier.gilles 2016-05-31 11:53:59 UTC
*** Bug 363736 has been marked as a duplicate of this bug. ***
Comment 161 caulier.gilles 2016-06-09 20:49:05 UTC
*** Bug 364153 has been marked as a duplicate of this bug. ***
Comment 162 caulier.gilles 2017-01-03 08:32:44 UTC
*** Bug 374472 has been marked as a duplicate of this bug. ***