Bug 331220 - digiKam eventually crashes at search initiation or selecting search on left sidebar.
Summary: digiKam eventually crashes at search initiation or selecting search on left s...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Sqlite (show other bugs)
Version: 3.5.0
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-16 23:30 UTC by BruceS
Modified: 2021-12-17 11:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BruceS 2014-02-16 23:30:57 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.11.3
Qt Version: 4.8.6
Operating System: Linux 3.12-1-amd64 x86_64
Distribution: Debian GNU/Linux testing (jessie)

-- Information about the crash:
- What I was doing when the application crashed:

After cycling between view album, and search a crash eventually occurs 
when clicking the search button on left sidebar or clicking on the 
search button below the search box.  I cannot predict when this crash 
will happen, but eventually it will happen without fail!

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa643e4ba80 (LWP 9420))]

Thread 7 (Thread 0x7fa6202c1700 (LWP 9421)):
#0  0x00007fa63d72395d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa6244ea6f8 in poll (__timeout=-1, __nfds=2, __fds=0x7fa6202c0b40) at /usr/include/x86_64-linux-gnu/bits/poll2.h:46
#2  linux_udev_event_thread_main (arg=<optimized out>) at ../../libusb/os/linux_udev.c:175
#3  0x00007fa638a6ce0e in start_thread (arg=0x7fa6202c1700) at pthread_create.c:311
#4  0x00007fa63d72f0fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 6 (Thread 0x7fa6198ef700 (LWP 9422)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fa63e4ff7d6 in wait (time=18446744073709551615, this=0x1a63b90) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a63a98, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005d5eee in ?? ()
#4  0x00007fa63e4ff2ef in QThreadPrivate::start (arg=0x1a63810) at thread/qthread_unix.cpp:349
#5  0x00007fa638a6ce0e in start_thread (arg=0x7fa6198ef700) at pthread_create.c:311
#6  0x00007fa63d72f0fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7fa6190ee700 (LWP 9423)):
#0  0x00007fa635e5cfda in g_mutex_get_impl (mutex=0x7fa60c0009a0) at /tmp/buildd/glib2.0-2.36.4/./glib/gthread-posix.c:121
#1  0x00007fa635e5d2b9 in g_mutex_unlock (mutex=mutex@entry=0x7fa60c0009a0) at /tmp/buildd/glib2.0-2.36.4/./glib/gthread-posix.c:229
#2  0x00007fa635e1daab in g_main_context_query (context=context@entry=0x7fa60c0009a0, max_priority=2147483647, timeout=timeout@entry=0x7fa6190ed97c, fds=fds@entry=0x7fa60c0029b0, n_fds=n_fds@entry=2) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3462
#3  0x00007fa635e1e102 in g_main_context_iterate (context=context@entry=0x7fa60c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3683
#4  0x00007fa635e1e29c in g_main_context_iteration (context=0x7fa60c0009a0, may_block=1) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3762
#5  0x00007fa63e62e636 in QEventDispatcherGlib::processEvents (this=0x7fa60c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007fa63e5fff9f in QEventLoop::processEvents (this=this@entry=0x7fa6190edab0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fa63e600295 in QEventLoop::exec (this=this@entry=0x7fa6190edab0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fa63e4fcc1f in QThread::exec (this=this@entry=0x1945390) at thread/qthread.cpp:537
#9  0x00007fa63e5e17d3 in QInotifyFileSystemWatcherEngine::run (this=0x1945390) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007fa63e4ff2ef in QThreadPrivate::start (arg=0x1945390) at thread/qthread_unix.cpp:349
#11 0x00007fa638a6ce0e in start_thread (arg=0x7fa6190ee700) at pthread_create.c:311
#12 0x00007fa63d72f0fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7fa6188ed700 (LWP 9427)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fa63e4ff7d6 in wait (time=18446744073709551615, this=0x1aae1c0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1bfefc8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fa6413ebdaa in ?? () from /usr/lib/digikam/libdigikamcore.so.3
#4  0x00007fa63e4ff2ef in QThreadPrivate::start (arg=0x1bfefb0) at thread/qthread_unix.cpp:349
#5  0x00007fa638a6ce0e in start_thread (arg=0x7fa6188ed700) at pthread_create.c:311
#6  0x00007fa63d72f0fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7fa5f77fe700 (LWP 10059)):
#0  0x00007fa63d72395d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa635e1e194 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7fa5e8046860, timeout=-1, context=0x7fa5e8045770) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3995
#2  g_main_context_iterate (context=context@entry=0x7fa5e8045770, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3696
#3  0x00007fa635e1e29c in g_main_context_iteration (context=0x7fa5e8045770, may_block=1) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3762
#4  0x00007fa63e62e636 in QEventDispatcherGlib::processEvents (this=0x7fa5e8039cb0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#5  0x00007fa63e5fff9f in QEventLoop::processEvents (this=this@entry=0x7fa5f77fda70, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa63e600295 in QEventLoop::exec (this=0x7fa5f77fda70, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fa6413eb453 in ?? () from /usr/lib/digikam/libdigikamcore.so.3
#8  0x00007fa63e4f2fae in QThreadPoolThread::run (this=0x2f16a80) at concurrent/qthreadpool.cpp:108
#9  0x00007fa63e4ff2ef in QThreadPrivate::start (arg=0x2f16a80) at thread/qthread_unix.cpp:349
#10 0x00007fa638a6ce0e in start_thread (arg=0x7fa5f77fe700) at pthread_create.c:311
#11 0x00007fa63d72f0fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fa5fcf1c700 (LWP 10061)):
#0  0x00007fa63d72395d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa635e1e194 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7fa5e0012d60, timeout=-1, context=0x7fa5e0025ca0) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3995
#2  g_main_context_iterate (context=context@entry=0x7fa5e0025ca0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3696
#3  0x00007fa635e1e29c in g_main_context_iteration (context=0x7fa5e0025ca0, may_block=1) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3762
#4  0x00007fa63e62e636 in QEventDispatcherGlib::processEvents (this=0x7fa5e0012ca0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#5  0x00007fa63e5fff9f in QEventLoop::processEvents (this=this@entry=0x7fa5fcf1ba70, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa63e600295 in QEventLoop::exec (this=0x7fa5fcf1ba70, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fa6413eb453 in ?? () from /usr/lib/digikam/libdigikamcore.so.3
#8  0x00007fa63e4f2fae in QThreadPoolThread::run (this=0x2f14cd0) at concurrent/qthreadpool.cpp:108
#9  0x00007fa63e4ff2ef in QThreadPrivate::start (arg=0x2f14cd0) at thread/qthread_unix.cpp:349
#10 0x00007fa638a6ce0e in start_thread (arg=0x7fa5fcf1c700) at pthread_create.c:311
#11 0x00007fa63d72f0fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fa643e4ba80 (LWP 9420)):
[KCrash Handler]
#6  0x0000000300000002 in ?? ()
#7  0x00007fa628a9a155 in sqlite3MemCompare (pMem1=pMem1@entry=0x7fffd9935b40, pMem2=0x55da5e8, pColl=0x7ab8da8) at sqlite3.c:60470
#8  0x00007fa628a9a233 in sqlite3VdbeRecordCompare (nKey1=24, pKey1=0x7fa6142200de, pPKey2=pPKey2@entry=0x7fffd9935e40) at sqlite3.c:64162
#9  0x00007fa628aae869 in sqlite3BtreeMovetoUnpacked (pCur=0x8889080, pIdxKey=0x7fffd9935e40, intKey=0, biasRight=<optimized out>, pRes=0x7fffd9935e30) at sqlite3.c:55077
#10 0x00007fa628ad6cd5 in sqlite3VdbeExec (p=p@entry=0x82ff848) at sqlite3.c:70168
#11 0x00007fa628adf1e7 in sqlite3Step (p=0x82ff848) at sqlite3.c:64828
#12 sqlite3_step (pStmt=<optimized out>) at sqlite3.c:64894
#13 0x00007fa60bdfb11c in QSQLiteResultPrivate::fetchNext (this=this@entry=0x5575e40, values=..., idx=idx@entry=0, initialFetch=initialFetch@entry=true) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:235
#14 0x00007fa60bdfbe48 in QSQLiteResult::exec (this=0x780d930) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:447
#15 0x00007fa643a74b7d in QSqlQuery::exec (this=0x7fffd9936378) at kernel/qsqlquery.cpp:949
#16 0x00007fa6413a5036 in Digikam::DatabaseCoreBackend::exec(Digikam::SqlQuery&) () from /usr/lib/digikam/libdigikamcore.so.3
#17 0x00007fa6413a50bc in Digikam::DatabaseCoreBackend::execQuery(Digikam::SqlQuery&, QVariant const&) () from /usr/lib/digikam/libdigikamcore.so.3
#18 0x00007fa6413a6160 in Digikam::DatabaseCoreBackend::execQuery(QString const&, QVariant const&) () from /usr/lib/digikam/libdigikamcore.so.3
#19 0x00007fa6413a61a9 in Digikam::DatabaseCoreBackend::execSql(QString const&, QVariant const&, QList<QVariant>*, QVariant*) () from /usr/lib/digikam/libdigikamcore.so.3
#20 0x00007fa640d3fede in Digikam::AlbumDB::getSetting(QString const&) () from /usr/lib/digikam/libdigikamdatabase.so.3
#21 0x00007fa640d4080c in Digikam::AlbumDB::getFilterSettings(QStringList*, QStringList*, QStringList*) () from /usr/lib/digikam/libdigikamdatabase.so.3
#22 0x000000000063a2d0 in ?? ()
#23 0x0000000000533f52 in ?? ()
#24 0x0000000000533a04 in ?? ()
#25 0x00007fa581dead94 in ?? () from /usr/lib/kde4/kipiplugin_advancedslideshow.so
#26 0x00007fa63e615658 in QMetaObject::activate (sender=0x251e0b0, m=m@entry=0x7fa641fc9e60 <KIPI::Interface::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fffd9936950) at kernel/qobject.cpp:3539
#27 0x00007fa641db5f62 in KIPI::Interface::currentAlbumChanged (this=<optimized out>, _t1=true) at ./interface.moc:128
#28 0x00007fa63e615658 in QMetaObject::activate (sender=0x1a29330, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd9936ae0) at kernel/qobject.cpp:3539
#29 0x00000000005a43f3 in ?? ()
#30 0x0000000000556868 in ?? ()
#31 0x0000000000558aa5 in ?? ()
#32 0x0000000000559235 in ?? ()
#33 0x00007fa63e615658 in QMetaObject::activate (sender=0x2410d60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#34 0x00007fa63e619811 in QObject::event (this=0x2410d60, e=<optimized out>) at kernel/qobject.cpp:1156
#35 0x00007fa63f0066cc in QApplicationPrivate::notify_helper (this=this@entry=0x1898920, receiver=receiver@entry=0x2410d60, e=e@entry=0x7fffd99370a0) at kernel/qapplication.cpp:4567
#36 0x00007fa63f00cd40 in QApplication::notify (this=this@entry=0x7fffd9937840, receiver=receiver@entry=0x2410d60, e=e@entry=0x7fffd99370a0) at kernel/qapplication.cpp:4353
#37 0x00007fa63fd2849a in KApplication::notify (this=0x7fffd9937840, receiver=0x2410d60, event=0x7fffd99370a0) at ../../kdeui/kernel/kapplication.cpp:311
#38 0x00007fa63e6013cd in QCoreApplication::notifyInternal (this=0x7fffd9937840, receiver=0x2410d60, event=0x7fffd99370a0) at kernel/qcoreapplication.cpp:953
#39 0x00007fa63e6310e3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#40 QTimerInfoList::activateTimers (this=0x1894930) at kernel/qeventdispatcher_unix.cpp:621
#41 0x00007fa63e62e419 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#42 idleTimerSourceDispatch (source=source@entry=0x1894980) at kernel/qeventdispatcher_glib.cpp:233
#43 0x00007fa635e1dea6 in g_main_dispatch (context=0x189ca30) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3054
#44 g_main_context_dispatch (context=context@entry=0x189ca30) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3630
#45 0x00007fa635e1e1f8 in g_main_context_iterate (context=context@entry=0x189ca30, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3701
#46 0x00007fa635e1e29c in g_main_context_iteration (context=0x189ca30, may_block=1) at /tmp/buildd/glib2.0-2.36.4/./glib/gmain.c:3762
#47 0x00007fa63e62e615 in QEventDispatcherGlib::processEvents (this=0x17f5da0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#48 0x00007fa63f0a4776 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007fa63e5fff9f in QEventLoop::processEvents (this=this@entry=0x7fffd9937320, flags=...) at kernel/qeventloop.cpp:149
#50 0x00007fa63e600295 in QEventLoop::exec (this=this@entry=0x7fffd9937320, flags=...) at kernel/qeventloop.cpp:204
#51 0x00007fa63e605a69 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#52 0x0000000000492033 in ?? ()
#53 0x00007fa63d667995 in __libc_start_main (main=0x490de0, argc=5, ubp_av=0x7fffd9937a38, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffd9937a28) at libc-start.c:276
#54 0x000000000049462f in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 329697.

Possible duplicates by query: bug 330674, bug 330633, bug 330302, bug 330155, bug 330104.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-02-17 02:58:58 UTC

*** This bug has been marked as a duplicate of bug 329697 ***
Comment 2 caulier.gilles 2021-12-17 11:50:49 UTC
Fixed with #329697