Bug 332100 - Crash while browsing album.
Summary: Crash while browsing album.
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Database-Sqlite (show other bugs)
Version: 3.5.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-03-13 15:08 UTC by Malcolm Beckett
Modified: 2021-12-17 11:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Malcolm Beckett 2014-03-13 15:08:34 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.12.2
Qt Version: 4.8.5
Operating System: Linux 3.12.8-300.fc20.x86_64 x86_64
Distribution: "Fedora release 20 (Heisenbug)"

-- Information about the crash:
- What I was doing when the application crashed:Browsing albums, selecting images.  This has also occurred while tagging, searching tags or any task involving several operations.

The crash can be reproduced sometimes.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f39ba243ac0 (LWP 6376))]

Thread 4 (Thread 0x7f39aa606700 (LWP 6394)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00000038f1c7c8d6 in wait (time=18446744073709551615, this=0x2470d60) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x2470c70, mutex=mutex@entry=0x2470c68, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005e24ce in Digikam::ScanController::run (this=0x2470a00) at /usr/src/debug/digikam-3.5.0/core/digikam/database/scancontroller.cpp:725
#4  0x00000038f1c7c3af in QThreadPrivate::start (arg=0x2470a00) at thread/qthread_unix.cpp:338
#5  0x00000038dfc07f33 in start_thread (arg=0x7f39aa606700) at pthread_create.c:309
#6  0x00000038df4f4ded in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f39a9e05700 (LWP 6395)):
#0  0x00000038df4ea9dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00000038e1c495b4 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f399c0028c0, timeout=-1, context=0x7f399c0009a0) at gmain.c:4007
#2  g_main_context_iterate (context=context@entry=0x7f399c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3708
#3  0x00000038e1c496dc in g_main_context_iteration (context=0x7f399c0009a0, may_block=1) at gmain.c:3774
#4  0x00000038f1db2ec6 in QEventDispatcherGlib::processEvents (this=0x7f399c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#5  0x00000038f1d82edf in QEventLoop::processEvents (this=this@entry=0x7f39a9e04ac0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00000038f1d8322d in QEventLoop::exec (this=this@entry=0x7f39a9e04ac0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00000038f1c79baf in QThread::exec (this=this@entry=0x2451b40) at thread/qthread.cpp:536
#8  0x00000038f1d63863 in QInotifyFileSystemWatcherEngine::run (this=0x2451b40) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00000038f1c7c3af in QThreadPrivate::start (arg=0x2451b40) at thread/qthread_unix.cpp:338
#10 0x00000038dfc07f33 in start_thread (arg=0x7f39a9e05700) at pthread_create.c:309
#11 0x00000038df4f4ded in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f39a9604700 (LWP 6409)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00000038f1c7c8d6 in wait (time=18446744073709551615, this=0x2914bf0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x2914960, mutex=mutex@entry=0x2914958, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003e83d6274a in Digikam::ParkingThread::run (this=0x2914940) at /usr/src/debug/digikam-3.5.0/core/libs/threads/threadmanager.cpp:119
#4  0x00000038f1c7c3af in QThreadPrivate::start (arg=0x2914940) at thread/qthread_unix.cpp:338
#5  0x00000038dfc07f33 in start_thread (arg=0x7f39a9604700) at pthread_create.c:309
#6  0x00000038df4f4ded in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f39ba243ac0 (LWP 6376)):
[KCrash Handler]
#5  0x000000540000007e in ?? ()
#6  0x00000038f6c31edc in sqlite3MemCompare () from /lib64/libsqlite3.so.0
#7  0x00000038f6c320a3 in sqlite3VdbeRecordCompare () from /lib64/libsqlite3.so.0
#8  0x00000038f6c46d59 in sqlite3BtreeMovetoUnpacked () from /lib64/libsqlite3.so.0
#9  0x00000038f6c6fa05 in sqlite3VdbeExec () from /lib64/libsqlite3.so.0
#10 0x00000038f6c77f37 in sqlite3_step () from /lib64/libsqlite3.so.0
#11 0x00007f39a8bfe45c in QSQLiteResultPrivate::fetchNext (this=this@entry=0x56562a0, values=..., idx=idx@entry=0, initialFetch=initialFetch@entry=true) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:235
#12 0x00007f39a8bff1b8 in QSQLiteResult::exec (this=0x48ed2c0) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:447
#13 0x0000003901c10c5d in QSqlQuery::exec (this=this@entry=0x7fff98d13488) at kernel/qsqlquery.cpp:949
#14 0x0000003e83d19276 in Digikam::DatabaseCoreBackend::exec (this=0x241ee20, query=...) at /usr/src/debug/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1414
#15 0x0000003e83d1930c in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x241ee20, query=..., boundValue1=...) at /usr/src/debug/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1056
#16 0x0000003e83d1a500 in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x241ee20, sql=..., boundValue1=...) at /usr/src/debug/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1005
#17 0x0000003e83d1a557 in Digikam::DatabaseCoreBackend::execSql (this=0x241ee20, sql=..., boundValue1=..., values=values@entry=0x7fff98d134d0, lastInsertId=lastInsertId@entry=0x0) at /usr/src/debug/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:902
#18 0x0000003e84265dfe in Digikam::AlbumDB::getSetting (this=this@entry=0x241ef40, keyword=...) at /usr/src/debug/digikam-3.5.0/core/libs/database/albumdb.cpp:972
#19 0x0000003e842667bf in Digikam::AlbumDB::getFilterSettings (this=0x241ef40, imageFilter=imageFilter@entry=0x7fff98d13710, videoFilter=videoFilter@entry=0x0, audioFilter=audioFilter@entry=0x0) at /usr/src/debug/digikam-3.5.0/core/libs/database/albumdb.cpp:1017
#20 0x000000000064be46 in Digikam::AlbumSettings::getImageFileFilter (this=<optimized out>) at /usr/src/debug/digikam-3.5.0/core/digikam/utils/albumsettings.cpp:915
#21 0x0000000000622540 in Digikam::ImageViewUtilities::openInEditor (this=0x29844e0, info=..., allInfosToOpen=..., currentAlbum=currentAlbum@entry=0x42b0aa0) at /usr/src/debug/digikam-3.5.0/core/digikam/items/imageviewutilities.cpp:267
#22 0x00000000006104d7 in Digikam::DigikamImageView::openInEditor (this=this@entry=0x2919990, info=...) at /usr/src/debug/digikam-3.5.0/core/digikam/items/digikamimageview.cpp:491
#23 0x000000000061056c in Digikam::DigikamImageView::activated (this=0x2919990, info=...) at /usr/src/debug/digikam-3.5.0/core/digikam/items/digikamimageview.cpp:315
#24 0x00000000006168f6 in Digikam::ImageCategorizedView::indexActivated (this=0x2919990, index=...) at /usr/src/debug/digikam-3.5.0/core/digikam/items/imagecategorizedview.cpp:630
#25 0x0000003e83dac740 in Digikam::DCategorizedView::slotActivated (this=0x2919990, index=...) at /usr/src/debug/digikam-3.5.0/core/libs/widgets/itemview/dcategorizedview.cpp:401
#26 0x00000038f1d98cf8 in QMetaObject::activate (sender=sender@entry=0x2919990, m=m@entry=0x38f3ab9320 <QAbstractItemView::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff98d13b20) at kernel/qobject.cpp:3547
#27 0x00000038f34e5795 in QAbstractItemView::activated (this=this@entry=0x2919990, _t1=...) at .moc/release-shared/moc_qabstractitemview.cpp:361
#28 0x00000038f34e8648 in QAbstractItemView::keyPressEvent (this=this@entry=0x2919990, event=event@entry=0x7fff98d141a0) at itemviews/qabstractitemview.cpp:2376
#29 0x0000003e83daea8b in Digikam::DCategorizedView::keyPressEvent (this=0x2919990, event=0x7fff98d141a0) at /usr/src/debug/digikam-3.5.0/core/libs/widgets/itemview/dcategorizedview.cpp:904
#30 0x00000038f301cb55 in QWidget::event (this=this@entry=0x2919990, event=event@entry=0x7fff98d141a0) at kernel/qwidget.cpp:8422
#31 0x00000038f33d315e in QFrame::event (this=this@entry=0x2919990, e=e@entry=0x7fff98d141a0) at widgets/qframe.cpp:557
#32 0x00000038f3456423 in QAbstractScrollArea::event (this=this@entry=0x2919990, e=e@entry=0x7fff98d141a0) at widgets/qabstractscrollarea.cpp:996
#33 0x00000038f34eee4b in QAbstractItemView::event (this=0x2919990, event=0x7fff98d141a0) at itemviews/qabstractitemview.cpp:1580
#34 0x00000038f2fc9d8c in QApplicationPrivate::notify_helper (this=0x216f9c0, receiver=0x2919990, e=0x7fff98d141a0) at kernel/qapplication.cpp:4562
#35 0x00000038f2fd1996 in QApplication::notify (this=<optimized out>, receiver=0x2919990, e=0x7fff98d141a0) at kernel/qapplication.cpp:4003
#36 0x0000003e7ce4aa1a in KApplication::notify(QObject*, QEvent*) () from /lib64/libkdeui.so.5
#37 0x00000038f1d8439d in QCoreApplication::notifyInternal (this=0x7fff98d15040, receiver=receiver@entry=0x2919990, event=event@entry=0x7fff98d141a0) at kernel/qcoreapplication.cpp:949
#38 0x00000038f2fc8606 in sendSpontaneousEvent (event=event@entry=0x7fff98d141a0, receiver=receiver@entry=0x2919990) at ../../src/corelib/kernel/qcoreapplication.h:234
#39 qt_sendSpontaneousEvent (receiver=receiver@entry=0x2919990, event=event@entry=0x7fff98d141a0) at kernel/qapplication.cpp:5560
#40 0x00000038f3068faa in QKeyMapper::sendKeyEvent (keyWidget=keyWidget@entry=0x2919990, grab=grab@entry=false, type=QEvent::KeyPress, code=16777220, modifiers=..., text=..., autorepeat=autorepeat@entry=false, count=1, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1866
#41 0x00000038f3069369 in QKeyMapperPrivate::translateKeyEvent (this=0x21d5720, keyWidget=keyWidget@entry=0x2919990, event=event@entry=0x7fff98d14720, grab=grab@entry=false) at kernel/qkeymapper_x11.cpp:1836
#42 0x00000038f304446f in QApplication::x11ProcessEvent (this=0x7fff98d15040, event=event@entry=0x7fff98d14720) at kernel/qapplication_x11.cpp:3554
#43 0x00000038f306bb24 in x11EventSourceDispatch (s=s@entry=0x2171aa0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#44 0x00000038e1c492a6 in g_main_dispatch (context=0x20db820) at gmain.c:3066
#45 g_main_context_dispatch (context=context@entry=0x20db820) at gmain.c:3642
#46 0x00000038e1c49628 in g_main_context_iterate (context=context@entry=0x20db820, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
#47 0x00000038e1c496dc in g_main_context_iteration (context=0x20db820, may_block=1) at gmain.c:3774
#48 0x00000038f1db2ea5 in QEventDispatcherGlib::processEvents (this=0x216d8a0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#49 0x00000038f306bca6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#50 0x00000038f1d82edf in QEventLoop::processEvents (this=this@entry=0x7fff98d14b10, flags=...) at kernel/qeventloop.cpp:149
#51 0x00000038f1d8322d in QEventLoop::exec (this=this@entry=0x7fff98d14b10, flags=...) at kernel/qeventloop.cpp:204
#52 0x00000038f1d88749 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#53 0x00000038f2fc83fc in QApplication::exec () at kernel/qapplication.cpp:3823
#54 0x000000000049232d in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/digikam-3.5.0/core/digikam/main/main.cpp:235

Possible duplicates by query: bug 331220, bug 330674, bug 330633, bug 330302, bug 330155.

Reported using DrKonqi
Comment 1 caulier.gilles 2014-03-13 16:05:58 UTC

*** This bug has been marked as a duplicate of bug 329697 ***
Comment 2 caulier.gilles 2021-12-17 11:51:01 UTC
Fixed with #329697