Bug 334042 - digikam crashed suddenly
Summary: digikam crashed suddenly
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Sqlite (show other bugs)
Version: 3.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-04-28 21:46 UTC by Paulo J. Matos
Modified: 2021-12-17 11:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paulo J. Matos 2014-04-28 21:46:12 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.13.0
Qt Version: 4.8.6
Operating System: Linux 3.13.0-24-generic x86_64
Distribution: Ubuntu 14.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Simply added a local folder with about 20 photos to my 25000 photo gallery;

- Unusual behavior I noticed:
At the time baloo was destroying my disk trying to index my home folder.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc787da4ac0 (LWP 24029))]

Thread 7 (Thread 0x7fc763475700 (LWP 24104)):
#0  0x00007fc7817c5fbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc768020248 in ?? () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#2  0x00007fc77ca55182 in start_thread (arg=0x7fc763475700) at pthread_create.c:312
#3  0x00007fc7817d330d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 6 (Thread 0x7fc75ca82700 (LWP 24111)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fc7825b4816 in wait (time=18446744073709551615, this=0x1c64e20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x1c64d30, mutex=mutex@entry=0x1c64d28, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005d5ede in Digikam::ScanController::run (this=0x1c64aa0) at /build/buildd/digikam-3.5.0/core/digikam/database/scancontroller.cpp:725
#4  0x00007fc7825b432f in QThreadPrivate::start (arg=0x1c64aa0) at thread/qthread_unix.cpp:349
#5  0x00007fc77ca55182 in start_thread (arg=0x7fc75ca82700) at pthread_create.c:312
#6  0x00007fc7817d330d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7fc757fff700 (LWP 24112)):
#0  0x00007fc77ca587ee in __pthread_mutex_unlock_usercnt (decr=1, mutex=0x7fc750000a60) at pthread_mutex_unlock.c:57
#1  __GI___pthread_mutex_unlock (mutex=0x7fc750000a60) at pthread_mutex_unlock.c:310
#2  0x00007fc77a2be9c1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc77a27ce9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc77a27d0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc7826e37be in QEventDispatcherGlib::processEvents (this=0x7fc7500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007fc7826b50af in QEventLoop::processEvents (this=this@entry=0x7fc757ffeae0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fc7826b53a5 in QEventLoop::exec (this=this@entry=0x7fc757ffeae0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fc7825b1c5f in QThread::exec (this=this@entry=0x1b44820) at thread/qthread.cpp:537
#9  0x00007fc782696823 in QInotifyFileSystemWatcherEngine::run (this=0x1b44820) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fc7825b432f in QThreadPrivate::start (arg=0x1b44820) at thread/qthread_unix.cpp:349
#11 0x00007fc77ca55182 in start_thread (arg=0x7fc757fff700) at pthread_create.c:312
#12 0x00007fc7817d330d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7fc7577fe700 (LWP 24166)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fc7825b4816 in wait (time=18446744073709551615, this=0x1d5f9d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x1c87e80, mutex=mutex@entry=0x1c87e78, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fc78542d79a in Digikam::ParkingThread::run (this=0x1c87e60) at /build/buildd/digikam-3.5.0/core/libs/threads/threadmanager.cpp:119
#4  0x00007fc7825b432f in QThreadPrivate::start (arg=0x1c87e60) at thread/qthread_unix.cpp:349
#5  0x00007fc77ca55182 in start_thread (arg=0x7fc7577fe700) at pthread_create.c:312
#6  0x00007fc7817d330d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7fc75615d700 (LWP 24179)):
#0  0x00007fc7817c46bd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc77a2bdc20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc77a27cb14 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc77a27cf7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc77a27d0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc7826e37be in QEventDispatcherGlib::processEvents (this=0x7fc74c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007fc7826b50af in QEventLoop::processEvents (this=this@entry=0x7fc75615cae0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fc7826b53a5 in QEventLoop::exec (this=this@entry=0x7fc75615cae0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fc7825b1c5f in QThread::exec (this=this@entry=0x2239d10) at thread/qthread.cpp:537
#9  0x00007fc782696823 in QInotifyFileSystemWatcherEngine::run (this=0x2239d10) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fc7825b432f in QThreadPrivate::start (arg=0x2239d10) at thread/qthread_unix.cpp:349
#11 0x00007fc77ca55182 in start_thread (arg=0x7fc75615d700) at pthread_create.c:312
#12 0x00007fc7817d330d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fc6c7fff700 (LWP 25677)):
#0  0x00007fc77a2be62a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fc77a2be9b9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc77a27c680 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc77a27cf03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc77a27d0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc7826e37be in QEventDispatcherGlib::processEvents (this=0x7fc6d021a290, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007fc7826b50af in QEventLoop::processEvents (this=this@entry=0x7fc6c7ffeaa0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fc7826b53a5 in QEventLoop::exec (this=this@entry=0x7fc6c7ffeaa0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fc78542ce43 in Digikam::WorkerObjectRunnable::run (this=0x5c9edc0) at /build/buildd/digikam-3.5.0/core/libs/threads/threadmanager.cpp:196
#9  0x00007fc7825a7fee in QThreadPoolThread::run (this=0x3614af0) at concurrent/qthreadpool.cpp:108
#10 0x00007fc7825b432f in QThreadPrivate::start (arg=0x3614af0) at thread/qthread_unix.cpp:349
#11 0x00007fc77ca55182 in start_thread (arg=0x7fc6c7fff700) at pthread_create.c:312
#12 0x00007fc7817d330d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fc787da4ac0 (LWP 24029)):
[KCrash Handler]
#6  0x0000000002d42770 in ?? ()
#7  0x00007fc76c321dac in sqlite3MemCompare (pMem1=pMem1@entry=0x7fff8be85b00, pMem2=<optimized out>, pColl=0x5d7ad78) at sqlite3.c:60484
#8  0x00007fc76c321f63 in sqlite3VdbeRecordCompare (nKey1=18, pKey1=0x7fc75834fabf, pPKey2=pPKey2@entry=0x7fff8be85e00) at sqlite3.c:64162
#9  0x00007fc76c336579 in sqlite3BtreeMovetoUnpacked (pCur=0x5b2cec0, pIdxKey=0x7fff8be85e00, intKey=0, biasRight=<optimized out>, pRes=0x7fff8be85df0) at sqlite3.c:55077
#10 0x00007fc76c35e9c5 in sqlite3VdbeExec (p=p@entry=0x58615f8) at sqlite3.c:70168
#11 0x00007fc76c366ed7 in sqlite3Step (p=0x58615f8) at sqlite3.c:64828
#12 sqlite3_step (pStmt=<optimized out>) at sqlite3.c:64894
#13 0x00007fc75c07d11c in QSQLiteResultPrivate::fetchNext (this=this@entry=0x5981920, values=..., idx=idx@entry=0, initialFetch=initialFetch@entry=true) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:235
#14 0x00007fc75c07de48 in QSQLiteResult::exec (this=0x4194070) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:447
#15 0x00007fc7879d9b7d in QSqlQuery::exec (this=this@entry=0x7fff8be86338) at kernel/qsqlquery.cpp:949
#16 0x00007fc7853e6a26 in Digikam::DatabaseCoreBackend::exec (this=0x1c0c040, query=...) at /build/buildd/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1414
#17 0x00007fc7853e6aac in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x1c0c040, query=..., boundValue1=...) at /build/buildd/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1056
#18 0x00007fc7853e7b50 in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x1c0c040, sql=..., boundValue1=...) at /build/buildd/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1005
#19 0x00007fc7853e7b99 in Digikam::DatabaseCoreBackend::execSql (this=0x1c0c040, sql=..., boundValue1=..., values=values@entry=0x7fff8be86380, lastInsertId=lastInsertId@entry=0x0) at /build/buildd/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:902
#20 0x00007fc784dab42e in Digikam::AlbumDB::getSetting (this=this@entry=0x1b5de80, keyword=...) at /build/buildd/digikam-3.5.0/core/libs/database/albumdb.cpp:972
#21 0x00007fc784dabd5c in Digikam::AlbumDB::getFilterSettings (this=0x1b5de80, imageFilter=imageFilter@entry=0x7fff8be865c0, videoFilter=videoFilter@entry=0x0, audioFilter=audioFilter@entry=0x0) at /build/buildd/digikam-3.5.0/core/libs/database/albumdb.cpp:1017
#22 0x000000000063a2c0 in Digikam::AlbumSettings::getRawFileFilter (this=this@entry=0x1d393c0) at /build/buildd/digikam-3.5.0/core/digikam/utils/albumsettings.cpp:958
#23 0x0000000000533f42 in Digikam::KipiInterface::hostSetting (this=this@entry=0x3297ea0, settingName=...) at /build/buildd/digikam-3.5.0/core/utilities/kipiiface/kipiinterface.cpp:363
#24 0x00000000005339f4 in Digikam::KipiInterface::currentAlbum (this=0x3297ea0) at /build/buildd/digikam-3.5.0/core/utilities/kipiiface/kipiinterface.cpp:110
#25 0x00007fc6ec172d94 in KIPIAdvancedSlideshowPlugin::Plugin_AdvancedSlideshow::slotAlbumChanged (this=0x2664000, anyAlbum=<optimized out>) at /build/buildd/digikam-3.5.0/extra/kipi-plugins/advancedslideshow/plugin/plugin_advancedslideshow.cpp:175
#26 0x00007fc7826ca87a in QMetaObject::activate (sender=0x3297ea0, m=m@entry=0x7fc785f3de60 <KIPI::Interface::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff8be86910) at kernel/qobject.cpp:3539
#27 0x00007fc785d2a4c2 in KIPI::Interface::currentAlbumChanged (this=<optimized out>, _t1=true) at ./interface.moc:128
#28 0x00007fc7826ca87a in QMetaObject::activate (sender=0x1bb62b0, m=m@entry=0x844e60 <Digikam::AlbumManager::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7fff8be86a40) at kernel/qobject.cpp:3539
#29 0x00000000005a2e04 in signalAlbumCurrentChanged (_t1=0x4032e90, this=<optimized out>) at /build/buildd/digikam-3.5.0/obj-x86_64-linux-gnu/core/digikam/albummanager.moc:267
#30 Digikam::AlbumManager::setCurrentAlbum (this=<optimized out>, album=album@entry=0x4032e90) at /build/buildd/digikam-3.5.0/core/digikam/album/albummanager.cpp:1846
#31 0x00000000005c81cd in Digikam::AbstractAlbumTreeView::mousePressEvent (this=0x2ace0e0, e=0x7fff8be872b0) at /build/buildd/digikam-3.5.0/core/digikam/album/albumtreeview.cpp:538
#32 0x00007fc7830f837b in QWidget::event (this=this@entry=0x2ace0e0, event=event@entry=0x7fff8be872b0) at kernel/qwidget.cpp:8372
#33 0x00007fc783499fce in QFrame::event (this=0x2ace0e0, e=0x7fff8be872b0) at widgets/qframe.cpp:557
#34 0x00007fc7835a95b3 in QAbstractItemView::viewportEvent (this=this@entry=0x2ace0e0, event=event@entry=0x7fff8be872b0) at itemviews/qabstractitemview.cpp:1644
#35 0x00007fc7835e8190 in QTreeView::viewportEvent (this=this@entry=0x2ace0e0, event=0x7fff8be872b0) at itemviews/qtreeview.cpp:1252
#36 0x00000000005c83d5 in Digikam::AbstractAlbumTreeView::viewportEvent (this=this@entry=0x2ace0e0, event=<optimized out>) at /build/buildd/digikam-3.5.0/core/digikam/album/albumtreeview.cpp:683
#37 0x00000000005c05c0 in Digikam::AlbumSelectionTreeView::viewportEvent (this=0x2ace0e0, event=<optimized out>) at /build/buildd/digikam-3.5.0/core/digikam/album/albumselectiontreeview.cpp:233
#38 0x00007fc7826b6646 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=this@entry=0x1a66ba0, receiver=receiver@entry=0x2acc1c0, event=event@entry=0x7fff8be872b0) at kernel/qcoreapplication.cpp:1063
#39 0x00007fc7830a8e0c in QApplicationPrivate::notify_helper (this=this@entry=0x1a66ba0, receiver=receiver@entry=0x2acc1c0, e=e@entry=0x7fff8be872b0) at kernel/qapplication.cpp:4563
#40 0x00007fc7830af5dd in QApplication::notify (this=this@entry=0x7fff8be87f20, receiver=receiver@entry=0x2acc1c0, e=e@entry=0x7fff8be872b0) at kernel/qapplication.cpp:4110
#41 0x00007fc783db3baa in KApplication::notify (this=0x7fff8be87f20, receiver=0x2acc1c0, event=0x7fff8be872b0) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x00007fc7826b64dd in QCoreApplication::notifyInternal (this=0x7fff8be87f20, receiver=receiver@entry=0x2acc1c0, event=event@entry=0x7fff8be872b0) at kernel/qcoreapplication.cpp:953
#43 0x00007fc7830aed93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#44 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x2acc1c0, event=event@entry=0x7fff8be872b0, alienWidget=alienWidget@entry=0x2acc1c0, nativeWidget=nativeWidget@entry=0x1d006b0, buttonDown=buttonDown@entry=0x7fc783b8e318 <qt_button_down>, lastMouseReceiver=..., spontaneous=spontaneous@entry=true) at kernel/qapplication.cpp:3178
#45 0x00007fc7831239cb in QETWidget::translateMouseEvent (this=this@entry=0x1d006b0, event=event@entry=0x7fff8be87630) at kernel/qapplication_x11.cpp:4634
#46 0x00007fc783123269 in QApplication::x11ProcessEvent (this=0x7fff8be87f20, event=event@entry=0x7fff8be87630) at kernel/qapplication_x11.cpp:3627
#47 0x00007fc78314ab02 in x11EventSourceDispatch (s=0x1a59a10, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x00007fc77a27ce04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007fc77a27d048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#50 0x00007fc77a27d0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#51 0x00007fc7826e37a1 in QEventDispatcherGlib::processEvents (this=0x19940d0, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#52 0x00007fc78314abb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x00007fc7826b50af in QEventLoop::processEvents (this=this@entry=0x7fff8be87a00, flags=...) at kernel/qeventloop.cpp:149
#54 0x00007fc7826b53a5 in QEventLoop::exec (this=this@entry=0x7fff8be87a00, flags=...) at kernel/qeventloop.cpp:204
#55 0x00007fc7826bab79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#56 0x00007fc7830a737c in QApplication::exec () at kernel/qapplication.cpp:3828
#57 0x0000000000492023 in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/digikam-3.5.0/core/digikam/main/main.cpp:235

Possible duplicates by query: bug 334017, bug 333976, bug 333953, bug 333952, bug 333792.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-04-29 02:17:44 UTC

*** This bug has been marked as a duplicate of bug 329697 ***
Comment 2 caulier.gilles 2021-12-17 11:50:50 UTC
Fixed with #329697