Bug 333660 - Crashed when clicking Image editor
Summary: Crashed when clicking Image editor
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Sqlite (show other bugs)
Version: 3.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-04-20 18:46 UTC by Ken Jarvis
Modified: 2021-12-17 11:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Jarvis 2014-04-20 18:46:50 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.13.0
Qt Version: 4.8.6
Operating System: Linux 3.13.0-24-generic x86_64
Distribution: Ubuntu 14.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I was searching through directories of pictures. Found one I wanted to work with and clicked "Image Editor". Then the Program disappeared and crash report came up.

The crash can be reproduced sometimes.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4146b54ac0 (LWP 8948))]

Thread 7 (Thread 0x7f4122221700 (LWP 8949)):
#0  0x00007f4140571fbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f4126dcc248 in ?? () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#2  0x00007f413b801182 in start_thread (arg=0x7f4122221700) at pthread_create.c:312
#3  0x00007f414057f30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 6 (Thread 0x7f411b930700 (LWP 8950)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f4141360816 in wait (time=18446744073709551615, this=0x2b59790) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x2b5f400, mutex=mutex@entry=0x2b5f3f8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005d5ede in Digikam::ScanController::run (this=0x2b47180) at /build/buildd/digikam-3.5.0/core/digikam/database/scancontroller.cpp:725
#4  0x00007f414136032f in QThreadPrivate::start (arg=0x2b47180) at thread/qthread_unix.cpp:349
#5  0x00007f413b801182 in start_thread (arg=0x7f411b930700) at pthread_create.c:312
#6  0x00007f414057f30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7f411b12f700 (LWP 8951)):
#0  0x00007f413906a62a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f413906a989 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4139028fca in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f41390290ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f414148f7be in QEventDispatcherGlib::processEvents (this=0x7f410c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007f41414610af in QEventLoop::processEvents (this=this@entry=0x7f411b12eae0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f41414613a5 in QEventLoop::exec (this=this@entry=0x7f411b12eae0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f414135dc5f in QThread::exec (this=this@entry=0x2b3b2c0) at thread/qthread.cpp:537
#8  0x00007f4141442823 in QInotifyFileSystemWatcherEngine::run (this=0x2b3b2c0) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f414136032f in QThreadPrivate::start (arg=0x2b3b2c0) at thread/qthread_unix.cpp:349
#10 0x00007f413b801182 in start_thread (arg=0x7f411b12f700) at pthread_create.c:312
#11 0x00007f414057f30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7f411a92e700 (LWP 8958)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f4141360816 in wait (time=18446744073709551615, this=0x2be9eb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x2ab48f0, mutex=mutex@entry=0x2ab48e8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f41441d979a in Digikam::ParkingThread::run (this=0x2ab48d0) at /build/buildd/digikam-3.5.0/core/libs/threads/threadmanager.cpp:119
#4  0x00007f414136032f in QThreadPrivate::start (arg=0x2ab48d0) at thread/qthread_unix.cpp:349
#5  0x00007f413b801182 in start_thread (arg=0x7f411a92e700) at pthread_create.c:312
#6  0x00007f414057f30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f4119084700 (LWP 8963)):
#0  0x00007f4140571fbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f4139028fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f41390290ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f414148f7be in QEventDispatcherGlib::processEvents (this=0x7f41040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f41414610af in QEventLoop::processEvents (this=this@entry=0x7f4119083ae0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f41414613a5 in QEventLoop::exec (this=this@entry=0x7f4119083ae0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f414135dc5f in QThread::exec (this=this@entry=0x31f3350) at thread/qthread.cpp:537
#7  0x00007f4141442823 in QInotifyFileSystemWatcherEngine::run (this=0x31f3350) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f414136032f in QThreadPrivate::start (arg=0x31f3350) at thread/qthread_unix.cpp:349
#9  0x00007f413b801182 in start_thread (arg=0x7f4119084700) at pthread_create.c:312
#10 0x00007f414057f30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f40f27fc700 (LWP 10685)):
#0  0x00007f4140571fbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f4139028fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f41390290ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f414148f7be in QEventDispatcherGlib::processEvents (this=0x7f40d8036a80, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f41414610af in QEventLoop::processEvents (this=this@entry=0x7f40f27fbaa0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f41414613a5 in QEventLoop::exec (this=this@entry=0x7f40f27fbaa0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f41441d8e43 in Digikam::WorkerObjectRunnable::run (this=0x2a47070) at /build/buildd/digikam-3.5.0/core/libs/threads/threadmanager.cpp:196
#7  0x00007f4141353fee in QThreadPoolThread::run (this=0x4236110) at concurrent/qthreadpool.cpp:108
#8  0x00007f414136032f in QThreadPrivate::start (arg=0x4236110) at thread/qthread_unix.cpp:349
#9  0x00007f413b801182 in start_thread (arg=0x7f40f27fc700) at pthread_create.c:312
#10 0x00007f414057f30d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f4146b54ac0 (LWP 8948)):
[KCrash Handler]
#6  0x0000000005ccf9d0 in ?? ()
#7  0x00007f412b0cddac in sqlite3MemCompare (pMem1=pMem1@entry=0x7fffd65e1a10, pMem2=<optimized out>, pColl=0x699c348) at sqlite3.c:60484
#8  0x00007f412b0cdf63 in sqlite3VdbeRecordCompare (nKey1=18, pKey1=0x7f4114055c2f, pPKey2=pPKey2@entry=0x7fffd65e1d10) at sqlite3.c:64162
#9  0x00007f412b0e2579 in sqlite3BtreeMovetoUnpacked (pCur=0x5d2cc00, pIdxKey=0x7fffd65e1d10, intKey=0, biasRight=<optimized out>, pRes=0x7fffd65e1d00) at sqlite3.c:55077
#10 0x00007f412b10a9c5 in sqlite3VdbeExec (p=p@entry=0x55e2498) at sqlite3.c:70168
#11 0x00007f412b112ed7 in sqlite3Step (p=0x55e2498) at sqlite3.c:64828
#12 sqlite3_step (pStmt=<optimized out>) at sqlite3.c:64894
#13 0x00007f411990711c in QSQLiteResultPrivate::fetchNext (this=this@entry=0x55e2650, values=..., idx=idx@entry=0, initialFetch=initialFetch@entry=true) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:235
#14 0x00007f4119907e48 in QSQLiteResult::exec (this=0x635e7b0) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:447
#15 0x00007f4146785b7d in QSqlQuery::exec (this=this@entry=0x7fffd65e2248) at kernel/qsqlquery.cpp:949
#16 0x00007f4144192a26 in Digikam::DatabaseCoreBackend::exec (this=0x2bc6090, query=...) at /build/buildd/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1414
#17 0x00007f4144192aac in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x2bc6090, query=..., boundValue1=...) at /build/buildd/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1056
#18 0x00007f4144193b50 in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x2bc6090, sql=..., boundValue1=...) at /build/buildd/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1005
#19 0x00007f4144193b99 in Digikam::DatabaseCoreBackend::execSql (this=0x2bc6090, sql=..., boundValue1=..., values=values@entry=0x7fffd65e2290, lastInsertId=lastInsertId@entry=0x0) at /build/buildd/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:902
#20 0x00007f4143b5742e in Digikam::AlbumDB::getSetting (this=this@entry=0x2b438b0, keyword=...) at /build/buildd/digikam-3.5.0/core/libs/database/albumdb.cpp:972
#21 0x00007f4143b57d5c in Digikam::AlbumDB::getFilterSettings (this=0x2b438b0, imageFilter=imageFilter@entry=0x7fffd65e24c0, videoFilter=videoFilter@entry=0x0, audioFilter=audioFilter@entry=0x0) at /build/buildd/digikam-3.5.0/core/libs/database/albumdb.cpp:1017
#22 0x0000000000639fe6 in Digikam::AlbumSettings::getImageFileFilter (this=<optimized out>) at /build/buildd/digikam-3.5.0/core/digikam/utils/albumsettings.cpp:915
#23 0x0000000000612758 in Digikam::ImageViewUtilities::openInEditor (this=0x31c0950, info=..., allInfosToOpen=..., currentAlbum=currentAlbum@entry=0x46647d0) at /build/buildd/digikam-3.5.0/core/digikam/items/imageviewutilities.cpp:267
#24 0x000000000065ec76 in Digikam::DigikamView::slotEditor (this=0x3052f90) at /build/buildd/digikam-3.5.0/core/digikam/views/digikamview.cpp:1641
#25 0x0000000000662065 in Digikam::DigikamView::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/digikam-3.5.0/obj-x86_64-linux-gnu/core/digikam/digikamview.moc:324
#26 0x00007f414147687a in QMetaObject::activate (sender=sender@entry=0x3a8b260, m=m@entry=0x7f41428fede0 <QAction::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fffd65e2850) at kernel/qobject.cpp:3539
#27 0x00007f4141e4ea62 in QAction::triggered (this=this@entry=0x3a8b260, _t1=false) at .moc/release-shared/moc_qaction.cpp:276
#28 0x00007f4141e50433 in QAction::activate (this=0x3a8b260, event=<optimized out>) at kernel/qaction.cpp:1257
#29 0x00007f4142207b02 in QAbstractButtonPrivate::click (this=this@entry=0x31aa270) at widgets/qabstractbutton.cpp:530
#30 0x00007f4142207c2c in QAbstractButton::mouseReleaseEvent (this=0x31aa240, e=0x7fffd65e2d50) at widgets/qabstractbutton.cpp:1123
#31 0x00007f41422bea4a in QToolButton::mouseReleaseEvent (this=<optimized out>, e=<optimized out>) at widgets/qtoolbutton.cpp:723
#32 0x00007f4141ea450a in QWidget::event (this=0x31aa240, event=0x7fffd65e2d50) at kernel/qwidget.cpp:8376
#33 0x00007f4141e54e2c in QApplicationPrivate::notify_helper (this=this@entry=0x29bbcc0, receiver=receiver@entry=0x31aa240, e=e@entry=0x7fffd65e2d50) at kernel/qapplication.cpp:4567
#34 0x00007f4141e5b5dd in QApplication::notify (this=this@entry=0x7fffd65e39c0, receiver=receiver@entry=0x31aa240, e=e@entry=0x7fffd65e2d50) at kernel/qapplication.cpp:4110
#35 0x00007f4142b5fbaa in KApplication::notify (this=0x7fffd65e39c0, receiver=0x31aa240, event=0x7fffd65e2d50) at ../../kdeui/kernel/kapplication.cpp:311
#36 0x00007f41414624dd in QCoreApplication::notifyInternal (this=0x7fffd65e39c0, receiver=receiver@entry=0x31aa240, event=event@entry=0x7fffd65e2d50) at kernel/qcoreapplication.cpp:953
#37 0x00007f4141e5ad93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#38 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x31aa240, event=event@entry=0x7fffd65e2d50, alienWidget=alienWidget@entry=0x31aa240, nativeWidget=nativeWidget@entry=0x32079f0, buttonDown=buttonDown@entry=0x7f414293a318 <qt_button_down>, lastMouseReceiver=..., spontaneous=spontaneous@entry=true) at kernel/qapplication.cpp:3178
#39 0x00007f4141ecf9cb in QETWidget::translateMouseEvent (this=this@entry=0x32079f0, event=event@entry=0x7fffd65e30d0) at kernel/qapplication_x11.cpp:4634
#40 0x00007f4141ecf269 in QApplication::x11ProcessEvent (this=0x7fffd65e39c0, event=event@entry=0x7fffd65e30d0) at kernel/qapplication_x11.cpp:3627
#41 0x00007f4141ef6b02 in x11EventSourceDispatch (s=0x29bc2e0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#42 0x00007f4139028e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f4139029048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007f41390290ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f414148f7be in QEventDispatcherGlib::processEvents (this=0x28e91a0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#46 0x00007f4141ef6bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007f41414610af in QEventLoop::processEvents (this=this@entry=0x7fffd65e34a0, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007f41414613a5 in QEventLoop::exec (this=this@entry=0x7fffd65e34a0, flags=...) at kernel/qeventloop.cpp:204
#49 0x00007f4141466b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#50 0x00007f4141e5337c in QApplication::exec () at kernel/qapplication.cpp:3828
#51 0x0000000000492023 in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/digikam-3.5.0/core/digikam/main/main.cpp:235

Possible duplicates by query: bug 333642, bug 333389, bug 333243, bug 332100, bug 331220.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-04-21 06:00:10 UTC

*** This bug has been marked as a duplicate of bug 329697 ***
Comment 2 caulier.gilles 2021-12-17 11:51:00 UTC
Fixed with #329697