Bug 324528 - Kate
Summary: Kate
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 3.11.0
Platform: Mint (Ubuntu based) Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-05 03:31 UTC by konstantine16
Modified: 2013-09-05 08:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description konstantine16 2013-09-05 03:31:01 UTC
Application: kate (3.11.0)
KDE Platform Version: 4.11.00
Qt Version: 4.8.4
Operating System: Linux 3.8.0-25-generic x86_64
Distribution: Linux Mint 15 Olivia

-- Information about the crash:
- What I was doing when the application crashed: open in kate *.adr. 000.adr and *.adr. Me name is Konstantin.

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe9b72d57c0 (LWP 2870))]

Thread 2 (Thread 0x7fe9a37bd700 (LWP 2871)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fe9a4b46b27 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fe9a4b46b59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fe9b424cf8e in start_thread (arg=0x7fe9a37bd700) at pthread_create.c:311
#4  0x00007fe9b6c19e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fe9b72d57c0 (LWP 2870)):
[KCrash Handler]
#6  0x00007fe9a4a632be in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#7  0x00007fe9a4ae7f89 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#8  0x00007fe9a4ae874c in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#9  0x00007fe9a4b88ed0 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#10 0x00007fe9a4b89ec6 in QScriptEngine::QScriptEngine() () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#11 0x00007fe9a51afd9a in KateScript::load (this=0x2097d80) at ../../part/script/katescript.cpp:168
#12 0x00007fe9a51b06e9 in KateScript::clearExceptions (this=0x2097d80) at ../../part/script/katescript.cpp:130
#13 0x00007fe9a51b213c in KateCommandLineScript::actionInfo (this=this@entry=0x2097d80, cmd=...) at ../../part/script/katecommandlinescript.cpp:78
#14 0x00007fe9a51b7d21 in KateScriptActionMenu::repopulate (this=this@entry=0x230c020) at ../../part/script/katescriptaction.cpp:118
#15 0x00007fe9a51b846c in KateScriptActionMenu::KateScriptActionMenu (this=0x230c020, view=0x229d830, text=...) at ../../part/script/katescriptaction.cpp:74
#16 0x00007fe9a520b719 in KateView::setupActions (this=this@entry=0x229d830) at ../../part/view/kateview.cpp:376
#17 0x00007fe9a5213f77 in KateView::KateView (this=0x229d830, doc=0x20b3900, parent=<optimized out>) at ../../part/view/kateview.cpp:260
#18 0x00007fe9a518c909 in KateDocument::createView (this=this@entry=0x20b3900, parent=0x212b920) at ../../part/document/katedocument.cpp:292
#19 0x00007fe9b5776949 in createView (doc=0x20b3900, this=0x214fca0) at ../../../kate/app/kateviewmanager.cpp:404
#20 KateViewManager::createView (this=this@entry=0x214fca0, doc=<optimized out>) at ../../../kate/app/kateviewmanager.cpp:395
#21 0x00007fe9b577cfea in KateViewSpace::restoreConfig (this=0x2123930, viewMan=viewMan@entry=0x214fca0, config=config@entry=0x1e89250, groupname=...) at ../../../kate/app/kateviewspace.cpp:266
#22 0x00007fe9b577844c in KateViewManager::restoreSplitter (this=this@entry=0x214fca0, configBase=0x1e89250, group=..., parent=parent@entry=0x214fca0, viewConfGrp=...) at ../../../kate/app/kateviewmanager.cpp:994
#23 0x00007fe9b5778db8 in KateViewManager::restoreViewConfiguration (this=0x214fca0, config=...) at ../../../kate/app/kateviewmanager.cpp:875
#24 0x00007fe9b576e7a6 in KateMainWindow::KateMainWindow (this=0x20dc600, sconfig=0x1e89250, sgroup=..., __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../kate/app/katemainwindow.cpp:192
#25 0x00007fe9b575ed84 in KateApp::newMainWindow (this=<optimized out>, sconfig_=sconfig_@entry=0x1e89250, sgroup_=...) at ../../../kate/app/kateapp.cpp:390
#26 0x00007fe9b57834b0 in KateSessionManager::activateSession (this=0x20bff70, session=..., closeLast=closeLast@entry=false, saveLast=saveLast@entry=false, loadNew=loadNew@entry=true) at ../../../kate/app/katesession.cpp:339
#27 0x00007fe9b5760088 in KateApp::startupKate (this=0x7ffff6080460) at ../../../kate/app/kateapp.cpp:194
#28 0x00007fe9b5760b15 in KateApp::initKate (this=this@entry=0x7ffff6080460) at ../../../kate/app/kateapp.cpp:135
#29 0x00007fe9b5760d30 in KateApp::KateApp (this=0x7ffff6080460, args=<optimized out>) at ../../../kate/app/kateapp.cpp:72
#30 0x00007fe9b6eed7b8 in kdemain (argc=3, argv=<optimized out>) at ../../../kate/app/katemain.cpp:376
#31 0x00007fe9b6b41ea5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=3, ubp_av=0x7ffff60805e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff60805d8) at libc-start.c:260
#32 0x0000000000400701 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 305718.

Possible duplicates by query: bug 307640, bug 307461, bug 307227, bug 307166.

Reported using DrKonqi
Comment 1 Dominik Haumann 2013-09-05 08:27:48 UTC

*** This bug has been marked as a duplicate of bug 305718 ***