Bug 307166 - Kate crash every time I open it
Summary: Kate crash every time I open it
Status: RESOLVED DUPLICATE of bug 305718
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-21 15:48 UTC by Andrea
Modified: 2012-09-21 15:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrea 2012-09-21 15:48:56 UTC
Application: kate (3.9.1)
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.3
Operating System: Linux 3.1.10-1.9-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
After upgrade libqt4 to 4.8.3-265.1 from kde 4.9 repository kate (and kwrite) can not be opened.

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0d38aba760 (LWP 15934))]

Thread 2 (Thread 0x7f0d27429700 (LWP 15935)):
#0  0x00007f0d35c10e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0d28120772 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f0d28419e80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f0d281207a9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f0d35c0cf05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0d3841e10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f0d38aba760 (LWP 15934)):
[KCrash Handler]
#6  0x00007f0d383cb651 in __memcpy_sse2 () from /lib64/libc.so.6
#7  0x00007f0d2805a179 in executableCopy (allocator=0x7f0d26b30960, this=<optimized out>) at /usr/include/bits/string3.h:52
#8  executableCopy (this=0x7fff38f6c1a0, allocator=0x7f0d26b30960) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1885
#9  executableCopy (allocator=0x7f0d26b30960, this=0x7fff38f6c1a0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/X86Assembler.h:1583
#10 LinkBuffer (executablePool=..., masm=0x7fff38f6c1a0, this=0x7fff38f6c0c0) at ../3rdparty/javascriptcore/JavaScriptCore/assembler/LinkBuffer.h:67
#11 QTJSC::JIT::privateCompileCTIMachineTrampolines (this=0x7fff38f6c1a0, executablePool=0x7f0d26b2a9e8, globalData=<optimized out>, ctiStringLengthTrampoline=0x7f0d26b2a9f0, ctiVirtualCallLink=0x7f0d26b2a9f8, ctiVirtualCall=0x7f0d26b2aa00, ctiNativeCallThunk=0x7f0d26b2aa08) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITOpcodes.cpp:1817
#12 0x00007f0d28079e8c in QTJSC::JIT::compileCTIMachineTrampolines (globalData=0x7f0d26b29800, executablePool=0x7f0d26b2a9e8, ctiStringLengthTrampoline=0x7f0d26b2a9f0, ctiVirtualCallLink=0x7f0d26b2a9f8, ctiVirtualCall=0x7f0d26b2aa00, ctiNativeCallThunk=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JIT.h:323
#13 0x00007f0d280778ba in QTJSC::JITThunks::JITThunks (this=0x7f0d26b2a9e8, globalData=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:768
#14 0x00007f0d280c59bd in QTJSC::JSGlobalData::JSGlobalData (this=0x7f0d26b29800, isShared=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:146
#15 0x00007f0d280c604c in QTJSC::JSGlobalData::create () at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:205
#16 0x00007f0d28162eb7 in QScriptEnginePrivate::QScriptEnginePrivate (this=0xb1c940) at api/qscriptengine.cpp:979
#17 0x00007f0d28163df6 in QScriptEngine::QScriptEngine (this=0xb1c920) at api/qscriptengine.cpp:1964
#18 0x00007f0d2878d273 in load (this=0x94c220) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:247
#19 KateScript::load (this=0x94c220) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:230
#20 0x00007f0d2878d619 in KateScript::clearExceptions (this=0x94c220) at /usr/src/debug/kate-4.9.1/part/script/katescript.cpp:157
#21 0x00007f0d2878f2e2 in KateCommandLineScript::actionInfo (this=0x94c220, cmd=...) at /usr/src/debug/kate-4.9.1/part/script/katecommandlinescript.cpp:78
#22 0x00007f0d28794e4b in KateScriptActionMenu::repopulate (this=0xb1c150) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:118
#23 0x00007f0d2879550b in KateScriptActionMenu::KateScriptActionMenu (this=0xb1c150, view=0xa20350, text=...) at /usr/src/debug/kate-4.9.1/part/script/katescriptaction.cpp:74
#24 0x00007f0d287f9acb in KateView::setupActions (this=0xa20350) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:350
#25 0x00007f0d287fddd3 in KateView::KateView (this=0xa20350, doc=0x781e90, parent=<optimized out>) at /usr/src/debug/kate-4.9.1/part/view/kateview.cpp:240
#26 0x00007f0d28761094 in KateDocument::createView (this=0x781e90, parent=0x9ac370) at /usr/src/debug/kate-4.9.1/part/document/katedocument.cpp:335
#27 0x00007f0d36f4902a in createView (doc=<optimized out>, this=0x9a31b0) at /usr/src/debug/kate-4.9.1/kate/app/kateviewmanager.cpp:391
#28 KateViewManager::createView (this=0x9a31b0, doc=<optimized out>) at /usr/src/debug/kate-4.9.1/kate/app/kateviewmanager.cpp:382
#29 0x00007f0d36f4dfca in KateViewSpace::restoreConfig (this=0x9e50e0, viewMan=0x9a31b0, config=0x6dda40, groupname=...) at /usr/src/debug/kate-4.9.1/kate/app/kateviewspace.cpp:266
#30 0x00007f0d36f4b6f4 in KateViewManager::restoreSplitter (this=0x9a31b0, configBase=0x6dda40, group=<optimized out>, parent=0x9a31b0, viewConfGrp=...) at /usr/src/debug/kate-4.9.1/kate/app/kateviewmanager.cpp:939
#31 0x00007f0d36f4c13c in KateViewManager::restoreViewConfiguration (this=0x9a31b0, config=...) at /usr/src/debug/kate-4.9.1/kate/app/kateviewmanager.cpp:820
#32 0x00007f0d36f40910 in KateMainWindow::KateMainWindow (this=0x991780, sconfig=0x6dda40, sgroup=..., __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/kate-4.9.1/kate/app/katemainwindow.cpp:195
#33 0x00007f0d36f310d4 in KateApp::newMainWindow (this=<optimized out>, sconfig_=<optimized out>, sgroup_=<optimized out>) at /usr/src/debug/kate-4.9.1/kate/app/kateapp.cpp:390
#34 0x00007f0d36f59a63 in KateSessionManager::activateSession (this=0x97d610, session=<optimized out>, closeLast=<optimized out>, saveLast=<optimized out>, loadNew=true) at /usr/src/debug/kate-4.9.1/kate/app/katesession.cpp:338
#35 0x00007f0d36f5aa59 in KateSessionManager::chooseSession (this=0x97d610) at /usr/src/debug/kate-4.9.1/kate/app/katesession.cpp:446
#36 0x00007f0d36f32b65 in KateApp::startupKate (this=0x7fff38f6f3a0) at /usr/src/debug/kate-4.9.1/kate/app/kateapp.cpp:182
#37 0x00007f0d36f32f15 in KateApp::initKate (this=0x7fff38f6f3a0) at /usr/src/debug/kate-4.9.1/kate/app/kateapp.cpp:135
#38 0x00007f0d36f33132 in KateApp::KateApp (this=0x7fff38f6f3a0, args=<optimized out>) at /usr/src/debug/kate-4.9.1/kate/app/kateapp.cpp:72
#39 0x00007f0d386d9006 in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kate-4.9.1/kate/app/katemain.cpp:373
#40 0x00007f0d3836423d in __libc_start_main () from /lib64/libc.so.6
#41 0x0000000000400681 in _start () at ../sysdeps/x86_64/elf/start.S:113

Reported using DrKonqi
Comment 1 Christoph Feck 2012-09-21 15:57:53 UTC

*** This bug has been marked as a duplicate of bug 305718 ***